aboutsummaryrefslogtreecommitdiff
path: root/math/gnuplot
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2017-12-13 07:11:07 +0000
committerGreg Lewis <glewis@FreeBSD.org>2017-12-13 07:11:07 +0000
commit926d6221f6f33adba9022ef46784b458fc414b64 (patch)
treecb45572d7599ad00cae238671f36024090242036 /math/gnuplot
parent19d334c6343fa6622fa7f31985e73aeb5b90288f (diff)
downloadports-926d6221f6f33adba9022ef46784b458fc414b64.tar.gz
ports-926d6221f6f33adba9022ef46784b458fc414b64.zip
Prepare for gnuplot-lite by splitting up the configure options, the
dependencies and adding some packing list substitution and hiding some of it based on the definition of "LITE".
Notes
Notes: svn path=/head/; revision=456192
Diffstat (limited to 'math/gnuplot')
-rw-r--r--math/gnuplot/Makefile47
-rw-r--r--math/gnuplot/pkg-plist4
2 files changed, 38 insertions, 13 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index 695cbe1a8e8b..36fd98da59d1 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -6,14 +6,43 @@ CATEGORIES= math graphics
MASTER_SITES= SF
MAINTAINER= glewis@FreeBSD.org
-COMMENT= Command-line driven graphing utility
+COMMENT?= Command-line driven graphing utility
LICENSE= Gnuplot
LICENSE_NAME= Gnuplot license
LICENSE_FILE= ${WRKSRC}/Copyright
LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
-USES+= groff iconv jpeg lua:53 pkgconfig readline
+CONFLICTS_INSTALL?= gnuplot-lite-[0-9]*
+
+USES+= groff iconv pkgconfig readline
+GNU_CONFIGURE= yes
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
+CONFIGURE_ARGS+=--with-readline=gnu \
+ --without-linux-vga \
+ --without-lisp-files \
+ --without-tutorial \
+ --with-qt=no
+
+.if defined(LITE)
+CONFIGURE_ARGS+=--disable-x11-mbfonts \
+ --disable-x11-external \
+ --disable-wxwidgets \
+ --without-x \
+ --without-ggi \
+ --without-gd \
+ --without-caca \
+ --without-wx \
+ --without-bitmap-terminals \
+ --without-gpic \
+ --without-mif \
+ --without-cairo \
+ --without-lua \
+ --without-latex \
+ --without-kpsexpand
+PLIST_SUB+= X11="@comment "
+.else
+USES+= jpeg lua:53
USE_TEX= kpathsea
USE_GNOME+= atk cairo gtk20 gdkpixbuf2
USE_WX= 2.8
@@ -23,23 +52,19 @@ LIB_DEPENDS+= libfontconfig.so:x11-fonts/fontconfig \
libgd.so:graphics/gd \
libpng.so:graphics/png \
libtiff.so:graphics/tiff
-GNU_CONFIGURE= yes
-LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
-CONFIGURE_ARGS+=--with-readline=gnu \
- --with-kpsexpand \
- --without-linux-vga \
- --without-lisp-files \
- --without-tutorial \
- --with-bitmap-terminals \
+CONFIGURE_ARGS+=--with-bitmap-terminals \
--with-gd=${LOCALBASE} \
--with-gpic \
--with-mif \
+ --with-kpsexpand \
--with-latex \
- --with-qt=no \
ac_cv_prog_KPSEXPAND=${LOCALBASE}/bin/kpsexpand \
ac_cv_prog_PLAINTEX=${LOCALBASE}/bin/tex \
ac_cv_prog_LATEX=${LOCALBASE}/bin/latex \
ac_cv_prog_PDFLATEX=${LOCALBASE}/bin/pdflatex
+PLIST_SUB+= X11=""
+.endif
+
TEST_TARGET= check
PORTDOCS= *
PORTEXAMPLES= *
diff --git a/math/gnuplot/pkg-plist b/math/gnuplot/pkg-plist
index 260c83e124d9..e58d3fae79f1 100644
--- a/math/gnuplot/pkg-plist
+++ b/math/gnuplot/pkg-plist
@@ -1,4 +1,4 @@
-bin/gnuplot
+%%X11%%bin/gnuplot
libexec/gnuplot/5.2/gnuplot_x11
man/man1/gnuplot-ja.1.gz
man/man1/gnuplot.1.gz
@@ -17,7 +17,7 @@ man/man1/gnuplot.1.gz
%%DATADIR%%/5.2/PostScript/koi8u.ps
%%DATADIR%%/5.2/PostScript/prologue.ps
%%DATADIR%%/5.2/PostScript/utf-8.ps
-%%DATADIR%%/5.2/app-defaults/Gnuplot
+%%X11%%%%DATADIR%%/5.2/app-defaults/Gnuplot
%%DATADIR%%/5.2/colors_default.gp
%%DATADIR%%/5.2/colors_mono.gp
%%DATADIR%%/5.2/colors_podo.gp