aboutsummaryrefslogtreecommitdiff
path: root/math/gp2c
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2020-03-28 18:37:49 +0000
committerThierry Thomas <thierry@FreeBSD.org>2020-03-28 18:37:49 +0000
commitf6ab14221bf864af3c7507557d64e6f193eda63e (patch)
tree4e01aa5a2531e3cc01c728b23c351483c0c1f3ba /math/gp2c
parentb3afbee9a838d6f6d40cb0d0d75886ae6f828cf5 (diff)
downloadports-f6ab14221bf864af3c7507557d64e6f193eda63e.tar.gz
ports-f6ab14221bf864af3c7507557d64e6f193eda63e.zip
Notes
Diffstat (limited to 'math/gp2c')
-rw-r--r--math/gp2c/Makefile24
-rw-r--r--math/gp2c/distinfo3
-rw-r--r--math/gp2c/pkg-descr9
-rw-r--r--math/gp2c/pkg-plist13
4 files changed, 49 insertions, 0 deletions
diff --git a/math/gp2c/Makefile b/math/gp2c/Makefile
new file mode 100644
index 000000000000..81b283c7eeeb
--- /dev/null
+++ b/math/gp2c/Makefile
@@ -0,0 +1,24 @@
+# Created by: thierry@pompo.net
+# $FreeBSD$
+
+PORTNAME= gp2c
+DISTVERSION= 0.0.11pl3
+CATEGORIES= math
+MASTER_SITES= http://pari.math.u-bordeaux.fr/pub/pari/GP2C/
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Package for translating GP routines into C
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libpari.so:math/pari
+
+USES= perl5
+
+OPTIONS_DEFINE= DOCS
+
+GNU_CONFIGURE= yes
+
+TEST_TARGET= check
+
+.include <bsd.port.mk>
diff --git a/math/gp2c/distinfo b/math/gp2c/distinfo
new file mode 100644
index 000000000000..1702f6d0c796
--- /dev/null
+++ b/math/gp2c/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1585404007
+SHA256 (gp2c-0.0.11pl3.tar.gz) = 35c33cd1529ee5d7a9494cf0a47362a7315d2da945cefa3004a070e95f5ed57b
+SIZE (gp2c-0.0.11pl3.tar.gz) = 854003
diff --git a/math/gp2c/pkg-descr b/math/gp2c/pkg-descr
new file mode 100644
index 000000000000..ffa585d592c0
--- /dev/null
+++ b/math/gp2c/pkg-descr
@@ -0,0 +1,9 @@
+The gp2c compiler is a package for translating GP routines into the C
+programming language, so that they can be compiled and used with the PARI system
+or the GP calculator.
+
+The main advantage of doing this is to speed up computations and to include your
+own routines within the preexisting GP ones. It may also find bugs in GP
+scripts.
+
+WWW: https://pari.math.u-bordeaux.fr/pub/pari/manuals/gp2c/gp2c.html
diff --git a/math/gp2c/pkg-plist b/math/gp2c/pkg-plist
new file mode 100644
index 000000000000..4e6f7e641f10
--- /dev/null
+++ b/math/gp2c/pkg-plist
@@ -0,0 +1,13 @@
+bin/gp2c
+bin/gp2c-run
+man/man1/gp2c-run.1.gz
+man/man1/gp2c.1.gz
+%%PORTDOCS%%%%DOCSDIR%%/gp2c.dvi
+%%PORTDOCS%%%%DOCSDIR%%/gp2c.html
+%%PORTDOCS%%%%DOCSDIR%%/gp2c.pdf
+%%PORTDOCS%%%%DOCSDIR%%/gp2c001.png
+%%PORTDOCS%%%%DOCSDIR%%/type.dvi
+%%PORTDOCS%%%%DOCSDIR%%/type.html
+%%PORTDOCS%%%%DOCSDIR%%/type.pdf
+%%PORTDOCS%%%%DOCSDIR%%/type001.png
+%%DATADIR%%/func.dsc