aboutsummaryrefslogtreecommitdiff
path: root/math/grace
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2012-12-08 06:13:55 +0000
committerBeech Rintoul <beech@FreeBSD.org>2012-12-08 06:13:55 +0000
commit45fbdb6153f5207b4949d83e5240ab8ae330aad0 (patch)
treed763ea5a15a43fc47b7fc22baa911bdbf43fb6fe /math/grace
parent6a432a3c7f991c3a36cad136eae58661921c2f5a (diff)
downloadports-45fbdb6153f5207b4949d83e5240ab8ae330aad0.tar.gz
ports-45fbdb6153f5207b4949d83e5240ab8ae330aad0.zip
- Update MASTER_SITES
- Fix LIB_DEPENDS - Add option for XmHTML support Feature safe: yes PR: ports/174177 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=308462
Diffstat (limited to 'math/grace')
-rw-r--r--math/grace/Makefile26
1 files changed, 16 insertions, 10 deletions
diff --git a/math/grace/Makefile b/math/grace/Makefile
index 4d9715cda628..28e58780ebf1 100644
--- a/math/grace/Makefile
+++ b/math/grace/Makefile
@@ -5,11 +5,10 @@ PORTNAME= grace
PORTVERSION= 5.1.23
PORTREVISION= 1
CATEGORIES= math print
-#
-MASTER_SITES= ftp://plasma-gate.weizmann.ac.il/pub/grace/src/stable/ \
- ftp://ftp.fu-berlin.de/unix/graphics/grace/src/stable/ \
+MASTER_SITES= ftp://ftp.fu-berlin.de/unix/graphics/grace/src/stable/ \
ftp://ftp.ntua.gr/pub/graphics/grace/src/stable/ \
- ftp://ftp.u-aizu.ac.jp/pub/SciEng/math/grace/src/stable/
+ ftp://ftp.u-aizu.ac.jp/pub/SciEng/math/grace/src/stable/ \
+ ftp://plasma-gate.weizmann.ac.il/pub/grace/src/stable/
MAINTAINER= ports@FreeBSD.org
COMMENT= Powerful 2D plotting tool (successor of xmgr)
@@ -19,10 +18,14 @@ LICENSE= GPLv2
LIB_DEPENDS= t1:${PORTSDIR}/devel/t1lib \
jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
- Xbae:${PORTSDIR}/x11-toolkits/xbae \
- XmHTML:${PORTSDIR}/x11-toolkits/xmhtml
+ Xbae:${PORTSDIR}/x11-toolkits/xbae
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
+OPTIONS_DEFINE= FFTW NETCDF PDF XMHTML DOCS EXAMPLES
+OPTIONS_DEFAULT=FFTW NETCDF PDF XMHTML
+PDF_DESC= PDF output
+XMHTML_DESC= Use XmHTML widget for on-line help
+
USE_MOTIF= yes
USE_GCC= any
USE_GMAKE= yes
@@ -39,10 +42,6 @@ MAN1= convcal.1 grace.1 grconvert.1
MLINKS= grace.1 gracebat.1 \
grace.1 xmgrace.1
-OPTIONS_DEFINE= FFTW NETCDF PDF DOCS EXAMPLES
-OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
-PDF_DESC= PDF output
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MFFTW}
@@ -66,6 +65,13 @@ CONFIGURE_ARGS+= --enable-pdfdrv
CONFIGURE_ARGS+= --disable-pdfdrv
.endif
+.if ${PORT_OPTIONS:MXMHTML}
+LIB_DEPENDS+= XmHTML:${PORTSDIR}/x11-toolkits/xmhtml
+CONFIGURE_ARGS+= --enable-xmhtml
+.else
+CONFIGURE_ARGS+= --disable-xmhtml
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/xmgrace ${PREFIX}/bin
@${LN} -sf xmgrace ${PREFIX}/bin/grace