aboutsummaryrefslogtreecommitdiff
path: root/math/grace
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-11-08 22:57:13 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-11-08 22:57:13 +0000
commit6a838e50a72a940403d32f405252053beaf6912e (patch)
treedd45fa1c09fa2029774e955b2be29630908b1d03 /math/grace
parent5c46e5fe2b8926f8e67d1cc1a2b11d6b883d8363 (diff)
downloadports-6a838e50a72a940403d32f405252053beaf6912e.tar.gz
ports-6a838e50a72a940403d32f405252053beaf6912e.zip
- Update to version 5.1.23 [1]
- Reformat description [1] - Trim Makefile header [1] - Add options: FFTW NETCDF PDF [2] PR: ports/172723 [1], based on ports/166117 [2] Submitted by: KATO Tsuguru <tkato432 at yahoo.com> [1], Momchil Ivanov <momchil at xaxo.eu> [2] Feature safe: yes
Notes
Notes: svn path=/head/; revision=307216
Diffstat (limited to 'math/grace')
-rw-r--r--math/grace/Makefile60
-rw-r--r--math/grace/distinfo4
-rw-r--r--math/grace/files/patch-src-motifutils.c39
-rw-r--r--math/grace/files/patch-src-rstdrv.c19
-rw-r--r--math/grace/pkg-descr14
5 files changed, 51 insertions, 85 deletions
diff --git a/math/grace/Makefile b/math/grace/Makefile
index 5b6a586e5b43..d7e1c6fe0e70 100644
--- a/math/grace/Makefile
+++ b/math/grace/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: grace
-# Date created: Dec 28 1998
-# Whom: Lars Köller <Lars.Koeller@Uni-Bielefeld.de>
-#
+# Created by: Lars Köller <Lars.Koeller@Uni-Bielefeld.de>
# $FreeBSD$
-#
PORTNAME= grace
-PORTVERSION= 5.1.22
-PORTREVISION= 8
+PORTVERSION= 5.1.23
CATEGORIES= math print
#
MASTER_SITES= ftp://plasma-gate.weizmann.ac.il/pub/grace/src/stable/ \
@@ -18,17 +13,16 @@ MASTER_SITES= ftp://plasma-gate.weizmann.ac.il/pub/grace/src/stable/ \
ftp://linux.mathematik.tu-darmstadt.de/pub/linux/mirrors/misc/grace/src/stable/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A powerful plotting tool (successor of xmgr)
+COMMENT= Powerful 2D plotting tool (successor of xmgr)
+
+LICENSE= GPLv2
-LIB_DEPENDS= t1:${PORTSDIR}/devel/t1lib \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- fftw.2:${PORTSDIR}/math/fftw \
- pdf.6:${PORTSDIR}/print/pdflib \
- netcdf.4:${PORTSDIR}/science/netcdf \
- Xbae.4:${PORTSDIR}/x11-toolkits/xbae \
- XmHTML.1:${PORTSDIR}/x11-toolkits/xmhtml
+LIB_DEPENDS= t1:${PORTSDIR}/devel/t1lib \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ png15:${PORTSDIR}/graphics/png \
+ tiff:${PORTSDIR}/graphics/tiff \
+ Xbae:${PORTSDIR}/x11-toolkits/xbae \
+ XmHTML:${PORTSDIR}/x11-toolkits/xmhtml
USE_MOTIF= yes
USE_GCC= any
@@ -39,11 +33,39 @@ CONFIGURE_ARGS= --enable-grace-home=${DATADIR} \
--with-extra-ldpath=${LOCALBASE}/lib \
--without-bundled-xbae
ALL_TARGET= # empty
+MAKE_JOBS_SAFE= yes
MAN1= convcal.1 grace.1 grconvert.1
MLINKS= grace.1 gracebat.1 \
grace.1 xmgrace.1
+OPTIONS_DEFINE= FFTW NETCDF PDF DOCS EXAMPLES
+OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
+PDF_DESC= PDF output
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MFFTW}
+LIB_DEPENDS+= fftw:${PORTSDIR}/math/fftw
+CONFIGURE_ARGS+= --with-fftw
+.else
+CONFIGURE_ARGS+= --without-fftw
+.endif
+
+.if ${PORT_OPTIONS:MNETCDF}
+LIB_DEPENDS+= netcdf:${PORTSDIR}/science/netcdf
+CONFIGURE_ARGS+= --enable-netcdf
+.else
+CONFIGURE_ARGS+= --disable-netcdf
+.endif
+
+.if ${PORT_OPTIONS:MPDF}
+LIB_DEPENDS+= pdf:${PORTSDIR}/print/pdflib
+CONFIGURE_ARGS+= --enable-pdfdrv
+.else
+CONFIGURE_ARGS+= --disable-pdfdrv
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/xmgrace ${PREFIX}/bin
@${LN} -sf xmgrace ${PREFIX}/bin/grace
@@ -70,7 +92,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/fonts/type1/*.pfb ${DATADIR}/fonts/type1
@${MKDIR} ${DATADIR}/templates
${INSTALL_DATA} ${WRKSRC}/templates/*.agr ${DATADIR}/templates
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${TAR} -C ${WRKSRC}/doc --exclude "*Makefile*" --exclude "*.1" \
-cf - . | ${TAR} -C ${DOCSDIR} --unlink -xf -
@@ -78,7 +100,7 @@ do-install:
@${FIND} ${DOCSDIR} -type f -exec ${CHMOD} ${SHAREMODE} {} \;
@${LN} -sf ${DOCSDIR} ${DATADIR}/doc
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@${TAR} -C ${WRKSRC}/examples --exclude "*Makefile*" \
-cf - . | ${TAR} -C ${EXAMPLESDIR} --unlink -xf -
diff --git a/math/grace/distinfo b/math/grace/distinfo
index 8ac9862f2542..f7bf84502ee9 100644
--- a/math/grace/distinfo
+++ b/math/grace/distinfo
@@ -1,2 +1,2 @@
-SHA256 (grace-5.1.22.tar.gz) = 4ce8f058b6c1267a842419a3edbf471421dea9cf5744783745b6cb375cdf5f25
-SIZE (grace-5.1.22.tar.gz) = 2516576
+SHA256 (grace-5.1.23.tar.gz) = 69527950fd9c056a76b7a6bf4ac37a9b87acc565c12a941ffae3c9c5a822ca10
+SIZE (grace-5.1.23.tar.gz) = 2501364
diff --git a/math/grace/files/patch-src-motifutils.c b/math/grace/files/patch-src-motifutils.c
deleted file mode 100644
index 3e765ae3380e..000000000000
--- a/math/grace/files/patch-src-motifutils.c
+++ /dev/null
@@ -1,39 +0,0 @@
-
---- src/motifutils.c.orig 2010-03-15 20:05:12.742336241 -0700
-+++ src/motifutils.c 2010-03-15 20:12:53.885346709 -0700
-@@ -118,7 +118,6 @@
-
- extern unsigned long xvlibcolors[];
-
--
- static OptionItem *color_option_items = NULL;
- static int ncolor_option_items = 0;
- static OptionStructure **color_selectors = NULL;
-@@ -1621,6 +1620,12 @@
- graph_popup_menu = xmalloc(sizeof(GraphPopupMenu));
-
- popup = XmCreatePopupMenu(listp->list, "graphPopupMenu", NULL, 0);
-+#if XmVersion >= 2000
-+ XtVaSetValues(popup, XmNpopupEnabled, XmPOPUP_DISABLED, NULL);
-+ XtUngrabButton(listp->list, AnyButton, AnyModifier);
-+#else
-+ XtVaSetValues(popup, XmNpopupEnabled, False, NULL);
-+#endif
- graph_popup_menu->popup = popup;
-
- graph_popup_menu->label_item = CreateMenuLabel(popup, "Selection:");
-@@ -2243,6 +2248,12 @@
-
- set_popup_menu = xmalloc(sizeof(SetPopupMenu));
- popup = XmCreatePopupMenu(listp->list, "setPopupMenu", NULL, 0);
-+#if XmVersion >= 2000
-+ XtVaSetValues(popup, XmNpopupEnabled, XmPOPUP_DISABLED, NULL);
-+ XtUngrabButton(listp->list, AnyButton, AnyModifier);
-+#else
-+ XtVaSetValues(popup, XmNpopupEnabled, False, NULL);
-+#endif
- set_popup_menu->popup = popup;
-
- set_popup_menu->label_item = CreateMenuLabel(popup, "Selection:");
-
-
diff --git a/math/grace/files/patch-src-rstdrv.c b/math/grace/files/patch-src-rstdrv.c
deleted file mode 100644
index c48c18824399..000000000000
--- a/math/grace/files/patch-src-rstdrv.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/rstdrv.c.orig 2004-07-03 22:47:46.000000000 +0200
-+++ src/rstdrv.c 2012-04-27 20:54:10.000000000 +0200
-@@ -54,6 +54,7 @@
-
- #ifdef HAVE_LIBPNG
- # include <png.h>
-+# include <zlib.h>
- #endif
-
- #ifndef NONE_GUI
-@@ -885,7 +886,7 @@
- return;
- }
-
-- if (setjmp(png_ptr->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png_ptr))) {
- png_destroy_write_struct(&png_ptr, &info_ptr);
- return;
- }
diff --git a/math/grace/pkg-descr b/math/grace/pkg-descr
index 482febba1e8d..2caf38078ddb 100644
--- a/math/grace/pkg-descr
+++ b/math/grace/pkg-descr
@@ -1,16 +1,18 @@
Grace is a WYSIWYG 2D plotting tool for the X Window System and M*tif,
successor of ACE/gr (Xmgr). A few of its features are:
- * User defined scaling, tick marks, labels, symbols, line styles, colors.
+ * User defined scaling, tick marks, labels, symbols, line styles,
+ colors.
* Batch mode for unattended plotting.
* Read and write parameters used during a session.
* Polynomial regression, splines, running averages, DFT/FFT,
cross/auto-correlation.
- * Exports high-resolution graphics to (E)PS, PDF, MIF, and SVG formats
+ * Exports high-resolution graphics to (E)PS, PDF, MIF, and SVG
+ formats
* Supports cross-platform PNM, JPEG and PNG formats
-While grace has a convenient point-and-click interface, most parameter settings
-and operations are available through a command line interface (found in
-Data/Commands).
+While grace has a convenient point-and-click interface, most parameter
+settings and operations are available through a command line interface
+(found in Data/Commands).
-WWW: http://plasma-gate.weizmann.ac.il/Grace/
+WWW: http://plasma-gate.weizmann.ac.il/Grace/