aboutsummaryrefslogtreecommitdiff
path: root/math/graphthing
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-25 21:49:44 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-25 21:49:44 +0000
commitb7936593e0636adeafe81a8e134167452ae02091 (patch)
treea52141e76029de21405e284add1c230f850c8db7 /math/graphthing
parent20687bc303083c2807ddba53c54c769ed4213b15 (diff)
downloadports-b7936593e0636adeafe81a8e134167452ae02091.tar.gz
ports-b7936593e0636adeafe81a8e134167452ae02091.zip
- Fix build on gcc-3.4
PR: ports/78017 Submitted by: Johan van Selst <johans@stack.nl>
Notes
Notes: svn path=/head/; revision=129806
Diffstat (limited to 'math/graphthing')
-rw-r--r--math/graphthing/Makefile8
-rw-r--r--math/graphthing/files/patch-src-gui.h18
2 files changed, 19 insertions, 7 deletions
diff --git a/math/graphthing/Makefile b/math/graphthing/Makefile
index 7307978a352e..238659063acf 100644
--- a/math/graphthing/Makefile
+++ b/math/graphthing/Makefile
@@ -25,14 +25,8 @@ GNU_CONFIGURE= yes
PLIST_FILES= bin/graphthing bin/gt
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Configure fails on FreeBSD >= 5.x"
-.endif
-
post-patch:
${REINPLACE_CMD} -e "s,\/usr\/include\/gtk-1.2\/gdk\/gdkkeysyms.h,," \
${WRKSRC}/src/depend.1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/graphthing/files/patch-src-gui.h b/math/graphthing/files/patch-src-gui.h
new file mode 100644
index 000000000000..8018b28a56d3
--- /dev/null
+++ b/math/graphthing/files/patch-src-gui.h
@@ -0,0 +1,18 @@
+--- src/gui.h.orig Thu Feb 24 14:11:10 2005
++++ src/gui.h Thu Feb 24 14:11:12 2005
+@@ -140,7 +140,6 @@ public:
+ class ParamDialog : public Gtk::Dialog
+ {
+ protected:
+- void ok_click ();
+
+ virtual int delete_event_impl (GdkEventAny *ev);
+ virtual void get_data () = 0;
+@@ -148,6 +147,7 @@ protected:
+ public:
+ bool cancelled;
+
++ void ok_click ();
+ ParamDialog (const String &title = "Prefab Parameter");
+ };
+