aboutsummaryrefslogtreecommitdiff
path: root/math/graphthing
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2012-02-21 13:16:58 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2012-02-21 13:16:58 +0000
commitf643369b0c29c609f3b43cb202fe2e98d342f4bf (patch)
tree4d86113f5b7cdde4c20180f91dcbe18bb9324546 /math/graphthing
parent6ca710cb278142265b48141e7f9f4f90a335e20a (diff)
downloadports-f643369b0c29c609f3b43cb202fe2e98d342f4bf.tar.gz
ports-f643369b0c29c609f3b43cb202fe2e98d342f4bf.zip
Fix build errors with latest bison
Notes
Notes: svn path=/head/; revision=291993
Diffstat (limited to 'math/graphthing')
-rw-r--r--math/graphthing/Makefile2
-rw-r--r--math/graphthing/files/patch-src-gt-bison.y20
-rw-r--r--math/graphthing/files/patch-src-lang-bison.y20
3 files changed, 40 insertions, 2 deletions
diff --git a/math/graphthing/Makefile b/math/graphthing/Makefile
index bebf22772552..39c49a084b9c 100644
--- a/math/graphthing/Makefile
+++ b/math/graphthing/Makefile
@@ -18,8 +18,6 @@ COMMENT= A tool that allows you to create, manipulate and study graphs
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= does not compile
-
USE_BZIP2= yes
USE_GNOME= gtk20
USE_BISON= build
diff --git a/math/graphthing/files/patch-src-gt-bison.y b/math/graphthing/files/patch-src-gt-bison.y
new file mode 100644
index 000000000000..550cdfa89f46
--- /dev/null
+++ b/math/graphthing/files/patch-src-gt-bison.y
@@ -0,0 +1,20 @@
+--- src/gt-bison.y.orig 2012-02-21 14:11:30.000000000 +0100
++++ src/gt-bison.y 2012-02-21 14:11:53.000000000 +0100
+@@ -18,7 +18,7 @@
+
+ extern char *yy_gt_text;
+
+-int yy_gt_error (char *s);
++int yy_gt_error (const char *s);
+ int yy_gt_lex (void);
+ %}
+
+@@ -132,7 +132,7 @@
+
+ %%
+
+-int yy_gt_error (char *s)
++int yy_gt_error (const char *s)
+ {
+ fprintf (stderr, "gt-parse: %s in line %i, at symbol \"%s\"\n",
+ s, gt_lineno, yy_gt_text);
diff --git a/math/graphthing/files/patch-src-lang-bison.y b/math/graphthing/files/patch-src-lang-bison.y
new file mode 100644
index 000000000000..6a82bc7268b4
--- /dev/null
+++ b/math/graphthing/files/patch-src-lang-bison.y
@@ -0,0 +1,20 @@
+--- src/lang-bison.y.orig 2012-02-21 14:12:06.000000000 +0100
++++ src/lang-bison.y 2012-02-21 14:12:27.000000000 +0100
+@@ -15,7 +15,7 @@
+
+ std::stack<PhraseBlock *> pbs;
+
+-int yy_lang_error (char *s);
++int yy_lang_error (const char *s);
+ int yy_lang_lex (void);
+ %}
+
+@@ -121,7 +121,7 @@
+
+ extern char *yy_lang_text;
+
+-int yy_lang_error (char *s)
++int yy_lang_error (const char *s)
+ {
+ fprintf (stderr, "lang-parse: %s in line %i, at symbol \"%s\"\n",
+ s, lang_lineno, yy_lang_text);