aboutsummaryrefslogtreecommitdiff
path: root/math/gretl/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-02-04 18:03:24 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-02-04 18:03:24 +0000
commit5b334b9cd6d814264633c2dc969af4004f22a672 (patch)
tree1cff294dbeab398e5e5e68ed49db784d72942d44 /math/gretl/Makefile
parent955f8e4e6649658dbf770e0d4ef2ee45689e71ab (diff)
downloadports-5b334b9cd6d814264633c2dc969af4004f22a672.tar.gz
ports-5b334b9cd6d814264633c2dc969af4004f22a672.zip
Notes
Diffstat (limited to 'math/gretl/Makefile')
-rw-r--r--math/gretl/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index 36382c0f0087..7d16a3bd476d 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gretl
DISTVERSION= 2021a
+PORTREVISION= 1
CATEGORIES= math finance
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSIONFULL}/
@@ -45,11 +46,11 @@ ATLAS_VARS= BLAS=-lf77blas LAPACK="-lalapack -lcblas"
ATLAS_VARS_OFF= BLAS=-lblas LAPACK=-llapack
GUI_DESC= Graphical user interface and plugins
-GUI_CONFIGURE_ON= --enable-gtk2=yes --enable-gui=yes
+GUI_CONFIGURE_ON= --enable-gui=yes
GUI_CONFIGURE_OFF= --enable-gui=no --enable-xdg=no
GUI_VARS= INSTALLS_ICONS=yes
-GUI_USE= GNOME=cairo,gtksourceview2
-GUI_USE_OFF= GNOME=glib20,libxml2
+GUI_USE= GNOME=cairo,gtksourceview3
+GUI_USE_OFF= GNOME=glib30,libxml2
GUI_USES= desktop-file-utils shared-mime-info
GUI_BUILD_DEPENDS= gnuplot:math/gnuplot
GUI_LIB_DEPENDS= libfreetype.so:print/freetype2 \
@@ -96,7 +97,7 @@ regression-test test check: build
${MAKE_ARGS} check
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/gretl-gtk2/*.so
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/gretl-gtk3/*.so
@${RMDIR} ${STAGEDIR}${DATADIR}/doc
.include <bsd.port.mk>