aboutsummaryrefslogtreecommitdiff
path: root/math/grpn
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-03-15 10:06:07 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-03-15 10:06:07 +0000
commit2db5a597efc942557449dc9fa613073e4a7a88af (patch)
tree0b8f5fff23022212ba384f71c30036dfe25a68e4 /math/grpn
parent2adf64a91170ce0c8726d8a730065b8b5fe626cc (diff)
downloadports-2db5a597efc942557449dc9fa613073e4a7a88af.tar.gz
ports-2db5a597efc942557449dc9fa613073e4a7a88af.zip
Resurrect `math/grpn' removed in r487992 because it used obsolete GTK+
stack. This version is a picked up fork on GitHub which now supports GTK+ 2.0 and include a number of bugfixes, so welcome back! Requested by: someone on #bsdports
Notes
Notes: svn path=/head/; revision=495782
Diffstat (limited to 'math/grpn')
-rw-r--r--math/grpn/Makefile34
-rw-r--r--math/grpn/distinfo3
-rw-r--r--math/grpn/files/patch-Makefile38
-rw-r--r--math/grpn/pkg-descr9
4 files changed, 84 insertions, 0 deletions
diff --git a/math/grpn/Makefile b/math/grpn/Makefile
new file mode 100644
index 000000000000..c53af0f7f9fe
--- /dev/null
+++ b/math/grpn/Makefile
@@ -0,0 +1,34 @@
+# Created by: Chris D. Faulhaber <jedgar@fxp.org>
+# $FreeBSD$
+
+PORTNAME= grpn
+PORTVERSION= 1.5.2
+DISTVERSIONPREFIX= v
+CATEGORIES= math
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= GTK+-based reverse polish notation (RPN) calculator
+
+LICENSE= GPLv2
+
+USES= gnome pkgconfig
+USE_GNOME= gtk20
+USE_GITHUB= yes
+GH_ACCOUNT= utopiabound
+
+WRKSRC_SUBDIR= src
+
+PLIST_FILES= bin/grpn man/man1/grpn.1.gz
+PORTDOCS= CHANGES
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,ulong,unsigned long,g' \
+ ${WRKSRC}/real.c
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/math/grpn/distinfo b/math/grpn/distinfo
new file mode 100644
index 000000000000..f19a35aa892f
--- /dev/null
+++ b/math/grpn/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1543025897
+SHA256 (utopiabound-grpn-v1.5.2_GH0.tar.gz) = 36a306ee7ac840c2f114877b07ee70688d53dd3111773938ae816c8b90d3e99d
+SIZE (utopiabound-grpn-v1.5.2_GH0.tar.gz) = 61799
diff --git a/math/grpn/files/patch-Makefile b/math/grpn/files/patch-Makefile
new file mode 100644
index 000000000000..9d94c0db7f9f
--- /dev/null
+++ b/math/grpn/files/patch-Makefile
@@ -0,0 +1,38 @@
+--- Makefile.orig 2018-11-24 02:18:17 UTC
++++ Makefile
+@@ -3,11 +3,11 @@
+ # Please read the next few lines and enter the correct values.
+
+ # where to install GRPN
+-PREFIX = /usr/local
+-MANDIR = ${PREFIX}/man
++PREFIX ?= /usr/local
++MANDIR ?= ${MANPREFIX}/man
+
+ # What compiler should be used
+-CC = gcc
++CC ?= gcc
+
+ # NOTE:
+ #
+@@ -16,10 +16,8 @@ CC = gcc
+ # add -DUSE_GNOME if you want to make grpn GNOME compliant.
+
+
+-CFLAGS = -Wall -g -O2 -I/usr/X11/include -DUSE_PANGO `pkg-config --cflags gtk+-2.0` -DGTK_VER_1_1
++CFLAGS += -Wall -DUSE_PANGO `pkg-config --cflags gtk+-2.0` -DGTK_VER_1_1
+
+-DFLAGS = -L/usr/X11/lib
+-
+ # end of user configurable section
+
+
+@@ -32,6 +30,8 @@ OBJS = test_gtk_ver.o real.o complex.o matrix.o number
+ error.o help.o mode.o undo.o
+
+ LIBS = `pkg-config --libs gtk+-2.0` -lX11 -lm
++
++all: grpn
+
+ grpn: $(OBJS)
+ $(CC) $(DFLAGS) -o $@ $(OBJS) $(LIBS)
diff --git a/math/grpn/pkg-descr b/math/grpn/pkg-descr
new file mode 100644
index 000000000000..2b89f04ee6a3
--- /dev/null
+++ b/math/grpn/pkg-descr
@@ -0,0 +1,9 @@
+GRPN is a RPN calculator for the X Window system built using
+the GIMP Toolkit (GTK).
+
+GRPN works with real numbers, complex numbers, matrices, and
+complex matrices. Numbers can be displayed in 4 different
+radix modes, and complex numbers can be displayed in either
+Cartesian or polar form.
+
+WWW: https://github.com/utopiabound/grpn