aboutsummaryrefslogtreecommitdiff
path: root/math/grpn
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2013-11-05 15:52:36 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2013-11-05 15:52:36 +0000
commit3437a3151148eb1c1f7ebec33e1f7c64bca59426 (patch)
tree43aede85ade0e85ba9c46e5a7f42ed78cbd1e1d5 /math/grpn
parentc96c9660986fc80c7875532361b677cd0c0391db (diff)
downloadports-3437a3151148eb1c1f7ebec33e1f7c64bca59426.tar.gz
ports-3437a3151148eb1c1f7ebec33e1f7c64bca59426.zip
Convert to staging, add missing includes.
Notes
Notes: svn path=/head/; revision=332860
Diffstat (limited to 'math/grpn')
-rw-r--r--math/grpn/Makefile10
-rw-r--r--math/grpn/files/patch-Makefile (renamed from math/grpn/files/patch-aa)12
-rw-r--r--math/grpn/files/patch-complex.c10
-rw-r--r--math/grpn/files/patch-help.c10
-rw-r--r--math/grpn/files/patch-lcd.c11
-rw-r--r--math/grpn/files/patch-main.c10
-rw-r--r--math/grpn/files/patch-mode.c10
-rw-r--r--math/grpn/files/patch-process_input.c10
-rw-r--r--math/grpn/files/patch-run_cmd.c10
9 files changed, 81 insertions, 12 deletions
diff --git a/math/grpn/Makefile b/math/grpn/Makefile
index 9b4b666771f4..1a6f7b89edb8 100644
--- a/math/grpn/Makefile
+++ b/math/grpn/Makefile
@@ -3,7 +3,7 @@
PORTNAME= grpn
PORTVERSION= 1.1.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= math
MASTER_SITES= http://lashwhip.com/grpn/
@@ -14,12 +14,10 @@ USE_GNOME= gtk12
ALL_TARGET=
-MAN1= grpn.1
-PLIST_FILES= bin/grpn
+PLIST_FILES= bin/grpn man/man1/grpn.1.gz
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/grpn ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/grpn.1 ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/grpn ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/grpn.1 ${STAGEDIR}${PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/math/grpn/files/patch-aa b/math/grpn/files/patch-Makefile
index 4c2a2a4836e0..c55c8e64731b 100644
--- a/math/grpn/files/patch-aa
+++ b/math/grpn/files/patch-Makefile
@@ -1,7 +1,7 @@
---- Makefile.orig Mon May 31 21:46:31 1999
-+++ Makefile Mon Oct 25 19:52:03 1999
-@@ -3,7 +3,7 @@
- # Please read the next few lines and enter the correct values.
+--- Makefile.orig 2002-04-05 05:56:05.000000000 +0200
++++ Makefile 2013-11-05 16:39:16.000000000 +0100
+@@ -6,7 +6,7 @@
+ PREFIX = /usr/local/
# What compiler should be used
-CC = gcc
@@ -9,7 +9,7 @@
# Where to find the gtk-config script
GTK_DIR =
-@@ -17,9 +17,9 @@
+@@ -20,9 +20,9 @@ GTK_DIR =
# add -DUSE_GNOME if you want to make grpn GNOME compliant.
@@ -21,7 +21,7 @@
# end of user configurable section
-@@ -34,7 +34,7 @@
+@@ -37,7 +37,7 @@ OBJS = test_gtk_ver.o real.o complex.o m
diff --git a/math/grpn/files/patch-complex.c b/math/grpn/files/patch-complex.c
new file mode 100644
index 000000000000..bfb241fda0ea
--- /dev/null
+++ b/math/grpn/files/patch-complex.c
@@ -0,0 +1,10 @@
+--- complex.c.orig 2002-04-04 05:46:10.000000000 +0200
++++ complex.c 2013-11-05 16:40:36.000000000 +0100
+@@ -21,6 +21,7 @@ Foundation, Inc., 59 Temple Place - Suit
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <math.h>
+
+ #include "complex.h"
diff --git a/math/grpn/files/patch-help.c b/math/grpn/files/patch-help.c
new file mode 100644
index 000000000000..823c30dc4d7f
--- /dev/null
+++ b/math/grpn/files/patch-help.c
@@ -0,0 +1,10 @@
+--- help.c.orig 2002-04-04 05:46:11.000000000 +0200
++++ help.c 2013-11-05 16:44:41.000000000 +0100
+@@ -19,6 +19,7 @@ Foundation, Inc., 59 Temple Place - Suit
+ */
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <gtk/gtk.h>
+
+ #include "help.h"
diff --git a/math/grpn/files/patch-lcd.c b/math/grpn/files/patch-lcd.c
new file mode 100644
index 000000000000..df0c7a35dd5a
--- /dev/null
+++ b/math/grpn/files/patch-lcd.c
@@ -0,0 +1,11 @@
+--- lcd.c.orig 2002-04-04 05:46:11.000000000 +0200
++++ lcd.c 2013-11-05 16:42:40.000000000 +0100
+@@ -20,6 +20,8 @@ Foundation, Inc., 59 Temple Place - Suit
+ /* lcd.c by Paul Wilkins 3/22/97 */
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <gtk/gtk.h>
+ #include <gdk/gdkkeysyms.h>
+
diff --git a/math/grpn/files/patch-main.c b/math/grpn/files/patch-main.c
new file mode 100644
index 000000000000..8c2d70330227
--- /dev/null
+++ b/math/grpn/files/patch-main.c
@@ -0,0 +1,10 @@
+--- main.c.orig 2002-04-04 05:46:11.000000000 +0200
++++ main.c 2013-11-05 16:42:00.000000000 +0100
+@@ -23,6 +23,7 @@ Foundation, Inc., 59 Temple Place - Suit
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #ifdef USE_GNOME
+ #include <gnome.h>
+ #endif
diff --git a/math/grpn/files/patch-mode.c b/math/grpn/files/patch-mode.c
new file mode 100644
index 000000000000..911e5718f1a7
--- /dev/null
+++ b/math/grpn/files/patch-mode.c
@@ -0,0 +1,10 @@
+--- mode.c.orig 2002-04-04 05:46:11.000000000 +0200
++++ mode.c 2013-11-05 16:44:30.000000000 +0100
+@@ -20,6 +20,7 @@ Foundation, Inc., 59 Temple Place - Suit
+ /* setup mode.c by Paul Wilkins 2/8/98 */
+
+ #include <stdio.h>
++#include <string.h>
+ #include <gtk/gtk.h>
+
+ #include "mode.h"
diff --git a/math/grpn/files/patch-process_input.c b/math/grpn/files/patch-process_input.c
new file mode 100644
index 000000000000..7666ba826b47
--- /dev/null
+++ b/math/grpn/files/patch-process_input.c
@@ -0,0 +1,10 @@
+--- process_input.c.orig 2002-04-04 05:46:11.000000000 +0200
++++ process_input.c 2013-11-05 16:43:55.000000000 +0100
+@@ -20,6 +20,7 @@ Foundation, Inc., 59 Temple Place - Suit
+ /* process_input.c by Paul Wilkins 3/21/97 */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <gtk/gtk.h>
+ #include <gdk/gdkkeysyms.h>
+
diff --git a/math/grpn/files/patch-run_cmd.c b/math/grpn/files/patch-run_cmd.c
new file mode 100644
index 000000000000..ff220434c9a9
--- /dev/null
+++ b/math/grpn/files/patch-run_cmd.c
@@ -0,0 +1,10 @@
+--- run_cmd.c.orig 2002-04-04 05:46:11.000000000 +0200
++++ run_cmd.c 2013-11-05 16:41:30.000000000 +0100
+@@ -20,6 +20,7 @@ Foundation, Inc., 59 Temple Place - Suit
+ /* run_cmd.c by Paul Wilkins */
+
+ #include <stdio.h>
++#include <string.h>
+ #include <gtk/gtk.h>
+
+ #include "buttons.h"