aboutsummaryrefslogtreecommitdiff
path: root/math/gsl/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-02-25 15:27:17 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-02-25 15:27:17 +0000
commita23f6437e8e6c10966aa7079af31a1c63620a91c (patch)
treed56b036d1faa183d0cf8dea8356bd15dc7bd0586 /math/gsl/Makefile
parent50e7992774cff4c273d843b464466ae2f1355663 (diff)
downloadports-a23f6437e8e6c10966aa7079af31a1c63620a91c.tar.gz
ports-a23f6437e8e6c10966aa7079af31a1c63620a91c.zip
Notes
Diffstat (limited to 'math/gsl/Makefile')
-rw-r--r--math/gsl/Makefile22
1 files changed, 10 insertions, 12 deletions
diff --git a/math/gsl/Makefile b/math/gsl/Makefile
index c2872ce0086c..7913faefd835 100644
--- a/math/gsl/Makefile
+++ b/math/gsl/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: gsl
-# Date created: 15 Feb 2000
-# Whom: Andrew L. Neporada <andrew@chg.ru>
+# New ports collection makefile for: gsl
+# Date created: 15 Feb 2000
+# Whom: Andrew L. Neporada <andrew@chg.ru>
#
# $FreeBSD$
#
@@ -8,26 +8,24 @@
PORTNAME= gsl
PORTVERSION= 0.7
CATEGORIES= math
-MASTER_SITES= ftp://sourceware.cygnus.com/pub/gsl/ \
- ftp://ftp.freesoftware.com/pub/sourceware/gsl/ \
- ftp://sunsite.org.uk/Mirrors/sourceware.cygnus.com/pub/gsl/ \
- ftp://ftp.funet.fi/pub/mirrors/sourceware.cygnus.com/pub/gsl/ \
- ftp://ftp.chg.ru/pub/math/gsl/
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${GSLREF}
+MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
.if !defined(NOPORTDOCS)
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${GSLREF}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
.endif
-MAINTAINER= ports@freebsd.org
+MAINTAINER= ports@FreeBSD.org
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
+
GSLREF= gsl-ref.ps.gz
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/gsl
- ${INSTALL_MAN} ${DISTDIR}/${GSLREF} ${PREFIX}/share/doc/gsl
+ @${MKDIR} ${PREFIX}/share/doc/gsl
+ ${INSTALL_DATA} ${_DISTDIR}/${GSLREF} ${PREFIX}/share/doc/gsl
${GUNZIP_CMD} ${PREFIX}/share/doc/gsl/${GSLREF}
.endif