aboutsummaryrefslogtreecommitdiff
path: root/math/half
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-04-26 21:32:58 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-04-26 21:32:58 +0000
commitaf24a3a1a4bac34e96d625f1eb27b091d7b82960 (patch)
tree301bb4546d50790556e6aa1555e225427a2a9ec5 /math/half
parent6e4c5541efa0d6904b8403038267d0f82ece4930 (diff)
downloadports-af24a3a1a4bac34e96d625f1eb27b091d7b82960.tar.gz
ports-af24a3a1a4bac34e96d625f1eb27b091d7b82960.zip
New port: math/half: C++ library for half precision floating point arithmetic
Notes
Notes: svn path=/head/; revision=533085
Diffstat (limited to 'math/half')
-rw-r--r--math/half/Makefile25
-rw-r--r--math/half/distinfo3
-rw-r--r--math/half/pkg-descr7
3 files changed, 35 insertions, 0 deletions
diff --git a/math/half/Makefile b/math/half/Makefile
new file mode 100644
index 000000000000..998e9ae8e66e
--- /dev/null
+++ b/math/half/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= half
+DISTVERSION= 2.1.0
+CATEGORIES= math
+MASTER_SITES= SF
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ library for half precision floating point arithmetic
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= zip
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES= include/half.hpp
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/include/half.hpp ${STAGEDIR}${PREFIX}/include
+
+.include <bsd.port.mk>
diff --git a/math/half/distinfo b/math/half/distinfo
new file mode 100644
index 000000000000..857d301c0cfe
--- /dev/null
+++ b/math/half/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1587931990
+SHA256 (half-2.1.0.zip) = ad1788afe0300fa2b02b0d1df128d857f021f92ccf7c8bddd07812685fa07a25
+SIZE (half-2.1.0.zip) = 47043
diff --git a/math/half/pkg-descr b/math/half/pkg-descr
new file mode 100644
index 000000000000..daa27f9e3216
--- /dev/null
+++ b/math/half/pkg-descr
@@ -0,0 +1,7 @@
+half is a C++ header-only library to provide an IEEE 754 conformant 16-bit
+half-precision floating-point type along with corresponding arithmetic
+operators, type conversions and common mathematical functions. It aims for
+both efficiency and ease of use, trying to accurately mimic the behaviour of
+the built-in floating-point types at the best performance possible.
+
+WWW: http://half.sourceforge.net/