aboutsummaryrefslogtreecommitdiff
path: root/math/hpipm
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-10-16 15:37:20 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-10-16 15:37:20 +0000
commit15ba13897e1505ba7eabcbeaac38405a31792ce1 (patch)
treeeee103030800ad59d49515be45d98f8d25a7add0 /math/hpipm
parentbc7e359cc926687d722ca83679ecd68ad794e259 (diff)
downloadports-15ba13897e1505ba7eabcbeaac38405a31792ce1.tar.gz
ports-15ba13897e1505ba7eabcbeaac38405a31792ce1.zip
math/hpipm: fix build on non-x86
Don't enable AVX on non-x86. PR: 241242 Approved by: yuri (maintainer), linimon (mentor) Differential Revision: https://reviews.freebsd.org/D22024
Notes
Notes: svn path=/head/; revision=514603
Diffstat (limited to 'math/hpipm')
-rw-r--r--math/hpipm/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/math/hpipm/Makefile b/math/hpipm/Makefile
index d29d4ea76854..973dcd106cd9 100644
--- a/math/hpipm/Makefile
+++ b/math/hpipm/Makefile
@@ -17,4 +17,10 @@ USES= cmake localbase
USE_GITHUB= yes
GH_ACCOUNT= giaf
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != amd64 && ${ARCH} != i386
+CMAKE_ARGS+= -DAVX:BOOL=OFF
+.endif
+
+.include <bsd.port.post.mk>