aboutsummaryrefslogtreecommitdiff
path: root/math/jags
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2012-07-14 01:16:37 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2012-07-14 01:16:37 +0000
commit5f58d65d7c291c2cbc92b6eac7cde623a7b92f55 (patch)
treecb04eb1e31dcd9186aa112ac21c1efd5fdf537c9 /math/jags
parent980b67f35497c350de770d6bdaf0f86074a9f890 (diff)
downloadports-5f58d65d7c291c2cbc92b6eac7cde623a7b92f55.tar.gz
ports-5f58d65d7c291c2cbc92b6eac7cde623a7b92f55.zip
clean up pkg-descr and correct WWW; while here, switch to
the new options format
Notes
Notes: svn path=/head/; revision=300887
Diffstat (limited to 'math/jags')
-rw-r--r--math/jags/Makefile46
-rw-r--r--math/jags/pkg-descr10
2 files changed, 28 insertions, 28 deletions
diff --git a/math/jags/Makefile b/math/jags/Makefile
index 4795628e6c3b..e061591f6578 100644
--- a/math/jags/Makefile
+++ b/math/jags/Makefile
@@ -15,13 +15,6 @@ MASTER_SITE_SUBDIR= mcmc-jags/JAGS/${S}.x/Source/:1 \
mcmc-jags/Manuals/2.x/:3 \
mcmc-jags/Manuals/${S}.x/:4
DISTFILES= JAGS-${PORTVERSION}${EXTRACT_SUFX}:1
-.if !defined(NOPORTDOCS) || make(makesum)
-DISTFILES+= jags_developer_manual.pdf:3 jags_installation_manual.pdf:4 \
- jags_user_manual.pdf:4
-.endif
-.if !defined(NOPORTEXAMPLES) || make(makesum)
-DISTFILES+= classic-bugs.tar.gz:2
-.endif
EXTRACT_ONLY= ${DISTFILES:M*[12]:C|:.*||}
MAINTAINER= bf@FreeBSD.org
@@ -40,27 +33,36 @@ WRKSRC= ${WRKDIR}/JAGS-${PORTVERSION}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAN1= jags.1
-OPTIONS= ATLAS "use ATLAS libraries instead of BLAS and LAPACK" off
PLIST_SUB= MODULEVERSION=${S}
S= ${PORTVERSION:C|\..*||}
.include <bsd.port.options.mk>
-.if defined(WITH_ATLAS)
-LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-CONFIGURE_ARGS= --with-lapack="-lalapack -lptcblas" --with-blas="-lptf77blas"
-.else
-LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
-CONFIGURE_ARGS= --with-lapack="-llapack" --with-blas="-lblas"
+.if ${PORT_OPTIONS:MDOCS} || make(makesum)
+DISTFILES+= jags_developer_manual.pdf:3 jags_installation_manual.pdf:4 \
+ jags_user_manual.pdf:4
+PORTDOCS= ${DISTFILES:M*[34]:C|:.*||}
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES} || make(makesum)
+DISTFILES+= classic-bugs.tar.gz:2
+PORTEXAMPLES= *
.endif
-.if !defined(NOPORTDOCS)
-PORTDOCS= ${DISTFILES:M*[34]:C|:.*||}
+.if exists(${LOCALBASE}/lib/libatlas.so)
+WITH_BLAS?= atlas
+.else
+WITH_BLAS?= reference
.endif
-.if !defined(NOPORTEXAMPLES)
-PORTEXAMPLES= *
+.if ${WITH_BLAS} == "atlas"
+LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
+CONFIGURE_ARGS= --with-lapack="-lalapack -lptcblas" --with-blas="-lptf77blas"
+.elif ${WITH_BLAS} == "reference"
+LIB_DEPENDS+= blas:${PORTSDIR}/math/blas
+LIB_DEPENDS+= lapack:${PORTSDIR}/math/lapack
+CONFIGURE_ARGS= --with-lapack="-llapack" --with-blas="-lblas"
+.else
+IGNORE = : invalid value for WITH_BLAS: ${WITH_BLAS}
.endif
post-patch:
@@ -73,17 +75,17 @@ post-patch:
-e '/@WINDOWS_FALSE@.*rm -f jags/s/jags/mcmc-&/' \
-e '/@WINDOWS_FALSE@.*mv jags.tmp jags/s/jags/mcmc-&/2' \
${WRKSRC}/src/terminal/Makefile.in
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${SED} -i '' -e '\|JAGS ?=|{s|jags|mcmc-&|;s|/usr/local|${PREFIX}|;}' \
${WRKDIR}/classic-bugs/vol[12]/Makefile
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@cd ${_DISTDIR}; ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@cd ${WRKDIR}/classic-bugs; ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
.endif
diff --git a/math/jags/pkg-descr b/math/jags/pkg-descr
index cb9d5de7b9a6..3ed5fc95d3ca 100644
--- a/math/jags/pkg-descr
+++ b/math/jags/pkg-descr
@@ -1,14 +1,12 @@
JAGS is Just Another Gibbs Sampler -- a program for analysis of
-Bayesian hierarchical models using Gibbs sampling not wholly unlike BUGS.
+Bayesian hierarchical models using Markov Chain Monte Carlo (MCMC)
+simulation.
The functionality of JAGS is based on the BUGS program created by the
MRC Biostatistics Unit (http://www.mrc-bsu.cam.ac.uk/). There is a short
manual that describes the differences between JAGS and BUGS.
-The manual is installed as /usr/local/share/doc/jags/jags_user_manual.pdf.
-
Some of the BUGS examples have been modified to run with JAGS, and have
-been turned into a test suite. They are installed under
-/usr/local/share/examples/jags/.
+been turned into a test suite.
-WWW: http://www-fis.iarc.fr/~martyn/software/jags/
+WWW: http://mcmc-jags.sourceforge.net/