aboutsummaryrefslogtreecommitdiff
path: root/math/jlatexmath/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2019-08-21 19:43:32 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2019-08-21 19:43:32 +0000
commit5b4829585a005cdef02d3854f0053622c8250ee5 (patch)
tree08dd036e858f517c95b487f329bc5dd9c039b0d6 /math/jlatexmath/Makefile
parent83a13ea186ce8be877e35f034f40351d0d208b34 (diff)
downloadports-5b4829585a005cdef02d3854f0053622c8250ee5.tar.gz
ports-5b4829585a005cdef02d3854f0053622c8250ee5.zip
math/jlatexmath:
- Update to 1.0.7 - Switch to the binary distribution since building from the sources requires maven - Remove FOP option and install fop plugin unconditionally: jlatexmath is solely used by math/scilab only and it needs fop. - Update WWW
Notes
Notes: svn path=/head/; revision=509550
Diffstat (limited to 'math/jlatexmath/Makefile')
-rw-r--r--math/jlatexmath/Makefile56
1 files changed, 16 insertions, 40 deletions
diff --git a/math/jlatexmath/Makefile b/math/jlatexmath/Makefile
index d1d58fce2fef..9d485bbeb5fc 100644
--- a/math/jlatexmath/Makefile
+++ b/math/jlatexmath/Makefile
@@ -2,55 +2,31 @@
# $FreeBSD$
PORTNAME= jlatexmath
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.7
CATEGORIES= math java
-MASTER_SITES= http://forge.scilab.org/upload/jlatexmath/files/
-DISTNAME= ${PORTNAME}-src-all-${PORTVERSION}
+MASTER_SITES= https://repo1.maven.org/maven2/org/scilab/forge/jlatexmath/${PORTVERSION}/:0 \
+ https://repo1.maven.org/maven2/org/scilab/forge/jlatexmath-fop/${PORTVERSION}/:1
+DISTFILES= ${PORTNAME}-${PORTVERSION}.jar:0 \
+ ${PORTNAME}-fop-${PORTVERSION}.jar:1
+EXTRACT_ONLY= # none
MAINTAINER= makc@FreeBSD.org
COMMENT= Java API to display mathematical formulas written in LaTeX
LICENSE= GPLv2
-USES= zip
-USE_JAVA= yes
-JAVA_BUILD= yes
-JAVA_RUN= yes
-USE_ANT= yes
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
-OPTIONS_DEFINE= FOP EXAMPLES
-OPTIONS_DEFAULT= FOP
-OPTIONS_SUB= yes
-
-FOP_DESC= textproc/fop plugin (required for math/scilab)
-FOP_BUILD_DEPENDS= fop:textproc/fop \
- ${JAVALIBDIR}/xmlgraphics-commons.jar:graphics/xmlgraphics-commons
-FOP_RUN_DEPENDS:= ${FOP_BUILD_DEPENDS} \
- ${LOCALBASE}/share/java/batik/batik.jar:graphics/batik \
- ${JAVALIBDIR}/avalon-framework.jar:devel/avalon-framework \
- ${JAVALIBDIR}/commons-io.jar:devel/jakarta-commons-io \
- ${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging \
- ${JAVALIBDIR}/xml-apis-ext.jar:textproc/xml-commons
-FOP_ALL_TARGET= fop
-
-post-patch:
- ${REINPLACE_CMD} -e 's|/usr/share/java/fop.jar|${LOCALBASE}/share/java/fop/build/fop.jar|' ${WRKSRC}/fop.properties
- ${REINPLACE_CMD} -e 's|/usr/share/java/batik.jar|${LOCALBASE}/share/java/batik/batik.jar|' ${WRKSRC}/fop.properties
- ${REINPLACE_CMD} -e 's|/usr/share/java/|${JAVALIBDIR}/|' ${WRKSRC}/fop.properties
-
-pre-install:
-# Remove empty directory
- -${RMDIR} ${WRKSRC}/examples/Macros/bin
+RUN_DEPENDS= ${JAVALIBDIR}/xmlgraphics-commons.jar:graphics/xmlgraphics-commons
-do-install:
- ${INSTALL_DATA} ${WRKSRC}/dist/jlatexmath-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/jlatexmath.jar
+USE_JAVA= 1.7+
-do-install-EXAMPLES-on:
- (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR})
+NO_ARCH= yes
+NO_BUILD= yes
+PLIST_SUB= PORTVERSION=${PORTVERSION}
-do-install-FOP-on:
- ${INSTALL_DATA} ${WRKSRC}/dist/jlatexmath-fop-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/jlatexmath-fop.jar
+do-install:
+.for f in jlatexmath jlatexmath-fop
+ ${INSTALL_DATA} ${DISTDIR}/${f}-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}
+ ${LN} -sf ${f}-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/${f}.jar
+.endfor
.include <bsd.port.mk>