aboutsummaryrefslogtreecommitdiff
path: root/math/kfr
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-06-18 06:47:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-06-18 06:52:14 +0000
commite44b400014a2bea7f5d3ab659dd76f365b5977a2 (patch)
treec79ad63c09291415475a65be6fee819b9e4f45df /math/kfr
parent64301771eefd6c2873365f7a2340252c8d647a0c (diff)
downloadports-e44b400014a2bea7f5d3ab659dd76f365b5977a2.tar.gz
ports-e44b400014a2bea7f5d3ab659dd76f365b5977a2.zip
Diffstat (limited to 'math/kfr')
-rw-r--r--math/kfr/Makefile2
-rw-r--r--math/kfr/distinfo6
-rw-r--r--math/kfr/pkg-plist48
3 files changed, 32 insertions, 24 deletions
diff --git a/math/kfr/Makefile b/math/kfr/Makefile
index dcac4543f6b1..649f9f1dd85c 100644
--- a/math/kfr/Makefile
+++ b/math/kfr/Makefile
@@ -1,5 +1,5 @@
PORTNAME= kfr
-DISTVERSION= 4.3.0
+DISTVERSION= 5.0.2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/kfr/distinfo b/math/kfr/distinfo
index cca0e174cfb5..b0dbbe677dae 100644
--- a/math/kfr/distinfo
+++ b/math/kfr/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1665940011
-SHA256 (kfrlib-kfr-4.3.0_GH0.tar.gz) = 80206067e50cde2e94965eda013c7f6fe4dd4490cb6b14803cdbbd91fe9f46fb
-SIZE (kfrlib-kfr-4.3.0_GH0.tar.gz) = 10852418
+TIMESTAMP = 1687070134
+SHA256 (kfrlib-kfr-5.0.2_GH0.tar.gz) = e45cd66f941d00c4bf72a10dddf010b6f67f92a6278f5c6caf84ed7f8a67f069
+SIZE (kfrlib-kfr-5.0.2_GH0.tar.gz) = 11214067
diff --git a/math/kfr/pkg-plist b/math/kfr/pkg-plist
index e40afd0cc3e2..2f1b74cc6af9 100644
--- a/math/kfr/pkg-plist
+++ b/math/kfr/pkg-plist
@@ -5,14 +5,19 @@ include/kfr/base/conversion.hpp
include/kfr/base/expression.hpp
include/kfr/base/filter.hpp
include/kfr/base/fraction.hpp
-include/kfr/base/function_expressions.hpp
include/kfr/base/generators.hpp
+include/kfr/base/handle.hpp
+include/kfr/base/impl/static_array.hpp
+include/kfr/base/math_expressions.hpp
include/kfr/base/memory.hpp
-include/kfr/base/pointer.hpp
include/kfr/base/random.hpp
+include/kfr/base/random_bits.hpp
include/kfr/base/reduce.hpp
+include/kfr/base/shape.hpp
+include/kfr/base/simd_expressions.hpp
include/kfr/base/small_buffer.hpp
-include/kfr/base/sort.hpp
+include/kfr/base/state_holder.hpp
+include/kfr/base/tensor.hpp
include/kfr/base/univector.hpp
include/kfr/capi.h
include/kfr/cident.h
@@ -65,15 +70,15 @@ include/kfr/dsp/oscillators.hpp
include/kfr/dsp/sample_rate_conversion.hpp
include/kfr/dsp/speaker.hpp
include/kfr/dsp/special.hpp
-include/kfr/dsp/state_holder.hpp
include/kfr/dsp/units.hpp
include/kfr/dsp/waveshaper.hpp
include/kfr/dsp/weighting.hpp
include/kfr/dsp/window.hpp
+include/kfr/except.hpp
include/kfr/graphics.hpp
include/kfr/graphics/color.hpp
include/kfr/graphics/geometry.hpp
-include/kfr/graphics/scaled.hpp
+include/kfr/graphics/impl/scaled.hpp
include/kfr/io.hpp
include/kfr/io/audiofile.hpp
include/kfr/io/dr/README.txt
@@ -86,38 +91,24 @@ include/kfr/io/python_plot.hpp
include/kfr/io/tostring.hpp
include/kfr/kfr.h
include/kfr/math.hpp
-include/kfr/math/abs.hpp
include/kfr/math/asin_acos.hpp
include/kfr/math/atan.hpp
-include/kfr/math/clamp.hpp
include/kfr/math/compiletime.hpp
include/kfr/math/complex_math.hpp
include/kfr/math/gamma.hpp
include/kfr/math/hyperbolic.hpp
-include/kfr/math/impl/abs.hpp
include/kfr/math/impl/asin_acos.hpp
include/kfr/math/impl/atan.hpp
-include/kfr/math/impl/clamp.hpp
include/kfr/math/impl/gamma.hpp
include/kfr/math/impl/hyperbolic.hpp
include/kfr/math/impl/log_exp.hpp
-include/kfr/math/impl/logical.hpp
-include/kfr/math/impl/min_max.hpp
include/kfr/math/impl/modzerobessel.hpp
-include/kfr/math/impl/round.hpp
-include/kfr/math/impl/saturation.hpp
-include/kfr/math/impl/select.hpp
include/kfr/math/impl/sin_cos.hpp
include/kfr/math/impl/sqrt.hpp
include/kfr/math/impl/tan.hpp
include/kfr/math/interpolation.hpp
include/kfr/math/log_exp.hpp
-include/kfr/math/logical.hpp
-include/kfr/math/min_max.hpp
include/kfr/math/modzerobessel.hpp
-include/kfr/math/round.hpp
-include/kfr/math/saturation.hpp
-include/kfr/math/select.hpp
include/kfr/math/sin_cos.hpp
include/kfr/math/sqrt.hpp
include/kfr/math/tan.hpp
@@ -125,28 +116,45 @@ include/kfr/runtime.hpp
include/kfr/runtime/cpuid.hpp
include/kfr/runtime/cpuid_auto.hpp
include/kfr/simd.hpp
+include/kfr/simd/abs.hpp
+include/kfr/simd/clamp.hpp
include/kfr/simd/comparison.hpp
include/kfr/simd/complex.hpp
+include/kfr/simd/complex_type.hpp
include/kfr/simd/constants.hpp
include/kfr/simd/digitreverse.hpp
include/kfr/simd/horizontal.hpp
+include/kfr/simd/impl/abs.hpp
include/kfr/simd/impl/backend.hpp
include/kfr/simd/impl/backend_clang.hpp
include/kfr/simd/impl/backend_generic.hpp
include/kfr/simd/impl/basicoperators_clang.hpp
+include/kfr/simd/impl/basicoperators_complex.hpp
include/kfr/simd/impl/basicoperators_generic.hpp
+include/kfr/simd/impl/clamp.hpp
include/kfr/simd/impl/function.hpp
include/kfr/simd/impl/intrinsics.h
+include/kfr/simd/impl/logical.hpp
+include/kfr/simd/impl/min_max.hpp
include/kfr/simd/impl/operators.hpp
include/kfr/simd/impl/read_write.hpp
+include/kfr/simd/impl/round.hpp
+include/kfr/simd/impl/saturation.hpp
+include/kfr/simd/impl/select.hpp
include/kfr/simd/impl/simd.hpp
include/kfr/simd/impl/specialconstants.hpp
-include/kfr/simd/impl/specializations.i
+include/kfr/simd/impl/specializations.hpp
+include/kfr/simd/logical.hpp
include/kfr/simd/mask.hpp
+include/kfr/simd/min_max.hpp
include/kfr/simd/operators.hpp
include/kfr/simd/platform.hpp
include/kfr/simd/read_write.hpp
+include/kfr/simd/round.hpp
+include/kfr/simd/saturation.hpp
+include/kfr/simd/select.hpp
include/kfr/simd/shuffle.hpp
+include/kfr/simd/sort.hpp
include/kfr/simd/types.hpp
include/kfr/simd/vec.hpp
include/kfr/testo/assert.hpp