aboutsummaryrefslogtreecommitdiff
path: root/math/lambda
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-02-15 14:31:57 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-02-15 14:31:57 +0000
commitba84d6c09650fe3edec5febdad14c40401c5ec27 (patch)
tree470980a6199af5e754bc5d1dc07284a85004e4c1 /math/lambda
parent69ffafb00de1158ef9635e66d9fed3f7acc97fdb (diff)
downloadports-ba84d6c09650fe3edec5febdad14c40401c5ec27.tar.gz
ports-ba84d6c09650fe3edec5febdad14c40401c5ec27.zip
Notes
Diffstat (limited to 'math/lambda')
-rw-r--r--math/lambda/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/math/lambda/Makefile b/math/lambda/Makefile
index 153c2cf5c99b..0662e88a48bb 100644
--- a/math/lambda/Makefile
+++ b/math/lambda/Makefile
@@ -7,32 +7,31 @@ CATEGORIES= math
MASTER_SITES= http://www.freebsdbrasil.com.br/~jmelo/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A lambda calculus interpreter
+COMMENT= Lambda calculus interpreter
+
+LICENSE= GPLv2
USES= perl5
USE_PERL5= build
GNU_CONFIGURE= yes
+OPTIONS_DEFINE= DOCS
+
PLIST_FILES= bin/lambda \
share/lambda/definitions \
share/lambda/definitions_with_numbers
PLIST_DIRS= share/lambda
-.if !defined(NOPORTDOCS)
DOCS= lambda.html lambdamanual.html user_manual_style.css
PORTDOCS= *
-.endif
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/lambda ${PREFIX}/bin
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/definitions* ${DATADIR}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/lambda ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/definitions* ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/docs/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>