aboutsummaryrefslogtreecommitdiff
path: root/math/laspack
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-07-25 09:05:50 +0000
committerSimon Barner <barner@FreeBSD.org>2005-07-25 09:05:50 +0000
commitbcd4eab4cbfc5558096ce018c35572ab4121637e (patch)
treed81e5d5d789bc6ceeceb7adeb1ca319ce322bc64 /math/laspack
parenta58473d9fcd8618853e34fb82050a8af7d481b28 (diff)
downloadports-bcd4eab4cbfc5558096ce018c35572ab4121637e.tar.gz
ports-bcd4eab4cbfc5558096ce018c35572ab4121637e.zip
Add laspack 1.12.2,
package for solving large sparse systems of linear equations. PR: 83968 Submitted by: Pedro F. Giffuni" <giffunip at asme dot org>
Notes
Notes: svn path=/head/; revision=140069
Diffstat (limited to 'math/laspack')
-rw-r--r--math/laspack/Makefile33
-rw-r--r--math/laspack/distinfo2
-rw-r--r--math/laspack/files/patch-makefile13
-rw-r--r--math/laspack/pkg-descr23
-rw-r--r--math/laspack/pkg-plist20
5 files changed, 91 insertions, 0 deletions
diff --git a/math/laspack/Makefile b/math/laspack/Makefile
new file mode 100644
index 000000000000..43afcf5a8a8f
--- /dev/null
+++ b/math/laspack/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: LASPack
+# Date created: 27 July 2005
+# Whom: giffunip
+#
+# $FreeBSD$
+#
+
+PORTNAME= laspack
+PORTVERSION= 1.12.2
+CATEGORIES= math
+MASTER_SITES= ftp://netlib.bell-labs.com/netlib/linalg/ \
+ ftp://www.hensa.ac.uk/mirrors/netlib/linalg/ \
+ http://www.netlib.org/linalg/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= giffunip@asme.org
+COMMENT= Package for solving large sparse systems of linear equations
+
+USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKEFILE= makefile
+
+post-patch:
+ @${REINPLACE_CMD} -e 's+/usr/local+${LOCALBASE}+g' ${WRKSRC}/${MAKEFILE}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/*.ps ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/laspack/distinfo b/math/laspack/distinfo
new file mode 100644
index 000000000000..04d23a040579
--- /dev/null
+++ b/math/laspack/distinfo
@@ -0,0 +1,2 @@
+MD5 (laspack.tgz) = fcfb3c86cc993e29eb477191b1136a8d
+SIZE (laspack.tgz) = 195214
diff --git a/math/laspack/files/patch-makefile b/math/laspack/files/patch-makefile
new file mode 100644
index 000000000000..4e1fb9a25266
--- /dev/null
+++ b/math/laspack/files/patch-makefile
@@ -0,0 +1,13 @@
+--- makefile.orig Mon Jul 25 00:24:08 2005
++++ makefile Mon Jul 25 00:24:30 2005
+@@ -21,8 +21,8 @@
+ #
+ # set the destination directories for the library and include files
+ #
+-LIBDEST = $(HOME)/lib$(ARCH_EXT)
+-INCDEST = $(HOME)/include
++LIBDEST = $(PREFIX)/lib
++INCDEST = $(PREFIX)/include
+
+ #
+ # the following text was created automaticaly. You should change it carefully.
diff --git a/math/laspack/pkg-descr b/math/laspack/pkg-descr
new file mode 100644
index 000000000000..cf5fdba6f37b
--- /dev/null
+++ b/math/laspack/pkg-descr
@@ -0,0 +1,23 @@
+ LASPack (version 1.12.2)
+
+LASPack is a package for solving large sparse systems of linear equations
+like those which arise from discretization of partial differential equations.
+
+Main features:
+
+- The primary aim of LASPack is the implementation of efficient iterative
+ methods for the solution of systems of linear equations.
+
+- Beside the obligatory Jacobi, succesive over-relaxation, Chebyshev, and
+ conjugate gradient solvers, LASPack contains selected state-of-the-art
+ algorithms which are commonly used for large sparse systems:
+
+ - CG-like methods for non-symmetric systems: CGN, GMRES, BiCG, QMR, CGS, and
+ BiCGStab,
+ - multilevel methods such as multigrid and conjugate gradient method
+ preconditioned by multigrid and BPX preconditioners.
+
+A complete description of the package (including the installation procedure)
+you may find in LASPack Reference Manual in the following postscript files:
+
+WWW: http://www.tu-dresden.de/mwism/skalicky/laspack/laspack.html
diff --git a/math/laspack/pkg-plist b/math/laspack/pkg-plist
new file mode 100644
index 000000000000..65ce63084edf
--- /dev/null
+++ b/math/laspack/pkg-plist
@@ -0,0 +1,20 @@
+include/laspack/copyrght.h
+include/laspack/eigenval.h
+include/laspack/elcmp.h
+include/laspack/errhandl.h
+include/laspack/factor.h
+include/laspack/itersolv.h
+include/laspack/lastypes.h
+include/laspack/matrix.h
+include/laspack/mlsolv.h
+include/laspack/operats.h
+include/laspack/precond.h
+include/laspack/qmatrix.h
+include/laspack/rtc.h
+include/laspack/vector.h
+include/laspack/version.h
+lib/liblaspack.a
+%%PORTDOCS%%%%DOCSDIR%%/laspack1.ps
+%%PORTDOCS%%%%DOCSDIR%%/laspack2.ps
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/laspack