aboutsummaryrefslogtreecommitdiff
path: root/math/levmar
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2015-05-11 11:58:46 +0000
committerThomas Zander <riggs@FreeBSD.org>2015-05-11 11:58:46 +0000
commitbbc78cb360810fbec8b06e742694f34eb2bd4d4a (patch)
tree06e2ebab1a0dc820ff7f41d0efeb2eab438e113a /math/levmar
parente61f6205b6d5e6ef8d979b0b03a386071ebdd1ae (diff)
downloadports-bbc78cb360810fbec8b06e742694f34eb2bd4d4a.tar.gz
ports-bbc78cb360810fbec8b06e742694f34eb2bd4d4a.zip
- Use blaslapack.mk
- Bump PORTREVISION PR: 199383 Submitted by: phd_kimberlite@yahoo.co.jp (maintainer)
Notes
Notes: svn path=/head/; revision=386074
Diffstat (limited to 'math/levmar')
-rw-r--r--math/levmar/Makefile38
1 files changed, 10 insertions, 28 deletions
diff --git a/math/levmar/Makefile b/math/levmar/Makefile
index a62d3c04343a..619624065593 100644
--- a/math/levmar/Makefile
+++ b/math/levmar/Makefile
@@ -3,7 +3,7 @@
PORTNAME= levmar
PORTVERSION= 2.6
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= http://users.ics.forth.gr/~lourakis/levmar/
@@ -17,34 +17,16 @@ USE_LDCONFIG= yes
USES= fortran tar:tgz uidfix
OPTIONS_DEFINE= DOCS EXAMPLES PROFILE
+OPTIONS_SINGLE= BLASLIB
+OPTIONS_DEFAULT= NETLIB
+OPTIONS_SINGLE_BLASLIB= ATLAS NETLIB OPENBLAS
PROFILE_DESC= Build a profiling library
-.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/lib/libgoto2p.so)
-WITH_BLAS?= gotoblas
-.elif exists(${LOCALBASE}/lib/libatlas.so)
-WITH_BLAS?= atlas
-.else
-WITH_BLAS?= reference
-.endif
+ATLAS_USES= blaslapack:atlas
+NETLIB_USES= blaslapack:netlib
+OPENBLAS_USES= blaslapack:openblas
-.if ${WITH_BLAS} == "reference"
-LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas \
- liblapack.so:${PORTSDIR}/math/lapack
-BLAS= -lblas
-LAPACK= -llapack
-.elif ${WITH_BLAS} == "gotoblas"
-LDFLAGS+= -lpthread -L${LOCALBASE}/lib
-LIB_DEPENDS+= libgoto2p.so:${PORTSDIR}/math/gotoblas
-BLAS= -lgoto2p
-LAPACK= -lgoto2p
-.elif ${WITH_BLAS} == "atlas"
-LDFLAGS+= -lpthread -L${LOCALBASE}/lib
-LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
-BLAS= -lptf77blas
-LAPACK= -lalapack -lptcblas
-.endif
+.include <bsd.port.pre.mk>
PORTDOCS= README.txt
PORTEXAMPLES= lmdemo.c Makefile.demo
@@ -73,8 +55,8 @@ post-extract:
@${REINPLACE_CMD} -e 's+%%CC%%+${CC}+g' \
-e 's+%%CFLAGS%%+${CFLAGS} -I${LOCALBASE}/include+g' \
-e 's+%%LDFLAGS%%+${LDFLAGS}+g' \
- -e 's+%%BLAS%%+${BLAS}+g' \
- -e 's+%%LAPACK%%+${LAPACK}+g' \
+ -e 's+%%BLAS%%+${BLASLIB}+g' \
+ -e 's+%%LAPACK%%+${LAPACKLIB}+g' \
${WRKSRC}/Makefile.demo
post-install: