aboutsummaryrefslogtreecommitdiff
path: root/math/libocas/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-18 16:05:20 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-18 16:05:20 +0000
commitf5457df2d56dda65ca00ea0a254c68b00aa9498e (patch)
tree55743b9e5568990749837eef97378824ebffd6cf /math/libocas/Makefile
parent10b9ef15902b1cdc09c7de4dd973db874d6754cb (diff)
downloadports-f5457df2d56dda65ca00ea0a254c68b00aa9498e.tar.gz
ports-f5457df2d56dda65ca00ea0a254c68b00aa9498e.zip
Notes
Diffstat (limited to 'math/libocas/Makefile')
-rw-r--r--math/libocas/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/math/libocas/Makefile b/math/libocas/Makefile
index 643d72532063..34c7370a33f6 100644
--- a/math/libocas/Makefile
+++ b/math/libocas/Makefile
@@ -22,7 +22,6 @@ MAKE_ENV= CLIBS="${CLIBS}" MEXDETECTED=no
PLIST_FILES= bin/linclassif bin/msvmocas bin/svmocas lib/libocas.so \
lib/libocas.so.1
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == sparc64
@@ -42,10 +41,10 @@ post-patch:
do-install:
.for p in linclassif msvmocas svmocas
- @${INSTALL_PROGRAM} ${WRKSRC}/${p} ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/${p} ${STAGEDIR}${PREFIX}/bin
.endfor
- @${INSTALL_LIB} ${WRKSRC}/libocas.so.1 ${PREFIX}/lib
- @${LN} -sf libocas.so.1 ${PREFIX}/lib/libocas.so
+ @${INSTALL_LIB} ${WRKSRC}/libocas.so.1 ${STAGEDIR}${PREFIX}/lib
+ @${LN} -sf libocas.so.1 ${STAGEDIR}${PREFIX}/lib/libocas.so
check regression-test test: build
${WRKSRC}/msvmocas -c 10 -v 1 ${WRKSRC}/data/example4_train.light \