aboutsummaryrefslogtreecommitdiff
path: root/math/libtommath
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2016-03-09 07:46:56 +0000
committerWen Heping <wen@FreeBSD.org>2016-03-09 07:46:56 +0000
commit8c2f29747a851ccdd65730cf192fab1f7f7efcee (patch)
tree77f0e2d790072f18a435b704409b61f285ec37a4 /math/libtommath
parent9923887cd7da43d47b3f0e6b54fcb7e6cb918d3f (diff)
downloadports-8c2f29747a851ccdd65730cf192fab1f7f7efcee.tar.gz
ports-8c2f29747a851ccdd65730cf192fab1f7f7efcee.zip
- Update to 1.0
PR: 207266 Submitted by: takefu@airport.fm
Notes
Notes: svn path=/head/; revision=410694
Diffstat (limited to 'math/libtommath')
-rw-r--r--math/libtommath/Makefile17
-rw-r--r--math/libtommath/distinfo4
-rw-r--r--math/libtommath/files/patch-makefile57
-rw-r--r--math/libtommath/files/patch-makefile.include47
4 files changed, 55 insertions, 70 deletions
diff --git a/math/libtommath/Makefile b/math/libtommath/Makefile
index 62fc3f9322ef..45b2b3a60523 100644
--- a/math/libtommath/Makefile
+++ b/math/libtommath/Makefile
@@ -1,17 +1,16 @@
# $FreeBSD$
PORTNAME= libtommath
-PORTVERSION= 0.42.0
-PORTREVISION= 2
+PORTVERSION= 1.0
CATEGORIES= math
-MASTER_SITES= http://libtom.net/files/
+MASTER_SITES= https://github.com/libtom/libtommath/releases/download/v${PORTVERSION}/
DISTNAME= ltm-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Comprehensive, modular, and portable mathematical routines
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= gmake tar:bzip2
+USES= gmake tar:xz
ALL_TARGET= default
CFLAGS+= -fPIC
PORTDOCS= *
@@ -24,14 +23,10 @@ OPTIONS_DEFINE= DOCS SHARED
SHARED_DESC= Build shared library
SHARED_USES= libtool:build
SHARED_USE= LDCONFIG=yes
-SHARED_PLIST_FILES= lib/libtommath.so lib/libtommath.so.0 lib/libtommath.so.0.0.41
+SHARED_PLIST_FILES= lib/libtommath.so lib/libtommath.so.1 lib/libtommath.so.1.0.0
SHARED_VARS= MAKEFILE=makefile.shared
SHARED_VARS_OFF= MAKEFILE=makefile
-post-patch:
- ${REINPLACE_CMD} -e 's|gcc|${CC}|g' ${WRKSRC}/makefile.shared
- ${REINPLACE_CMD} -e 's|DESTDIR=|DESTDIR?=| ; s|-g $$(GROUP) -o $$(USER)||' ${WRKSRC}/${MAKEFILE}
-
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/bn.pdf ${STAGEDIR}${DOCSDIR}
@@ -39,9 +34,9 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/tommath.pdf ${STAGEDIR}${DOCSDIR}
post-install-SHARED-on:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtommath.so.0
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtommath.so.1
-regression-test:
+do-test:
(cd ${WRKSRC}; \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} -f ${MAKEFILE} mtest test; \
./mtest/mtest | ./test)
diff --git a/math/libtommath/distinfo b/math/libtommath/distinfo
index c259cd7e2541..e60c6709900c 100644
--- a/math/libtommath/distinfo
+++ b/math/libtommath/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ltm-0.42.0.tar.bz2) = 7b5c258304c34ac5901cfddb9f809b9b3b8ac7d04f700cf006ac766a923eb217
-SIZE (ltm-0.42.0.tar.bz2) = 1968961
+SHA256 (ltm-1.0.tar.xz) = 993a7df9ee091fca430cdde3263df57d88ef62af8103903214da49fc51bbb56c
+SIZE (ltm-1.0.tar.xz) = 2191540
diff --git a/math/libtommath/files/patch-makefile b/math/libtommath/files/patch-makefile
deleted file mode 100644
index 8e262a3dadab..000000000000
--- a/math/libtommath/files/patch-makefile
+++ /dev/null
@@ -1,57 +0,0 @@
---- makefile.bak 2010-07-30 12:05:21.219322050 +0200
-+++ makefile 2010-07-30 12:07:19.588144344 +0200
-@@ -14,7 +14,7 @@
- ifndef IGNORE_SPEED
-
- #for speed
--CFLAGS += -O3 -funroll-loops
-+CFLAGS += -funroll-loops
-
- #for size
- #CFLAGS += -Os
-@@ -53,9 +53,9 @@
- #INCPATH-The directory to install the header files for libtommath.
- #DATAPATH-The directory to install the pdf docs.
- DESTDIR=
--LIBPATH=/usr/lib
--INCPATH=/usr/include
--DATAPATH=/usr/share/doc/libtommath/pdf
-+LIBPATH=${PREFIX}/lib
-+INCPATH=${PREFIX}/include
-+DATAPATH=${DOCSDIR}/pdf
-
- OBJECTS=bncore.o bn_mp_init.o bn_mp_clear.o bn_mp_exch.o bn_mp_grow.o bn_mp_shrink.o \
- bn_mp_clamp.o bn_mp_zero.o bn_mp_set.o bn_mp_set_int.o bn_mp_init_size.o bn_mp_copy.o \
---- makefile.shared.orig 2010-07-23 16:27:20.000000000 +0200
-+++ makefile.shared 2013-04-18 15:26:25.000000000 +0200
-@@ -10,7 +10,7 @@
- ifndef IGNORE_SPEED
-
- #for speed
--CFLAGS += -O3 -funroll-loops
-+CFLAGS += -funroll-loops
-
- #for size
- #CFLAGS += -Os
-@@ -48,9 +48,9 @@
- #INCPATH-The directory to install the header files for libtommath.
- #DATAPATH-The directory to install the pdf docs.
- DESTDIR=
--LIBPATH=/usr/lib
--INCPATH=/usr/include
--DATAPATH=/usr/share/doc/libtommath/pdf
-+LIBPATH=${PREFIX}/lib
-+INCPATH=${PREFIX}/include
-+DATAPATH=${DOCSDIR}/pdf
-
- OBJECTS=bncore.o bn_mp_init.o bn_mp_clear.o bn_mp_exch.o bn_mp_grow.o bn_mp_shrink.o \
- bn_mp_clamp.o bn_mp_zero.o bn_mp_set.o bn_mp_set_int.o bn_mp_init_size.o bn_mp_copy.o \
-@@ -93,7 +93,7 @@
-
- test: $(LIBNAME) demo/demo.o
- gcc $(CFLAGS) -c demo/demo.c -o demo/demo.o
-- libtool --mode=link gcc -o test demo/demo.o $(LIBNAME_S)
-+ libtool --mode=link gcc -o test demo/demo.o .libs/$(LIBNAME_S)
-
- mtest: test
- cd mtest ; gcc $(CFLAGS) mtest.c -o mtest
diff --git a/math/libtommath/files/patch-makefile.include b/math/libtommath/files/patch-makefile.include
new file mode 100644
index 000000000000..9aa4bb7d7bf5
--- /dev/null
+++ b/math/libtommath/files/patch-makefile.include
@@ -0,0 +1,47 @@
+--- makefile.include.orig 2016-02-03 18:07:27 UTC
++++ makefile.include
+@@ -14,15 +14,15 @@ ifndef PREFIX
+ PREFIX=
+ endif
+
+-ifeq ($(CC),cc)
+- CC = $(PREFIX)gcc
+-endif
+-LD=$(PREFIX)ld
+-AR=$(PREFIX)ar
+-RANLIB=$(PREFIX)ranlib
++#ifeq ($(CC),cc)
++# CC = $(PREFIX)gcc
++#endif
++#LD=$(PREFIX)ld
++AR=$(shell which ar)
++RANLIB=$(shell which ranlib)
+
+ ifndef MAKE
+- MAKE=make
++ MAKE=$(shell which gmake)
+ endif
+
+ CFLAGS += -I./ -Wall -Wsign-compare -Wextra -Wshadow
+@@ -55,7 +55,7 @@ endif # COMPILE_SIZE
+ endif # COMPILE_DEBUG
+
+ # adjust coverage set
+-ifneq ($(filter $(shell arch), i386 i686 x86_64 amd64 ia64),)
++ifneq ($(filter $(shell /sbin/sysctl -b hw.machine_arch), i386 i686 x86_64 amd64 ia64),)
+ COVERAGE = test_standalone timing
+ COVERAGE_APP = ./test && ./ltmtest
+ else
+@@ -71,9 +71,9 @@ test_standalone: CFLAGS+=-DLTM_DEMO_TEST
+ #LIBPATH-The directory for libtommath to be installed to.
+ #INCPATH-The directory to install the header files for libtommath.
+ #DATAPATH-The directory to install the pdf docs.
+-LIBPATH?=/usr/lib
+-INCPATH?=/usr/include
+-DATAPATH?=/usr/share/doc/libtommath/pdf
++LIBPATH?=$(PREFIX)/lib
++INCPATH?=$(PREFIX)/include
++DATAPATH?=$(DOCSDIR)/pdf
+
+ #make the code coverage of the library
+ #