aboutsummaryrefslogtreecommitdiff
path: root/math/libtommath
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2019-01-31 11:50:23 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2019-01-31 11:50:23 +0000
commitdac7957e58712bf9dba0d3d5dee24eb37f2ddbb4 (patch)
tree0ae8eff356a80b9822d6349c45a3b25a09a8c090 /math/libtommath
parent113c37b5e253fa1b83ca7d95f9f793ffb6490d50 (diff)
downloadports-dac7957e58712bf9dba0d3d5dee24eb37f2ddbb4.tar.gz
ports-dac7957e58712bf9dba0d3d5dee24eb37f2ddbb4.zip
math/libtommath: update to 1.1.0
Notes
Notes: svn path=/head/; revision=491708
Diffstat (limited to 'math/libtommath')
-rw-r--r--math/libtommath/Makefile18
-rw-r--r--math/libtommath/distinfo6
-rw-r--r--math/libtommath/files/patch-makefile__include.mk34
3 files changed, 12 insertions, 46 deletions
diff --git a/math/libtommath/Makefile b/math/libtommath/Makefile
index b03329c5fad6..c08f0c95619a 100644
--- a/math/libtommath/Makefile
+++ b/math/libtommath/Makefile
@@ -1,11 +1,11 @@
# $FreeBSD$
PORTNAME= libtommath
-PORTVERSION= 1.0.1
-PORTREVISION= 1
+DISTVERSION= 1.1.0
+PORTREVISION= 0
CATEGORIES= math
-MASTER_SITES= https://github.com/libtom/libtommath/releases/download/v${PORTVERSION}/
-DISTNAME= ltm-${PORTVERSION}
+MASTER_SITES= https://github.com/libtom/libtommath/releases/download/v${DISTVERSION}/
+DISTNAME= ltm-${DISTVERSION}
MAINTAINER= gahr@FreeBSD.org
COMMENT= Comprehensive, modular, and portable mathematical routines
@@ -13,7 +13,7 @@ COMMENT= Comprehensive, modular, and portable mathematical routines
LICENSE= PD WTFPL
LICENSE_COMB= dual
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
USES= gmake tar:xz
ALL_TARGET= default
CFLAGS+= -fPIC
@@ -30,8 +30,8 @@ SHARED_DESC= Build shared library
SHARED_USES= libtool:build
SHARED_USE= LDCONFIG=yes
SHARED_PLIST_FILES= lib/libtommath.so \
- lib/libtommath.so.${PORTVERSION:R:R} \
- lib/libtommath.so.${PORTVERSION} \
+ lib/libtommath.so.${DISTVERSION:R:R} \
+ lib/libtommath.so.${DISTVERSION} \
libdata/pkgconfig/libtommath.pc
SHARED_VARS= MAKEFILE=makefile.shared
SHARED_VARS_OFF= MAKEFILE=makefile
@@ -43,11 +43,11 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/tommath.pdf ${STAGEDIR}${DOCSDIR}
post-install-SHARED-on:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtommath.so.${PORTVERSION}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtommath.so.${DISTVERSION}
do-test:
(cd ${WRKSRC}; \
- ${SETENV} ${MAKE_ENV} ${MAKE_CMD} -f ${MAKEFILE} mtest test; \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} -f ${MAKEFILE} mtest/mtest test; \
./mtest/mtest | ./test)
.include <bsd.port.mk>
diff --git a/math/libtommath/distinfo b/math/libtommath/distinfo
index 7b79da457099..cffad92d6751 100644
--- a/math/libtommath/distinfo
+++ b/math/libtommath/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1505472472
-SHA256 (ltm-1.0.1.tar.xz) = 47032fb39d698ce4cf9c9c462c198e6b08790ce8203ad1224086b9b978636c69
-SIZE (ltm-1.0.1.tar.xz) = 2210120
+TIMESTAMP = 1548935126
+SHA256 (ltm-1.1.0.tar.xz) = 90466c88783d1fe9f5c2364a69f5479f10d73ed616011be6196f35f7f1537ead
+SIZE (ltm-1.1.0.tar.xz) = 2125456
diff --git a/math/libtommath/files/patch-makefile__include.mk b/math/libtommath/files/patch-makefile__include.mk
deleted file mode 100644
index e8ac6d3375c3..000000000000
--- a/math/libtommath/files/patch-makefile__include.mk
+++ /dev/null
@@ -1,34 +0,0 @@
---- makefile_include.mk.orig 2017-08-29 20:27:36 UTC
-+++ makefile_include.mk
-@@ -17,16 +17,16 @@ ifndef CROSS_COMPILE
- CROSS_COMPILE=
- endif
-
--ifeq ($(CC),cc)
-- CC = $(CROSS_COMPILE)gcc
--endif
-+#ifeq ($(CC),cc)
-+# CC = $(CROSS_COMPILE)gcc
-+#endif
- LD=$(CROSS_COMPILE)ld
- AR=$(CROSS_COMPILE)ar
- RANLIB=$(CROSS_COMPILE)ranlib
-
--ifndef MAKE
-- MAKE=make
--endif
-+#ifndef MAKE
-+# MAKE=make
-+#endif
-
- CFLAGS += -I./ -Wall -Wsign-compare -Wextra -Wshadow
-
-@@ -65,7 +65,7 @@ CFLAGS += -Wno-nullability-completeness
- endif
-
- # adjust coverage set
--ifneq ($(filter $(shell arch), i386 i686 x86_64 amd64 ia64),)
-+ifneq ($(filter $(shell /sbin/sysctl -b hw.machine_arch), i386 i686 x86_64 amd64 ia64),)
- COVERAGE = test_standalone timing
- COVERAGE_APP = ./test && ./ltmtest
- else