aboutsummaryrefslogtreecommitdiff
path: root/math/libtommath
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-02-14 08:27:10 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-02-14 08:27:10 +0000
commite87ee9e2a83eaad255e7b7c8715188d02f7179c1 (patch)
tree12b56c0fdcbdf354d908e0513d63c4936c0e57db /math/libtommath
parent3dcf0976118eaf6c367ab2c717c7cba0f395449b (diff)
downloadports-e87ee9e2a83eaad255e7b7c8715188d02f7179c1.tar.gz
ports-e87ee9e2a83eaad255e7b7c8715188d02f7179c1.zip
- STAGE-clean
- STRIP shared library
Notes
Notes: svn path=/head/; revision=344166
Diffstat (limited to 'math/libtommath')
-rw-r--r--math/libtommath/Makefile25
1 files changed, 13 insertions, 12 deletions
diff --git a/math/libtommath/Makefile b/math/libtommath/Makefile
index 38991c803285..220740172b9f 100644
--- a/math/libtommath/Makefile
+++ b/math/libtommath/Makefile
@@ -13,8 +13,8 @@ OPTIONS_DEFINE= DOCS SHARED
SHARED_DESC= Build shared library
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USES= gmake
USE_BZIP2= yes
-USE_GMAKE= yes
ALL_TARGET= default
CFLAGS+= -fPIC
PORTDOCS= *
@@ -22,11 +22,11 @@ PORTDOCS= *
PLIST_FILES= include/tommath.h include/tommath_class.h \
include/tommath_superclass.h lib/libtommath.a
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
${REINPLACE_CMD} -e 's|gcc|${CC}|g' ${WRKSRC}/makefile.shared
+ ${REINPLACE_CMD} -e 's|DESTDIR=|DESTDIR?=|' ${WRKSRC}/${MAKEFILE}
.if ${PORT_OPTIONS:MSHARED}
BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool
@@ -37,17 +37,18 @@ MAKEFILE= makefile.shared
MAKEFILE= makefile
.endif
-.if ${PORT_OPTIONS:MDOCS}
post-install:
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/bn.pdf ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/poster.pdf ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/tommath.pdf ${DOCSDIR}/
+.if ${PORT_OPTIONS:MSHARED}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtommath.so.0
.endif
-
-#regression-test:
-# (cd ${WRKSRC}; \
-# ${SETENV} ${MAKE_ENV} ${GMAKE} -f ${MAKEFILE} mtest test; \
-# ./mtest/mtest | ./test)
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/bn.pdf ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/poster.pdf ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/tommath.pdf ${STAGEDIR}${DOCSDIR}
+
+regression-test:
+ (cd ${WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} -f ${MAKEFILE} mtest test; \
+ ./mtest/mtest | ./test)
.include <bsd.port.mk>