aboutsummaryrefslogtreecommitdiff
path: root/math/libxlsxwriter
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2017-04-20 09:16:41 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2017-04-20 09:16:41 +0000
commitf2d70258003f5c434e3107752a42fafa7c8626d9 (patch)
treea31736c102161f775d7bea1bfcfcc5140d1f5b60 /math/libxlsxwriter
parent16ca1839e2384b78c64979f30d15697c5f2e418a (diff)
downloadports-f2d70258003f5c434e3107752a42fafa7c8626d9.tar.gz
ports-f2d70258003f5c434e3107752a42fafa7c8626d9.zip
libxlsxwriter is a C library that can be used to write text, numbers, formulas
and hyperlinks to multiple worksheets in an Excel 2007+ XLSX file. It supports features such as: * 100% compatible Excel XLSX files. * Full Excel formatting. * Merged cells. * Defined names. * Autofilters. * Charts. * Worksheet PNG/JPEG images. * Memory optimization mode for writing large files. * Source code available on GitHub. * FreeBSD License. * ANSI C. * Compiles for 32 and 64 bit. * The only dependency is on zlib. WWW: http://libxlsxwriter.github.io/
Notes
Notes: svn path=/head/; revision=438935
Diffstat (limited to 'math/libxlsxwriter')
-rw-r--r--math/libxlsxwriter/Makefile23
-rw-r--r--math/libxlsxwriter/distinfo3
-rw-r--r--math/libxlsxwriter/files/patch-Makefile13
-rw-r--r--math/libxlsxwriter/files/patch-src_Makefile34
-rw-r--r--math/libxlsxwriter/pkg-descr19
-rw-r--r--math/libxlsxwriter/pkg-plist27
6 files changed, 119 insertions, 0 deletions
diff --git a/math/libxlsxwriter/Makefile b/math/libxlsxwriter/Makefile
new file mode 100644
index 000000000000..ff50137f42f0
--- /dev/null
+++ b/math/libxlsxwriter/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= libxlsxwriter
+PORTVERSION= 0.6.9
+DISTVERSIONPREFIX= RELEASE_
+CATEGORIES= math devel
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= C library for creating Excel XLSX files
+
+LICENSE= BSD2CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= jmcnamara
+
+USE_LDCONFIG= yes
+USES= gmake
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libxlsxwriter.so.0
+ ${LN} -s libxlsxwriter.so.0 ${STAGEDIR}${PREFIX}/lib/libxlsxwriter.so
+
+.include <bsd.port.mk>
diff --git a/math/libxlsxwriter/distinfo b/math/libxlsxwriter/distinfo
new file mode 100644
index 000000000000..79a8ae993593
--- /dev/null
+++ b/math/libxlsxwriter/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1492678168
+SHA256 (jmcnamara-libxlsxwriter-RELEASE_0.6.9_GH0.tar.gz) = 260bc1a3f3cfc36fd61b59edbf43ba3731fd210ff27ef61a20464bcd6ab1f389
+SIZE (jmcnamara-libxlsxwriter-RELEASE_0.6.9_GH0.tar.gz) = 12188770
diff --git a/math/libxlsxwriter/files/patch-Makefile b/math/libxlsxwriter/files/patch-Makefile
new file mode 100644
index 000000000000..e570cd674104
--- /dev/null
+++ b/math/libxlsxwriter/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig 2017-01-30 00:30:31 UTC
++++ Makefile
+@@ -84,8 +84,8 @@ docs:
+
+ # Simple minded install.
+ install:
+- $(Q)cp -r include/* /usr/include
+- $(Q)cp lib/* /usr/lib
++ $(Q)cp -r include/* $(DESTDIR)$(PREFIX)/include
++ $(Q)cp lib/* $(DESTDIR)$(PREFIX)/lib
+
+ # Simpler minded uninstall.
+ uninstall:
diff --git a/math/libxlsxwriter/files/patch-src_Makefile b/math/libxlsxwriter/files/patch-src_Makefile
new file mode 100644
index 000000000000..381e821df971
--- /dev/null
+++ b/math/libxlsxwriter/files/patch-src_Makefile
@@ -0,0 +1,34 @@
+--- src/Makefile.orig 2017-01-30 00:30:31 UTC
++++ src/Makefile
+@@ -39,7 +39,7 @@ endif
+
+ # Library names.
+ LIBXLSXWRITER_A = libxlsxwriter.a
+-LIBXLSXWRITER_SO = libxlsxwriter.so
++LIBXLSXWRITER_SO = libxlsxwriter.so.0
+
+ # Library with additional non-static functions for testing.
+ LIBXLSXWRITER_TO = libxlsxwriter_test.a
+@@ -49,7 +49,7 @@ ARFLAGS = rc
+
+ # Flags passed to dynamic linker.
+ FPIC = -fPIC
+-SOFLAGS = -shared $(FPIC)
++SOFLAGS = -shared $(FPIC) -Wl,-soname=${LIBXLSXWRITER_SO}
+
+ # Get Env/OS name.
+ UNAME := $(shell uname)
+@@ -101,11 +101,11 @@ $(LIBXLSXWRITER_A) : $(OBJS)
+
+ # The dynamic library.
+ ifeq ($(findstring m32,$(CFLAGS)),m32)
+-ARCH = -m32
++XSLX_ARCH = -m32
+ endif
+
+ $(LIBXLSXWRITER_SO) : $(SOBJS)
+- $(Q)$(CC) $(SOFLAGS) $(ARCH) -o $@ $(MINIZIP_DIR)/ioapi.so $(MINIZIP_DIR)/zip.so $(TMPFILEPLUS_SO) $^ -lz
++ $(Q)$(CC) $(SOFLAGS) $(XLSX_ARCH) -o $@ $(MINIZIP_DIR)/ioapi.so $(MINIZIP_DIR)/zip.so $(TMPFILEPLUS_SO) $^ -lz
+
+ # The test library.
+ $(LIBXLSXWRITER_TO) : $(TOBJS)
diff --git a/math/libxlsxwriter/pkg-descr b/math/libxlsxwriter/pkg-descr
new file mode 100644
index 000000000000..043f817d7e71
--- /dev/null
+++ b/math/libxlsxwriter/pkg-descr
@@ -0,0 +1,19 @@
+libxlsxwriter is a C library that can be used to write text, numbers, formulas
+and hyperlinks to multiple worksheets in an Excel 2007+ XLSX file. It supports
+features such as:
+
+* 100% compatible Excel XLSX files.
+* Full Excel formatting.
+* Merged cells.
+* Defined names.
+* Autofilters.
+* Charts.
+* Worksheet PNG/JPEG images.
+* Memory optimization mode for writing large files.
+* Source code available on GitHub.
+* FreeBSD License.
+* ANSI C.
+* Compiles for 32 and 64 bit.
+* The only dependency is on zlib.
+
+WWW: http://libxlsxwriter.github.io/
diff --git a/math/libxlsxwriter/pkg-plist b/math/libxlsxwriter/pkg-plist
new file mode 100644
index 000000000000..2edf753c6799
--- /dev/null
+++ b/math/libxlsxwriter/pkg-plist
@@ -0,0 +1,27 @@
+include/xlsxwriter.h
+include/xlsxwriter/app.h
+include/xlsxwriter/chart.h
+include/xlsxwriter/common.h
+include/xlsxwriter/content_types.h
+include/xlsxwriter/core.h
+include/xlsxwriter/custom.h
+include/xlsxwriter/drawing.h
+include/xlsxwriter/format.h
+include/xlsxwriter/hash_table.h
+include/xlsxwriter/packager.h
+include/xlsxwriter/relationships.h
+include/xlsxwriter/shared_strings.h
+include/xlsxwriter/styles.h
+include/xlsxwriter/theme.h
+include/xlsxwriter/third_party/ioapi.h
+include/xlsxwriter/third_party/queue.h
+include/xlsxwriter/third_party/tmpfileplus.h
+include/xlsxwriter/third_party/tree.h
+include/xlsxwriter/third_party/zip.h
+include/xlsxwriter/utility.h
+include/xlsxwriter/workbook.h
+include/xlsxwriter/worksheet.h
+include/xlsxwriter/xmlwriter.h
+lib/libxlsxwriter.a
+lib/libxlsxwriter.so
+lib/libxlsxwriter.so.0