aboutsummaryrefslogtreecommitdiff
path: root/math/lp_solve
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2003-07-19 04:33:07 +0000
committerMaho Nakata <maho@FreeBSD.org>2003-07-19 04:33:07 +0000
commite3b29ff95b9948af58787da4589e39192efb762f (patch)
treec650979cb82f33b1f07f191878e40823f4d826db /math/lp_solve
parentefc116207eb088b65e3f4783ecfe77f71ba034e1 (diff)
downloadports-e3b29ff95b9948af58787da4589e39192efb762f.tar.gz
ports-e3b29ff95b9948af58787da4589e39192efb762f.zip
lp_solve, A free linear programming solver that can process
standard MPL format. This lp_solve versions is released under the LGPL license PR: 53649 Submitted by: Pedro F. Giffuni <giffunip@yahoo.com>
Notes
Notes: svn path=/head/; revision=85171
Diffstat (limited to 'math/lp_solve')
-rw-r--r--math/lp_solve/Makefile40
-rw-r--r--math/lp_solve/distinfo1
-rw-r--r--math/lp_solve/files/patch-Makefile26
-rw-r--r--math/lp_solve/files/patch-lpkit.h10
-rw-r--r--math/lp_solve/pkg-descr11
-rw-r--r--math/lp_solve/pkg-plist41
6 files changed, 129 insertions, 0 deletions
diff --git a/math/lp_solve/Makefile b/math/lp_solve/Makefile
new file mode 100644
index 000000000000..1ab1d4d9ae7a
--- /dev/null
+++ b/math/lp_solve/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: lp_solve
+# Date created: 31 June 2003
+# Whom: Pedro F. Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lp_solve
+PORTVERSION= 4.0
+CATEGORIES= math
+MASTER_SITES= ftp://ftp.ics.ele.tue.nl/pub/lp_solve/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Linear Programming Solver
+
+MAN1= lp_solve.1
+
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,%%CC%%,${CC},g ; \
+ s,%%CFLAGS%%,${CFLAGS},g' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/lp_solve ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/lp2mps ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/mps2lp ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/lp_solve.1 ${PREFIX}/man/man1
+.ifndef NOPORTDOCS
+ ${MKDIR} ${DOCSDIR}
+ ${CP} $(WRKSRC)/HARTMUT_DOCUMENTATION ${DOCSDIR}
+ ${CP} $(WRKSRC)/MPS.description ${DOCSDIR}
+ ${CP} $(WRKSRC)/*.pdf ${DOCSDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/demo ${EXAMPLESDIR}
+ ${CP} -R $(WRKSRC)/lp_examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/lp_solve/distinfo b/math/lp_solve/distinfo
new file mode 100644
index 000000000000..9508f935e762
--- /dev/null
+++ b/math/lp_solve/distinfo
@@ -0,0 +1 @@
+MD5 (lp_solve_4.0.tar.gz) = 58892f708d7f78664bce80c1ebc250f9
diff --git a/math/lp_solve/files/patch-Makefile b/math/lp_solve/files/patch-Makefile
new file mode 100644
index 000000000000..e0239c9b50a0
--- /dev/null
+++ b/math/lp_solve/files/patch-Makefile
@@ -0,0 +1,26 @@
+--- Makefile.orig Sat Jun 7 14:05:47 2003
++++ Makefile Sat Jun 7 14:37:17 2003
+@@ -1,4 +1,4 @@
+-CC= gcc
++CC= %%CC%%
+
+ #should be OK in most situations:
+ #CFLAGS= -O
+@@ -9,7 +9,7 @@
+ #CFLAGS= -g -Aa -D_POSIX_SOURCE -DCHECK +FP VZOUiD
+
+ # nice for gcc
+-CFLAGS= -O3 -Wall -pedantic -ansi
++CFLAGS= %%CFLAGS%% -DCHECK
+ #CFLAGS= -g -Wall -pedantic -ansi
+
+ # Option -DCHECK checks for numerical problems during rounding of numbers.
+@@ -39,7 +39,7 @@
+ #ANSI math lib
+ #MATHLIB= -lM
+ #non-ANSI math lib, should also work
+-MATHLIB= -lm
++MATHLIB= -lm -lcompat
+
+ LPKSRC.c= lpkit.c solve.c debug.c read.c readmps.c hash.c presolve.c
+ LEXFILE.l= lex.l
diff --git a/math/lp_solve/files/patch-lpkit.h b/math/lp_solve/files/patch-lpkit.h
new file mode 100644
index 000000000000..c3f1673e9b70
--- /dev/null
+++ b/math/lp_solve/files/patch-lpkit.h
@@ -0,0 +1,10 @@
+--- lpkit.h.orig Sat Jun 7 14:25:47 2003
++++ lpkit.h Sat Jun 7 14:30:27 2003
+@@ -260,6 +260,7 @@
+ #define MAX_WARN_COUNT 20
+
+ #ifdef CHECK
++extern int Warn_count;
+ #define my_round(val, eps) { \
+ REAL absv; \
+ absv = ((val) < 0 ? -(val) : (val)); \
diff --git a/math/lp_solve/pkg-descr b/math/lp_solve/pkg-descr
new file mode 100644
index 000000000000..81109f09bbe9
--- /dev/null
+++ b/math/lp_solve/pkg-descr
@@ -0,0 +1,11 @@
+This is the lp_solve, A free linear programming solver that can process
+standard MPL format.
+This lp_solve versions is released under the LGPL license. See LGPL.txt
+
+bug reports, success stories and requests for changes are welcome at:
+
+Michel Berkelaar
+michel@ics.ele.tue.nl
+________
+NOTE: Current development of this tool is done on Yahoo's "lp_solve"
+group.
diff --git a/math/lp_solve/pkg-plist b/math/lp_solve/pkg-plist
new file mode 100644
index 000000000000..779a60709fd8
--- /dev/null
+++ b/math/lp_solve/pkg-plist
@@ -0,0 +1,41 @@
+bin/lp2mps
+bin/lp_solve
+bin/mps2lp
+%%PORTDOCS%%%%DOCSDIR%%/HARTMUT_DOCUMENTATION
+%%PORTDOCS%%%%DOCSDIR%%/MPS.description
+%%PORTDOCS%%%%DOCSDIR%%/SOSInterpolation.pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%%%EXAMPLESDIR%%/demo
+%%PORTDOCS%%%%EXAMPLESDIR%%/demo_lag.lp
+%%PORTDOCS%%%%EXAMPLESDIR%%/demo_lag.out
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex1.lp
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex1.out
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex1sc.mps
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex1sc.out
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex1sos.mps
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex1sos.out
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex2.lp
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex2.out
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex2sc.mps
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex2sc.out
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex2sos.mps
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex2sos.out
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex3.lp
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex3.out
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex3sos.mps
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex3sos.out
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex4.lp
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex4.out
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex4sos.mps
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex4sos.out
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex5.lp
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex5.out
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex5sos.mps
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex5sos.out
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex6.lp
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex6.out
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex6sos.mps
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex6sos.out
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex7.lp
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex7.out
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%