aboutsummaryrefslogtreecommitdiff
path: root/math/ltl
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-10-07 20:43:52 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-10-07 20:43:52 +0000
commitffdf4a418b5a53ea72d940bee569c685408b3f02 (patch)
tree84112badc93dea336235f731eff1a567b128c442 /math/ltl
parent01aeb9e835b1143c5f294f9123edb0d39346e159 (diff)
downloadports-ffdf4a418b5a53ea72d940bee569c685408b3f02.tar.gz
ports-ffdf4a418b5a53ea72d940bee569c685408b3f02.zip
Notes
Diffstat (limited to 'math/ltl')
-rw-r--r--math/ltl/Makefile38
-rw-r--r--math/ltl/distinfo3
-rw-r--r--math/ltl/pkg-descr13
-rw-r--r--math/ltl/pkg-message9
-rw-r--r--math/ltl/pkg-plist89
5 files changed, 152 insertions, 0 deletions
diff --git a/math/ltl/Makefile b/math/ltl/Makefile
new file mode 100644
index 000000000000..4d7922c2318e
--- /dev/null
+++ b/math/ltl/Makefile
@@ -0,0 +1,38 @@
+# ex:ts=8
+# Ports collection makefile for: ltl
+# Date created: Sep 11, 2006
+# Whom: rossiya
+#
+# $FreeBSD$
+#
+
+PORTNAME= ltl
+PORTVERSION= 1.7.10
+CATEGORIES= math
+MASTER_SITES= http://www.mpe.mpg.de/~drory/ltl/
+
+MAINTAINER= rossiya@gmail.com
+COMMENT= A C++ class SSE library for scientific computing
+
+USE_GCC= 3.2+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-cxx=gcc --disable-doxygen --prefix=${PREFIX} --includedir=${PREFIX}/include/LTL
+MAKE_ENV= prefix=${TARGETDIR} exec_prefix=${TARGETDIR}
+MAKE_ARGS+= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
+ AUTOHEADER="${TRUE}"
+INSTALL_TARGET= install install-data check distdir
+
+PORTDOCS= doc/html/*[h.][tp][mn][lg]
+PLIST_FILES= `ls ${WRKSRC}/doc/html/*[h.][tp][mn][lg] | ${SED} -e 's!${WRKSRC}/doc/html/!%%PORTDOCS%%%%DOCSDIR%%/!g'`
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && pwd && ${INSTALL_DATA} -v ${PORTDOCS} ${DOCSDIR}
+.endif
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/math/ltl/distinfo b/math/ltl/distinfo
new file mode 100644
index 000000000000..af5ccd23f434
--- /dev/null
+++ b/math/ltl/distinfo
@@ -0,0 +1,3 @@
+MD5 (ltl-1.7.10.tar.gz) = ebd6dce461a56d4d696cb09219174c33
+SHA256 (ltl-1.7.10.tar.gz) = ee9cc0b8acb1a4aef6a9b5c219fa1c218db0c1a060969544599c662410d984e3
+SIZE (ltl-1.7.10.tar.gz) = 1244938
diff --git a/math/ltl/pkg-descr b/math/ltl/pkg-descr
new file mode 100644
index 000000000000..03a68417bcc2
--- /dev/null
+++ b/math/ltl/pkg-descr
@@ -0,0 +1,13 @@
+LTL is a C++ class template library for scientific computing which provides
+high performance via SSE3 floating point support for vector operations.
+
+Useful for array processing, image processing, FITS and ASCII I/O, and linear
+algebra (astronomical and scientific computing, in short). LTL provides
+dynamic arrays of up to 5-dimensions, subarrays and slicing, support for fixed
+size vectors and matrices including basic linear algebra operations, expression
+templates based evaluation, and I/O facilities for ascii and FITS format files.
+
+Users of the boost and blitz++ library may find the cross-pollination of these
+unique features to be fruitful.
+
+WWW: http://www.mpe.mpg.de/~drory/ltl/
diff --git a/math/ltl/pkg-message b/math/ltl/pkg-message
new file mode 100644
index 000000000000..e2c01529bfd4
--- /dev/null
+++ b/math/ltl/pkg-message
@@ -0,0 +1,9 @@
+==============================================================================
+
+Library headers are installed at LTL", so use "#include <LTL/file.h>" form for
+inclusion in your programs.
+
+There is no support yet for X11 libraries. Let me know if you have
+interest/patches.
+
+==============================================================================
diff --git a/math/ltl/pkg-plist b/math/ltl/pkg-plist
new file mode 100644
index 000000000000..3ce1b74a97e4
--- /dev/null
+++ b/math/ltl/pkg-plist
@@ -0,0 +1,89 @@
+include/LTL/ltl/acconfig.h
+include/LTL/ltl/ascio.h
+include/LTL/ltl/config.h
+include/LTL/ltl/fits.h
+include/LTL/ltl/fitsio.h
+include/LTL/ltl/fmatrix.h
+include/LTL/ltl/fmatrix/fmatmat.h
+include/LTL/ltl/fmatrix/fmatrix_methods.h
+include/LTL/ltl/fmatrix/fmatrix_ops.h
+include/LTL/ltl/fmatrix/fmatvec.h
+include/LTL/ltl/fmatrix/fmbool.h
+include/LTL/ltl/fmatrix/fmexpr.h
+include/LTL/ltl/fmatrix/fmexpr_ops.h
+include/LTL/ltl/fmatrix/fmiter.h
+include/LTL/ltl/fmatrix/fmtloops.h
+include/LTL/ltl/fmatrix/fmtranspose.h
+include/LTL/ltl/fmatrix/gaussj.h
+include/LTL/ltl/fmatrix/marquardt.h
+include/LTL/ltl/fmatrix/mrqfuncs.h
+include/LTL/ltl/fmatrix/polynomfit.h
+include/LTL/ltl/fvector.h
+include/LTL/ltl/fvector/fvbool.h
+include/LTL/ltl/fvector/fvdot.h
+include/LTL/ltl/fvector/fvector_methods.h
+include/LTL/ltl/fvector/fvector_ops.h
+include/LTL/ltl/fvector/fvexpr.h
+include/LTL/ltl/fvector/fvexpr_ops.h
+include/LTL/ltl/fvector/fviter.h
+include/LTL/ltl/fvector/fvmemory.h
+include/LTL/ltl/fvector/fvtloops.h
+include/LTL/ltl/io/fits_card.h
+include/LTL/ltl/io/fits_const.h
+include/LTL/ltl/io/fits_data.h
+include/LTL/ltl/io/fits_header.h
+include/LTL/ltl/linlsqfit.h
+include/LTL/ltl/marray.h
+include/LTL/ltl/marray/cast.h
+include/LTL/ltl/marray/eval.h
+include/LTL/ltl/marray/eval_reduc.h
+include/LTL/ltl/marray/expr.h
+include/LTL/ltl/marray/expr_iter.h
+include/LTL/ltl/marray/expr_ops.h
+include/LTL/ltl/marray/index_iter.h
+include/LTL/ltl/marray/marray_iter.h
+include/LTL/ltl/marray/marray_methods.h
+include/LTL/ltl/marray/marray_ops.h
+include/LTL/ltl/marray/merge.h
+include/LTL/ltl/marray/reductions.h
+include/LTL/ltl/marray/shape.h
+include/LTL/ltl/marray/shape_iter.h
+include/LTL/ltl/marray/simplevec.h
+include/LTL/ltl/marray/slice.h
+include/LTL/ltl/marray/where.h
+include/LTL/ltl/marray_io.h
+include/LTL/ltl/misc/applicops.h
+include/LTL/ltl/misc/applicops_altivec.h
+include/LTL/ltl/misc/applicops_sse.h
+include/LTL/ltl/misc/exceptions.h
+include/LTL/ltl/misc/limits_hack.h
+include/LTL/ltl/misc/mdebug.h
+include/LTL/ltl/misc/memblock.h
+include/LTL/ltl/misc/range.h
+include/LTL/ltl/misc/staticinit.h
+include/LTL/ltl/misc/stdint_hack.h
+include/LTL/ltl/misc/swapbytes.h
+include/LTL/ltl/misc/type_promote.h
+include/LTL/ltl/nonlinlsqfit.h
+include/LTL/ltl/statistics.h
+include/LTL/ltl/util/command_line_reader.h
+include/LTL/ltl/util/config_file_reader.h
+include/LTL/ltl/util/option.h
+include/LTL/ltl/util/option_parser.h
+include/LTL/ltl/util/region.h
+include/LTL/ltl/util/stringfac.h
+include/LTL/ltl/util/timer.h
+include/LTL/ltl/util/u_exception.h
+include/LTL/ltl/util/utdate.h
+include/LTL/ltl/wcs.h
+lib/libltl.a
+share/nls/POSIX
+share/nls/en_US.US-ASCII
+@dirrm include/LTL/ltl/util
+@dirrm include/LTL/ltl/misc
+@dirrm include/LTL/ltl/marray
+@dirrm include/LTL/ltl/io
+@dirrm include/LTL/ltl/fvector
+@dirrm include/LTL/ltl/fmatrix
+@dirrm include/LTL/ltl
+@dirrm include/LTL