aboutsummaryrefslogtreecommitdiff
path: root/math/m4rie
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2020-04-04 17:50:39 +0000
committerThierry Thomas <thierry@FreeBSD.org>2020-04-04 17:50:39 +0000
commitba7c30e4a663537a473f0f908b40d845d3ac1b36 (patch)
treec6c80c5f771f0d5c82240b3c97f70e49b5330a2b /math/m4rie
parentd0bd8d08fe017c9ee5472a664a7bd4f8465460e4 (diff)
downloadports-ba7c30e4a663537a473f0f908b40d845d3ac1b36.tar.gz
ports-ba7c30e4a663537a473f0f908b40d845d3ac1b36.zip
Adding M4RIE, a library for fast arithmetic with dense matrices over GF(2^e)
for 2 <= e <= 16. To be used by SageMath.
Notes
Notes: svn path=/head/; revision=530697
Diffstat (limited to 'math/m4rie')
-rw-r--r--math/m4rie/Makefile27
-rw-r--r--math/m4rie/distinfo3
-rw-r--r--math/m4rie/pkg-descr5
-rw-r--r--math/m4rie/pkg-plist20
4 files changed, 55 insertions, 0 deletions
diff --git a/math/m4rie/Makefile b/math/m4rie/Makefile
new file mode 100644
index 000000000000..c3b4dfc8ebbc
--- /dev/null
+++ b/math/m4rie/Makefile
@@ -0,0 +1,27 @@
+# Created by: thierry@pompo.net
+# $FreeBSD$
+
+PORTNAME= M4RIE
+PORTVERSION= 20200115
+DISTVERSIONPREFIX= release-
+CATEGORIES= math
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Library for fast arithmetic with dense matrices over GF(2^e)
+
+LICENSE= GPLv2+
+
+LIB_DEPENDS= libm4ri.so:math/m4ri
+
+USE_GITHUB= yes
+GH_ACCOUNT= malb
+GH_PROJECT= ${PORTNAME:tl}
+
+USES= autoreconf libtool localbase pkgconfig
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+TEST_TARGET= check
+
+.include <bsd.port.mk>
diff --git a/math/m4rie/distinfo b/math/m4rie/distinfo
new file mode 100644
index 000000000000..a6c9147f9ff0
--- /dev/null
+++ b/math/m4rie/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1586021030
+SHA256 (malb-m4rie-release-20200115_GH0.tar.gz) = 2d38af6afe01cd1b21baa746cb108fb262d775cc5180883592a3971fb970f357
+SIZE (malb-m4rie-release-20200115_GH0.tar.gz) = 167356
diff --git a/math/m4rie/pkg-descr b/math/m4rie/pkg-descr
new file mode 100644
index 000000000000..d086dd9c6465
--- /dev/null
+++ b/math/m4rie/pkg-descr
@@ -0,0 +1,5 @@
+M4RIE is a library for fast arithmetic with dense matrices over GF(2^e) for
+2<=e<=16. The name stems from the fact that is relies heavily on M4RI.
+
+WWW: https://bitbucket.org/malb/m4rie/src/master/
+WWW: https://github.com/malb/m4rie
diff --git a/math/m4rie/pkg-plist b/math/m4rie/pkg-plist
new file mode 100644
index 000000000000..77df750d2305
--- /dev/null
+++ b/math/m4rie/pkg-plist
@@ -0,0 +1,20 @@
+include/m4rie/blm.h
+include/m4rie/conversion.h
+include/m4rie/echelonform.h
+include/m4rie/gf2e.h
+include/m4rie/gf2x.h
+include/m4rie/m4ri_functions.h
+include/m4rie/m4rie.h
+include/m4rie/mzd_poly.h
+include/m4rie/mzd_ptr.h
+include/m4rie/mzd_slice.h
+include/m4rie/mzed.h
+include/m4rie/newton_john.h
+include/m4rie/permutation.h
+include/m4rie/ple.h
+include/m4rie/strassen.h
+include/m4rie/trsm.h
+lib/libm4rie-0.0.20200115.so
+lib/libm4rie.a
+lib/libm4rie.so
+libdata/pkgconfig/m4rie.pc