aboutsummaryrefslogtreecommitdiff
path: root/math/mathmod
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2016-03-04 22:54:36 +0000
committerThierry Thomas <thierry@FreeBSD.org>2016-03-04 22:54:36 +0000
commitc171d67c25e832dde0bf9fa82d4100ba83a0aa43 (patch)
treeade18961e703bdbd1d6262cbd70f4241462360cc /math/mathmod
parent34a1f601d54edcb37052bce676a86989efed1378 (diff)
downloadports-c171d67c25e832dde0bf9fa82d4100ba83a0aa43.tar.gz
ports-c171d67c25e832dde0bf9fa82d4100ba83a0aa43.zip
MathMod is the new K3DSurf, now based on Qt 5.
Notes
Notes: svn path=/head/; revision=410155
Diffstat (limited to 'math/mathmod')
-rw-r--r--math/mathmod/Makefile30
-rw-r--r--math/mathmod/distinfo2
-rw-r--r--math/mathmod/files/patch-MathMod.pro10
-rw-r--r--math/mathmod/pkg-descr8
4 files changed, 50 insertions, 0 deletions
diff --git a/math/mathmod/Makefile b/math/mathmod/Makefile
new file mode 100644
index 000000000000..863ef4eab77a
--- /dev/null
+++ b/math/mathmod/Makefile
@@ -0,0 +1,30 @@
+# Created by: thierry@pompo.net
+# $FreeBSD$
+
+PORTNAME= MathMod
+PORTVERSION= 4.0
+CATEGORIES= math graphics
+MASTER_SITES= SF/${PORTNAME:tl}/${PKGNAME}/
+DISTNAME= ${PORTNAME:tl}-${PORTVERSION}-src
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Mathematical modeling software
+
+LICENSE= GPLv2
+
+USES= dos2unix zip
+USE_GL= yes
+USE_QT5= buildtools_build core gui opengl qmake_build widgets
+
+BRANCHE= 246
+WRKSRC= ${WRKDIR}/${PORTNAME:tl}-branches-${BRANCHE}-trunk
+
+PLIST_FILES= bin/MathMod
+
+pre-build:
+ cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${QMAKE}
+
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ARGET/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/math/mathmod/distinfo b/math/mathmod/distinfo
new file mode 100644
index 000000000000..bd141bab29ba
--- /dev/null
+++ b/math/mathmod/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mathmod-4.0-src.zip) = 337d8c2aec31747ed21d1cc7037b079fdf5702eb6ad2c151e1977d46ac49a4e6
+SIZE (mathmod-4.0-src.zip) = 967153
diff --git a/math/mathmod/files/patch-MathMod.pro b/math/mathmod/files/patch-MathMod.pro
new file mode 100644
index 000000000000..a74e07fc4ead
--- /dev/null
+++ b/math/mathmod/files/patch-MathMod.pro
@@ -0,0 +1,10 @@
+--- MathMod.pro.orig 2016-03-03 21:15:56 UTC
++++ MathMod.pro
+@@ -58,7 +58,6 @@ FORMS = ui_forms/drawingoptions.ui \
+
+ RC_FILE = mm.rc
+ RESOURCES += myressources.qrc
+-LIBS += -lopengl32
+ QT += opengl widgets
+
+ OTHER_FILES += \
diff --git a/math/mathmod/pkg-descr b/math/mathmod/pkg-descr
new file mode 100644
index 000000000000..1c69b2abc6f5
--- /dev/null
+++ b/math/mathmod/pkg-descr
@@ -0,0 +1,8 @@
+MathMod is a mathematical modeling software that visualize and animate implicit
+and parametric surfaces.
+
+MathMod supports: 3D and 4D plotting and animation, OBJ output file format,
+Texture and pigmentation support, Noise and Turbulence effects support, Large
+set of scripted examples.
+
+WWW: https://sourceforge.net/projects/mathmod/