aboutsummaryrefslogtreecommitdiff
path: root/math/matio
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2012-12-12 19:29:29 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2012-12-12 19:29:29 +0000
commitc83885d4c5c829527be15b37f665729e42f71529 (patch)
treeee40532f4588e5f7a21de101f50f1b3014c84110 /math/matio
parentfe36a879c070145289ad42e7e5fcfc5b79d3ed3b (diff)
downloadports-c83885d4c5c829527be15b37f665729e42f71529.tar.gz
ports-c83885d4c5c829527be15b37f665729e42f71529.zip
- Trim header
- Convert to new options framework
Notes
Notes: svn path=/head/; revision=308784
Diffstat (limited to 'math/matio')
-rw-r--r--math/matio/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/math/matio/Makefile b/math/matio/Makefile
index 276d18c5777d..762c7dec28c3 100644
--- a/math/matio/Makefile
+++ b/math/matio/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: matio
-# Date created: 14 February 2010
-# Whom: rfarmer@predatorlabs.net
-#
+# Created by: rfarmer@predatorlabs.net
# $FreeBSD$
-#
PORTNAME= matio
PORTVERSION= 1.3.4
@@ -18,7 +14,8 @@ USE_LDCONFIG= yes
CFLAGS+= -fPIC
-OPTIONS= FORTRAN "Build Fortran bindings" OFF
+OPTIONS_DEFINE= FORTRAN
+FORTRAN_DESC= Build Fortran bindings
.include <bsd.port.options.mk>
@@ -29,7 +26,7 @@ PLIST_FILES= include/matio.h \
lib/libmatio.so.1 \
libdata/pkgconfig/matio.pc
-.if !defined(WITHOUT_FORTRAN)
+.if ${PORT_OPTIONS:MFORTRAN}
USE_FORTRAN= yes
FFLAGS+= -fPIC
@@ -41,7 +38,7 @@ PLIST_FILES+= include/matio.mod
.endif
post-build:
-.if defined(WITHOUT_FORTRAN)
+.if !${PORT_OPTIONS:MFORTRAN}
(cd ${WRKSRC}/src && ${CC} ${CFLAGS} -shared -o libmatio.so.1 snprintf.o \
endian.o io.o inflate.o read_data.o mat5.o mat4.o mat.o)
.else
@@ -57,7 +54,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/src/matioConfig.h ${PREFIX}/include
${INSTALL_PROGRAM} ${WRKSRC}/src/libmatio.so.1 ${PREFIX}/lib
${INSTALL_DATA} ${WRKSRC}/matio.pc ${PREFIX}/libdata/pkgconfig
-.if !defined(WITHOUT_FORTRAN)
+.if ${PORT_OPTIONS:MFORTRAN}
${INSTALL_DATA} ${WRKSRC}/src/matio.mod ${PREFIX}/include
.endif