aboutsummaryrefslogtreecommitdiff
path: root/math/metis
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-01-15 12:52:46 +0000
committerSteve Wills <swills@FreeBSD.org>2019-01-15 12:52:46 +0000
commit9403d24029fe5da38c4f54fd430c987f4da21750 (patch)
treea3c63b9484605f14c6cd494b11760f0122eac82e /math/metis
parent90e79f86a78eed0468f7dc8418645e44681f6aef (diff)
downloadports-9403d24029fe5da38c4f54fd430c987f4da21750.tar.gz
ports-9403d24029fe5da38c4f54fd430c987f4da21750.zip
math/metis: update IDXTYPEWIDTH to 64 on 64 bit platforms
While here, pet portlint PR: 219749 Submitted by: pfg
Notes
Notes: svn path=/head/; revision=490369
Diffstat (limited to 'math/metis')
-rw-r--r--math/metis/Makefile13
-rw-r--r--math/metis/files/patch-programs_CMakeLists.txt2
2 files changed, 10 insertions, 5 deletions
diff --git a/math/metis/Makefile b/math/metis/Makefile
index 94fd2edf8cfa..c129edad7ab0 100644
--- a/math/metis/Makefile
+++ b/math/metis/Makefile
@@ -3,7 +3,7 @@
PORTNAME= metis
PORTVERSION= 5.1.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= math
MASTER_SITES= http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis/
@@ -12,10 +12,10 @@ COMMENT= Package for unstructured graph partitioning
LICENSE= APACHE20
-CONFLICTS= metis4-4* metis-edf-[0-9]*
-
USES= cmake:noninja compiler:c11
+CONFLICTS= metis4-4* metis-edf-[0-9]*
+
OPTIONS_DEFINE= OPENMP SHARED STATIC DOCS
OPENMP_DESC= multithreading via OpenMP
@@ -30,8 +30,8 @@ BINS= cmpfillin gpmetis graphchk m2gmetis mpmetis ndmetis
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENMP}
+USES+= compiler:openmp
CMAKE_ARGS+= -DOPENMP=1
-USE_GCC= any
.endif
.if ${PORT_OPTIONS:MSHARED}
@@ -67,6 +67,11 @@ pre-configure:
${WRKSRC}/GKlib/GKlibSystem.cmake
@${REINPLACE_CMD} -e "\|/home/karypis/|d" \
${WRKSRC}/programs/CMakeLists.txt
+.if ((${ARCH}=="amd64") || (${ARCH}=="aarch64") || (${ARCH}=="sparc64") || (${ARCH}=="ppc64") || (${ARCH}=="ia64"))
+ @${REINPLACE_CMD}-e \
+ 's|IDXTYPEWIDTH 32|IDXTYPEWIDTH 64|' \
+ ${WRKSRC}/include/metis.h
+.endif
.for o in SHARED #PROFILE
.if ${PORT_OPTIONS:M${o}}
@${CP} -R ${WRKSRC} ${WRKSRC_${o}}
diff --git a/math/metis/files/patch-programs_CMakeLists.txt b/math/metis/files/patch-programs_CMakeLists.txt
index 0a0702e71e90..cb23d3df113d 100644
--- a/math/metis/files/patch-programs_CMakeLists.txt
+++ b/math/metis/files/patch-programs_CMakeLists.txt
@@ -1,6 +1,6 @@
--- programs/CMakeLists.txt.orig 2013-03-30 16:24:45 UTC
+++ programs/CMakeLists.txt
-@@ -13,9 +13,14 @@ foreach(prog gpmetis ndmetis mpmetis m2g
+@@ -13,9 +13,14 @@ foreach(prog gpmetis ndmetis mpmetis m2gmetis graphchk
# target_link_libraries(${prog} metis profiler)
endforeach(prog)