aboutsummaryrefslogtreecommitdiff
path: root/math/mfem
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-10 07:28:57 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-10 07:28:57 +0000
commit42f9374eed16199252d90c1ca6211b5027def9f3 (patch)
treea25a26a6f1ba36503db2fa0b6f980dfac47bccae /math/mfem
parent5c7a018a36dc70be00162205f07a8da12800e495 (diff)
downloadports-42f9374eed16199252d90c1ca6211b5027def9f3.tar.gz
ports-42f9374eed16199252d90c1ca6211b5027def9f3.zip
New port: math/mfem: Lightweight, general, scalable C++ library for finite element methods
Notes
Notes: svn path=/head/; revision=481699
Diffstat (limited to 'math/mfem')
-rw-r--r--math/mfem/Makefile25
-rw-r--r--math/mfem/distinfo3
-rw-r--r--math/mfem/pkg-descr8
-rw-r--r--math/mfem/pkg-plist109
4 files changed, 145 insertions, 0 deletions
diff --git a/math/mfem/Makefile b/math/mfem/Makefile
new file mode 100644
index 000000000000..e3688c38b283
--- /dev/null
+++ b/math/mfem/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= mfem
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.4
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Lightweight, general, scalable C++ library for finite element methods
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake:outsource
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+
+CMAKE_ON= BUILD_SHARED_LIBS
+
+OPTIONS_DEFINE= MPI
+
+MPI_CMAKE_BOOL= MFEM_USE_MPI
+MPI_BROKEN= see https://github.com/mfem/mfem/issues/622
+
+.include <bsd.port.mk>
diff --git a/math/mfem/distinfo b/math/mfem/distinfo
new file mode 100644
index 000000000000..c11ded594166
--- /dev/null
+++ b/math/mfem/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1539155589
+SHA256 (mfem-mfem-v3.4_GH0.tar.gz) = cec86054e1cf7c98b7999221e7caa5b7f280ec3363c66cf3ed54e0cbb94fa441
+SIZE (mfem-mfem-v3.4_GH0.tar.gz) = 4595868
diff --git a/math/mfem/pkg-descr b/math/mfem/pkg-descr
new file mode 100644
index 000000000000..1003245dea4a
--- /dev/null
+++ b/math/mfem/pkg-descr
@@ -0,0 +1,8 @@
+Features:
+* Arbitrary high-order finite element meshes and spaces.
+* Wide variety of finite element discretization approaches.
+* Conforming and nonconforming adaptive mesh refinement.
+* Scalable to hundreds of thousands of cores.
+* etc.
+
+WWW: http://mfem.org/
diff --git a/math/mfem/pkg-plist b/math/mfem/pkg-plist
new file mode 100644
index 000000000000..4ef7ce2643f6
--- /dev/null
+++ b/math/mfem/pkg-plist
@@ -0,0 +1,109 @@
+include/mfem-performance.hpp
+include/mfem.hpp
+include/mfem/config/config.hpp
+include/mfem/config/tconfig.hpp
+include/mfem/fem/bilinearform.hpp
+include/mfem/fem/bilininteg.hpp
+include/mfem/fem/coefficient.hpp
+include/mfem/fem/conduitdatacollection.hpp
+include/mfem/fem/datacollection.hpp
+include/mfem/fem/eltrans.hpp
+include/mfem/fem/estimators.hpp
+include/mfem/fem/fe.hpp
+include/mfem/fem/fe_coll.hpp
+include/mfem/fem/fem.hpp
+include/mfem/fem/fespace.hpp
+include/mfem/fem/geom.hpp
+include/mfem/fem/gridfunc.hpp
+include/mfem/fem/hybridization.hpp
+include/mfem/fem/intrules.hpp
+include/mfem/fem/linearform.hpp
+include/mfem/fem/lininteg.hpp
+include/mfem/fem/nonlinearform.hpp
+include/mfem/fem/nonlininteg.hpp
+include/mfem/fem/pbilinearform.hpp
+include/mfem/fem/pfespace.hpp
+include/mfem/fem/pgridfunc.hpp
+include/mfem/fem/plinearform.hpp
+include/mfem/fem/pnonlinearform.hpp
+include/mfem/fem/sidredatacollection.hpp
+include/mfem/fem/staticcond.hpp
+include/mfem/fem/tbilinearform.hpp
+include/mfem/fem/tbilininteg.hpp
+include/mfem/fem/tcoefficient.hpp
+include/mfem/fem/teltrans.hpp
+include/mfem/fem/tevaluator.hpp
+include/mfem/fem/tfe.hpp
+include/mfem/fem/tfespace.hpp
+include/mfem/fem/tintrules.hpp
+include/mfem/fem/tmop.hpp
+include/mfem/general/array.hpp
+include/mfem/general/binaryio.hpp
+include/mfem/general/communication.hpp
+include/mfem/general/error.hpp
+include/mfem/general/globals.hpp
+include/mfem/general/gzstream.hpp
+include/mfem/general/hash.hpp
+include/mfem/general/isockstream.hpp
+include/mfem/general/mem_alloc.hpp
+include/mfem/general/optparser.hpp
+include/mfem/general/osockstream.hpp
+include/mfem/general/sets.hpp
+include/mfem/general/socketstream.hpp
+include/mfem/general/sort_pairs.hpp
+include/mfem/general/stable3d.hpp
+include/mfem/general/table.hpp
+include/mfem/general/tassign.hpp
+include/mfem/general/text.hpp
+include/mfem/general/tic_toc.hpp
+include/mfem/general/version.hpp
+include/mfem/linalg/blockmatrix.hpp
+include/mfem/linalg/blockoperator.hpp
+include/mfem/linalg/blockvector.hpp
+include/mfem/linalg/complex_operator.hpp
+include/mfem/linalg/densemat.hpp
+include/mfem/linalg/handle.hpp
+include/mfem/linalg/hypre.hpp
+include/mfem/linalg/hypre_parcsr.hpp
+include/mfem/linalg/invariants.hpp
+include/mfem/linalg/linalg.hpp
+include/mfem/linalg/matrix.hpp
+include/mfem/linalg/ode.hpp
+include/mfem/linalg/operator.hpp
+include/mfem/linalg/petsc.hpp
+include/mfem/linalg/solvers.hpp
+include/mfem/linalg/sparsemat.hpp
+include/mfem/linalg/sparsesmoothers.hpp
+include/mfem/linalg/strumpack.hpp
+include/mfem/linalg/sundials.hpp
+include/mfem/linalg/superlu.hpp
+include/mfem/linalg/tlayout.hpp
+include/mfem/linalg/tmatrix.hpp
+include/mfem/linalg/ttensor.hpp
+include/mfem/linalg/vector.hpp
+include/mfem/mesh/element.hpp
+include/mfem/mesh/hexahedron.hpp
+include/mfem/mesh/mesh.hpp
+include/mfem/mesh/mesh_headers.hpp
+include/mfem/mesh/mesh_operators.hpp
+include/mfem/mesh/mesquite.hpp
+include/mfem/mesh/ncmesh.hpp
+include/mfem/mesh/nurbs.hpp
+include/mfem/mesh/pmesh.hpp
+include/mfem/mesh/pncmesh.hpp
+include/mfem/mesh/point.hpp
+include/mfem/mesh/pumi.hpp
+include/mfem/mesh/quadrilateral.hpp
+include/mfem/mesh/segment.hpp
+include/mfem/mesh/tetrahedron.hpp
+include/mfem/mesh/tmesh.hpp
+include/mfem/mesh/triangle.hpp
+include/mfem/mesh/vertex.hpp
+include/mfem/mfem-performance.hpp
+include/mfem/mfem.hpp
+lib/cmake/mfem/MFEMConfig.cmake
+lib/cmake/mfem/MFEMConfigVersion.cmake
+lib/cmake/mfem/MFEMTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/mfem/MFEMTargets.cmake
+lib/libmfem.so
+lib/libmfem.so.3.4.0