aboutsummaryrefslogtreecommitdiff
path: root/math/miracl
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-04-04 15:22:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-04-04 15:22:17 +0000
commit6b8ae907c6a2bd40dbeeafcb6bfbc9505c351e16 (patch)
tree529f6c8e166fcefcc4e6b163d0ed412b84e8101a /math/miracl
parent8ea7b0a83c3619c740c58016fc87dfdbe3bdbbf3 (diff)
downloadports-6b8ae907c6a2bd40dbeeafcb6bfbc9505c351e16.tar.gz
ports-6b8ae907c6a2bd40dbeeafcb6bfbc9505c351e16.zip
- Re-enable ASM on i386
PR: ports/122444 Submitted by: Ralf van der Enden <tremere@cainites.net>
Notes
Notes: svn path=/head/; revision=210518
Diffstat (limited to 'math/miracl')
-rw-r--r--math/miracl/Makefile8
-rw-r--r--math/miracl/files/patch-mirdef.lnx9
2 files changed, 8 insertions, 9 deletions
diff --git a/math/miracl/Makefile b/math/miracl/Makefile
index 4adf0bbef96e..8e68b6b52e99 100644
--- a/math/miracl/Makefile
+++ b/math/miracl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= miracl
PORTVERSION= 5.3.2
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ftp://ftp.computing.dcu.ie/pub/crypto/ \
${MASTER_SITE_LOCAL}
@@ -38,11 +39,18 @@ IGNORE= Builds on x86 and amd64 only
post-patch:
# C{C,XX} safeness
# CFLAGS safeness
+.if ${ARCH} == "i386"
+ @${REINPLACE_CMD} -E \
+ -e 's|gcc|${CC}|' \
+ -e 's|g\+\+|${CXX}|' \
+ -e 's|-O2|${CFLAGS}|' \
+.else
@${REINPLACE_CMD} -E \
-e 's|gcc|${CC}|' \
-e 's|g\+\+|${CXX}|' \
-e 's|-O2|${CFLAGS} -fPIC|' \
${WRKSRC}/${BUILDCMD}
+.endif
do-build:
@cd ${WRKSRC} && ${SH} ./${BUILDCMD}
diff --git a/math/miracl/files/patch-mirdef.lnx b/math/miracl/files/patch-mirdef.lnx
deleted file mode 100644
index ce1d464e683c..000000000000
--- a/math/miracl/files/patch-mirdef.lnx
+++ /dev/null
@@ -1,9 +0,0 @@
-diff -Nru mirdef.lnx mirdef.lnx
---- mirdef.lnx 2006-07-12 13:57:00.000000000 +0200
-+++ mirdef.lnx 2008-04-03 23:24:04.000000000 +0200
-@@ -27,4 +27,4 @@
-
- #define MAXBASE ((mr_small)1<<(MIRACL-1))
-
--
-+#define MR_NOASM