aboutsummaryrefslogtreecommitdiff
path: root/math/moab
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /math/moab
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadports-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=488341
Diffstat (limited to 'math/moab')
-rw-r--r--math/moab/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/moab/Makefile b/math/moab/Makefile
index a16eca56ac8c..66508fae631a 100644
--- a/math/moab/Makefile
+++ b/math/moab/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libhdf5.so:science/hdf5 \
libnetcdf.so:science/netcdf \
libopenblas.so:math/openblas
-USES= cmake:outsource,noninja eigen:3 fortran
+USES= cmake:noninja eigen:3 fortran
USE_LDCONFIG= yes
CMAKE_ARGS= -DBLAS_LIBRARIES:STRING=${LOCALBASE}/lib/libopenblas.so -DLAPACK_LIBRARIES:STRING=${LOCALBASE}/lib/libopenblas.so