aboutsummaryrefslogtreecommitdiff
path: root/math/mpc
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2010-06-20 22:54:24 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2010-06-20 22:54:24 +0000
commit7a9925a9445678e6a4d7c32dd701e27f77b0217e (patch)
treec8186e4ce55640c1b1e135a52ff33153e442411e /math/mpc
parent42e904229066c0173f7b4970e621e7bb0a7a271d (diff)
downloadports-7a9925a9445678e6a4d7c32dd701e27f77b0217e.tar.gz
ports-7a9925a9445678e6a4d7c32dd701e27f77b0217e.zip
Update to libmpc version 0.8.2 which brings a speed-up of mpc_pow_ui
through binary exponentiation and fixes the testsuite for mpfr 3.0.0. Suggested by: Gunther Nikl <gnikl@users.sourceforge.net> Feature safe: yes
Notes
Notes: svn path=/head/; revision=256771
Diffstat (limited to 'math/mpc')
-rw-r--r--math/mpc/Makefile3
-rw-r--r--math/mpc/distinfo6
-rw-r--r--math/mpc/files/patch-src_acos.c11
3 files changed, 4 insertions, 16 deletions
diff --git a/math/mpc/Makefile b/math/mpc/Makefile
index 6f2eb2fa4813..05dd0e9d1297 100644
--- a/math/mpc/Makefile
+++ b/math/mpc/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mpc
-PORTVERSION= 0.8.1
-PORTREVISION= 2
+PORTVERSION= 0.8.2
CATEGORIES= math devel
MASTER_SITES= http://www.multiprecision.org/mpc/download/
diff --git a/math/mpc/distinfo b/math/mpc/distinfo
index eccd5690fc52..ca535ee5edc9 100644
--- a/math/mpc/distinfo
+++ b/math/mpc/distinfo
@@ -1,3 +1,3 @@
-MD5 (mpc-0.8.1.tar.gz) = 5b34aa804d514cc295414a963aedb6bf
-SHA256 (mpc-0.8.1.tar.gz) = e664603757251fd8a352848276497a4c79b7f8b21fd8aedd5cc0598a38fee3e4
-SIZE (mpc-0.8.1.tar.gz) = 544950
+MD5 (mpc-0.8.2.tar.gz) = e98267ebd5648a39f881d66797122fb6
+SHA256 (mpc-0.8.2.tar.gz) = ae79f8d41d8a86456b68607e9ca398d00f8b7342d1d83bcf4428178ac45380c7
+SIZE (mpc-0.8.2.tar.gz) = 548401
diff --git a/math/mpc/files/patch-src_acos.c b/math/mpc/files/patch-src_acos.c
deleted file mode 100644
index 15ffa52b44e8..000000000000
--- a/math/mpc/files/patch-src_acos.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/acos.c.orig 2010-06-11 16:14:09.000000000 +0200
-+++ src/acos.c 2010-06-11 16:14:30.000000000 +0200
-@@ -189,7 +189,7 @@
- rnd_im = rnd_im == GMP_RNDU ? GMP_RNDD
- : rnd_im == GMP_RNDD ? GMP_RNDU
- #if MPFR_VERSION_MAJOR >= 3
-- : rnd_im == GMP_RNDA ? GMP_RNDZ
-+ : rnd_im == MPFR_RNDA ? MPFR_RNDZ
- #endif
- : rnd_im;
- rnd1 = RNDC(GMP_RNDN, rnd_im);