aboutsummaryrefslogtreecommitdiff
path: root/math/mpexpr
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2016-09-16 07:38:43 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2016-09-16 07:38:43 +0000
commit63360cedd42b9ea8548fe265b622342b3e47177d (patch)
tree7c98ceff421779c8f624aad194bbfe34a22da513 /math/mpexpr
parent186d0d428207b06ddc77fe633626842734e50b72 (diff)
downloadports-63360cedd42b9ea8548fe265b622342b3e47177d.tar.gz
ports-63360cedd42b9ea8548fe265b622342b3e47177d.zip
math/mpexpr: update to 1.2
Notes
Notes: svn path=/head/; revision=422247
Diffstat (limited to 'math/mpexpr')
-rw-r--r--math/mpexpr/Makefile14
-rw-r--r--math/mpexpr/distinfo5
-rw-r--r--math/mpexpr/files/patch-generic-mpexpr.h13
-rw-r--r--math/mpexpr/files/patch-generic_endian.c11
-rw-r--r--math/mpexpr/files/patch-generic_mpexpr.c70
-rw-r--r--math/mpexpr/files/patch-generic_mpiface.c11
-rw-r--r--math/mpexpr/files/patch-generic_mpparse.c28
-rw-r--r--math/mpexpr/files/patch-unix-Makefile.in6
-rw-r--r--math/mpexpr/files/patch-unix-configure8
9 files changed, 39 insertions, 127 deletions
diff --git a/math/mpexpr/Makefile b/math/mpexpr/Makefile
index ed54a389ea1d..87bfb1f8a0a5 100644
--- a/math/mpexpr/Makefile
+++ b/math/mpexpr/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mpexpr
-PORTVERSION= 1.1
+PORTVERSION= 1.2
CATEGORIES= math tcl
MASTER_SITES= SF
@@ -23,8 +23,8 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
CONFIGURE_ENV+= TCL_INC_DIR=${TCL_INCLUDEDIR} \
TCL_LIB_DIR=${TCL_LIBDIR}
-PLIST_FILES= lib/Mpexpr10/libMpexpr10.so \
- lib/Mpexpr10/pkgIndex.tcl \
+PLIST_FILES= lib/Mpexpr12/libMpexpr12.so \
+ lib/Mpexpr12/pkgIndex.tcl \
man/mann/mpexpr.n.gz
post-patch:
@@ -32,12 +32,12 @@ post-patch:
${REINPLACE_CMD} -e '/set VERBOSE/s|0|1|' ${WRKSRC}/../tests/defs
do-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/Mpexpr10
- ${INSTALL_PROGRAM} ${WRKSRC}/libMpexpr10.so ${STAGEDIR}${PREFIX}/lib/Mpexpr10
- ${INSTALL_DATA} ${WRKSRC}/pkgIndex.tcl ${STAGEDIR}${PREFIX}/lib/Mpexpr10
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/Mpexpr12
+ ${INSTALL_PROGRAM} ${WRKSRC}/libMpexpr12.so ${STAGEDIR}${PREFIX}/lib/Mpexpr12
+ ${INSTALL_DATA} ${WRKSRC}/pkgIndex.tcl ${STAGEDIR}${PREFIX}/lib/Mpexpr12
${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/doc/mpexpr.man ${STAGEDIR}${PREFIX}/man/mann/mpexpr.n
-regression-test: build
+do-test: build
cd ${WRKSRC} && ${MAKE_CMD} test
.include <bsd.port.mk>
diff --git a/math/mpexpr/distinfo b/math/mpexpr/distinfo
index 41808dd49f1d..1fff411befba 100644
--- a/math/mpexpr/distinfo
+++ b/math/mpexpr/distinfo
@@ -1,2 +1,3 @@
-SHA256 (mpexpr-1.1.tar.gz) = 7fc81ef9a213591c0c03939f18acfc0e1e4ddadf3a2c225450d148ffc26a877b
-SIZE (mpexpr-1.1.tar.gz) = 231911
+TIMESTAMP = 1474011027
+SHA256 (mpexpr-1.2.tar.gz) = 616397bb21823ea7d4527d61a19064012764025e429bfebc432f83116809682f
+SIZE (mpexpr-1.2.tar.gz) = 264067
diff --git a/math/mpexpr/files/patch-generic-mpexpr.h b/math/mpexpr/files/patch-generic-mpexpr.h
deleted file mode 100644
index 4205741fdf47..000000000000
--- a/math/mpexpr/files/patch-generic-mpexpr.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- generic/mpexpr.h.orig Thu Mar 15 03:21:12 2007
-+++ generic/mpexpr.h Thu Mar 15 03:21:46 2007
-@@ -100,8 +100,8 @@
-
- /* mpexpr tcl command procs */
-
--EXTERN Tcl_CmdProc Mp_ExprCmd;
--EXTERN Tcl_CmdProc Mp_FormatCmd;
-+EXTERN int Mp_ExprCmd(ClientData, Tcl_Interp *interp, int argc, char **argv);
-+EXTERN int Mp_FormatCmd(ClientData, Tcl_Interp *interp, int argc, char **argv);
-
-
- #endif
diff --git a/math/mpexpr/files/patch-generic_endian.c b/math/mpexpr/files/patch-generic_endian.c
new file mode 100644
index 000000000000..edd2e2cfc905
--- /dev/null
+++ b/math/mpexpr/files/patch-generic_endian.c
@@ -0,0 +1,11 @@
+--- generic/endian.c.orig 2016-09-16 07:35:45 UTC
++++ generic/endian.c
+@@ -35,7 +35,7 @@
+ char byte[8] = { (char)0x12, (char)0x36, (char)0x48, (char)0x59,
+ (char)0x01, (char)0x23, (char)0x45, (char)0x67 };
+
+-main()
++int main()
+ {
+ /* pointers into the byte order array */
+ int *intp = (int *)byte;
diff --git a/math/mpexpr/files/patch-generic_mpexpr.c b/math/mpexpr/files/patch-generic_mpexpr.c
deleted file mode 100644
index 5f1cbd9b6851..000000000000
--- a/math/mpexpr/files/patch-generic_mpexpr.c
+++ /dev/null
@@ -1,70 +0,0 @@
---- generic/mpexpr.c.orig 2013-11-06 15:23:00.000000000 +0100
-+++ generic/mpexpr.c 2013-11-06 15:29:26.000000000 +0100
-@@ -1242,7 +1242,7 @@
- */
-
- default:
-- interp->result = "unknown operator in expression";
-+ Tcl_SetObjResult(interp, Tcl_NewStringObj("unknown operator in expression", -1));
- result = TCL_ERROR;
- goto done;
- }
-@@ -1272,9 +1272,8 @@
-
- if (ziszero(value2.intValue)) {
- divideByZero:
-- interp->result = "divide by zero";
-- Tcl_SetErrorCode(interp, "ARITH", "DIVZERO",
-- interp->result, (char *) NULL);
-+ Tcl_SetObjResult(interp, Tcl_NewStringObj("divide by zero", -1));
-+ Tcl_SetErrorCode(interp, "ARITH", "DIVZERO", "divide by zero", (char *) NULL);
- result = TCL_ERROR;
- goto done;
- }
-@@ -1637,7 +1636,7 @@
- break;
-
- case COLON:
-- interp->result = "can't have : operator without ? first";
-+ Tcl_SetObjResult(interp, Tcl_NewStringObj("can't have : operator without ? first", -1));
- result = TCL_ERROR;
- goto done;
- }
-@@ -1930,8 +1929,7 @@
- ckfree(math_io);
- } else {
- if (value.pv.buffer != value.staticSpace) {
-- interp->result = value.pv.buffer;
-- interp->freeProc = TCL_DYNAMIC;
-+ Tcl_SetResult(interp, value.pv.buffer, TCL_DYNAMIC);
- value.pv.buffer = value.staticSpace;
- } else {
- Tcl_SetResult(interp, value.pv.buffer, TCL_VOLATILE);
-@@ -2133,8 +2131,7 @@
- ExprFreeMathArgs(args);
- zfree(funcResult.intValue);
- Qfree(funcResult.doubleValue);
-- interp->result =
-- "argument to math function didn't have numeric value";
-+ Tcl_SetObjResult(interp, Tcl_NewStringObj("argument to math function didn't have numeric value", -1));
- return TCL_ERROR;
- }
-
-@@ -2177,7 +2174,7 @@
- break;
- }
- if (infoPtr->token == COMMA) {
-- interp->result = "too many arguments for math function";
-+ Tcl_SetObjResult(interp, Tcl_NewStringObj("too many arguments for math function", -1));
- ExprFreeMathArgs(args);
- zfree(funcResult.intValue);
- Qfree(funcResult.doubleValue);
-@@ -2188,7 +2185,7 @@
- }
- if (infoPtr->token != COMMA) {
- if (infoPtr->token == CLOSE_PAREN) {
-- interp->result = "too few arguments for math function";
-+ Tcl_SetObjResult(interp, Tcl_NewStringObj("too few arguments for math function", -1));
- ExprFreeMathArgs(args);
- zfree(funcResult.intValue);
- Qfree(funcResult.doubleValue);
diff --git a/math/mpexpr/files/patch-generic_mpiface.c b/math/mpexpr/files/patch-generic_mpiface.c
new file mode 100644
index 000000000000..3053c05cae88
--- /dev/null
+++ b/math/mpexpr/files/patch-generic_mpiface.c
@@ -0,0 +1,11 @@
+--- generic/mpiface.c.orig 2016-09-16 07:36:35 UTC
++++ generic/mpiface.c
+@@ -69,7 +69,7 @@ Mpexpr_Init (interp)
+ Tcl_Interp *interp;
+ {
+ Mp_Data *mdPtr;
+- static initialized = 0;
++ static int initialized = 0;
+ TCL_DECLARE_MUTEX(mpMutex)
+
+ if (!initialized) {
diff --git a/math/mpexpr/files/patch-generic_mpparse.c b/math/mpexpr/files/patch-generic_mpparse.c
deleted file mode 100644
index 56140eb42a12..000000000000
--- a/math/mpexpr/files/patch-generic_mpparse.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- generic/mpparse.c.orig 2013-11-06 15:29:52.000000000 +0100
-+++ generic/mpparse.c 2013-11-06 15:36:11.000000000 +0100
-@@ -283,7 +283,9 @@
- continue;
- } else if (c == '\0') {
- Tcl_ResetResult(interp);
-- sprintf(interp->result, "missing %c", termChar);
-+ char buf[10];
-+ sprintf(buf, "missing %c", termChar);
-+ Tcl_SetObjResult(interp, Tcl_NewStringObj(buf, -1));
- *termPtr = string-1;
- return TCL_ERROR;
- } else {
-@@ -349,12 +351,12 @@
- if (result != TCL_OK) {
- return result;
- }
-- length = strlen(interp->result);
-+ length = strlen(Tcl_GetStringResult(interp));
- shortfall = length + 1 - (pvPtr->end - pvPtr->next);
- if (shortfall > 0) {
- (*pvPtr->expandProc)(pvPtr, shortfall);
- }
-- strcpy(pvPtr->next, interp->result);
-+ strcpy(pvPtr->next, Tcl_GetStringResult(interp));
- pvPtr->next += length;
- Tcl_ResetResult(interp);
- } else {
diff --git a/math/mpexpr/files/patch-unix-Makefile.in b/math/mpexpr/files/patch-unix-Makefile.in
index f0c76ee1d615..e324af217f18 100644
--- a/math/mpexpr/files/patch-unix-Makefile.in
+++ b/math/mpexpr/files/patch-unix-Makefile.in
@@ -1,6 +1,6 @@
---- unix/Makefile.in.orig 2004-06-08 04:16:40.000000000 +0200
-+++ unix/Makefile.in 2013-11-06 15:14:48.000000000 +0100
-@@ -219,17 +219,17 @@
+--- unix/Makefile.in.orig 2016-09-15 16:44:37 UTC
++++ unix/Makefile.in
+@@ -219,17 +219,17 @@ all: @PROGS@
# a make clobber and try LITTLE_ENDIAN. If that fails, ask a wizard
# for help.
#
diff --git a/math/mpexpr/files/patch-unix-configure b/math/mpexpr/files/patch-unix-configure
index 0fed1a1ef362..c65d813fe906 100644
--- a/math/mpexpr/files/patch-unix-configure
+++ b/math/mpexpr/files/patch-unix-configure
@@ -1,6 +1,6 @@
---- unix/configure.orig 2013-11-06 15:39:52.000000000 +0100
-+++ unix/configure 2013-11-06 15:39:52.000000000 +0100
-@@ -23,6 +23,8 @@
+--- unix/configure.orig 2013-05-09 14:28:39 UTC
++++ unix/configure
+@@ -23,6 +23,8 @@ ac_help="$ac_help
# Initialize some variables set by options.
# The variables have the same names as the options, with
# dashes changed to underlines.
@@ -9,7 +9,7 @@
build=NONE
cache_file=./config.cache
exec_prefix=NONE
-@@ -733,24 +735,6 @@
+@@ -733,24 +735,6 @@ if test "${with_tcl+set}" = set; then
fi