aboutsummaryrefslogtreecommitdiff
path: root/math/mpir
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-07-15 14:23:11 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-07-15 14:23:11 +0000
commitea412d50721a4a762904d06d6d72185ec77089cb (patch)
tree248232f26285e8d966b093458dd3288bbbbd84d1 /math/mpir
parentd3116291b12ddac050aa148147ce6edd11b142f5 (diff)
downloadports-ea412d50721a4a762904d06d6d72185ec77089cb.tar.gz
ports-ea412d50721a4a762904d06d6d72185ec77089cb.zip
New port: math/mpir
MPIR is an open source multiprecision integer (bignum) library forked from the GMP (GNU Multi Precision) project. It consists of much code from past GMP releases, in combination with much original contributed code. MPIR is constructed by a developer and vendor friendly community of professional and amateur mathematicians, computer scientists and hobbyists. WWW: http://www.mpir.org
Notes
Notes: svn path=/head/; revision=361925
Diffstat (limited to 'math/mpir')
-rw-r--r--math/mpir/Makefile45
-rw-r--r--math/mpir/distinfo2
-rw-r--r--math/mpir/pkg-descr8
3 files changed, 55 insertions, 0 deletions
diff --git a/math/mpir/Makefile b/math/mpir/Makefile
new file mode 100644
index 000000000000..4dce4a86c1ec
--- /dev/null
+++ b/math/mpir/Makefile
@@ -0,0 +1,45 @@
+# Created by: gahr
+# $FreeBSD$
+
+PORTNAME= mpir
+DISTVERSION= 2.7.0-alpha9
+CATEGORIES= math
+MASTER_SITES= http://www.mpir.org/
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= Multiprecision integer library
+
+LICENSE= LGPL3
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
+
+USES= libtool tar:bzip2
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--enable-cxx
+INSTALL_TARGET+=install-strip
+
+MPIR_VERSION= 10.6.0
+MPIRXX_VERSION= 4.4.0
+
+PLIST_FILES= include/mpir.h \
+ include/mpirxx.h \
+ lib/libmpir.a \
+ lib/libmpir.so \
+ lib/libmpir.so.${MPIR_VERSION} \
+ lib/libmpir.so.${MPIR_VERSION:R:R} \
+ lib/libmpirxx.a \
+ lib/libmpirxx.so \
+ lib/libmpirxx.so.${MPIRXX_VERSION} \
+ lib/libmpirxx.so.${MPIRXX_VERSION:R:R}
+
+post-install:
+ ${LN} -sf libmpir.so.${MPIR_VERSION} \
+ ${STAGEDIR}${PREFIX}/lib/libmpir.so.${MPIR_VERSION:R:R}
+ ${LN} -sf libmpirxx.so.${MPIRXX_VERSION} \
+ ${STAGEDIR}${PREFIX}/lib/libmpirxx.so.${MPIRXX_VERSION:R:R}
+
+regression-test:
+ ${MAKE} -C ${WRKSRC} check
+
+.include <bsd.port.mk>
diff --git a/math/mpir/distinfo b/math/mpir/distinfo
new file mode 100644
index 000000000000..6bd5a10730a0
--- /dev/null
+++ b/math/mpir/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mpir-2.7.0-alpha9.tar.bz2) = f8ede4d3422b39d0182042289cefab97f9bcaf7608e97e6c10fc09060b8e9bc7
+SIZE (mpir-2.7.0-alpha9.tar.bz2) = 3578569
diff --git a/math/mpir/pkg-descr b/math/mpir/pkg-descr
new file mode 100644
index 000000000000..af4dfb6183f4
--- /dev/null
+++ b/math/mpir/pkg-descr
@@ -0,0 +1,8 @@
+MPIR is an open source multiprecision integer (bignum) library forked from the
+GMP (GNU Multi Precision) project. It consists of much code from past GMP
+releases, in combination with much original contributed code.
+
+MPIR is constructed by a developer and vendor friendly community of
+professional and amateur mathematicians, computer scientists and hobbyists.
+
+WWW: http://www.mpir.org