aboutsummaryrefslogtreecommitdiff
path: root/math/mprime
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2017-11-21 22:43:06 +0000
committerSteve Wills <swills@FreeBSD.org>2017-11-21 22:43:06 +0000
commit18af141cc0293b65eb729e742de1c63d7ffeb2c1 (patch)
treeb01aae1e2ec52b1631e3b710214f09a30f49bd26 /math/mprime
parent66f1637cfd98e30359ff484311076620fb63f438 (diff)
downloadports-18af141cc0293b65eb729e742de1c63d7ffeb2c1.tar.gz
ports-18af141cc0293b65eb729e742de1c63d7ffeb2c1.zip
math/mprime: Update to 28.10
While here: * Set maintainer to submitter * Add License file * Appease portlint by tweaking comment and moving ONLY_FOR_ARCHES PR: 219432 Submitted by: rozhuk.im@gmail.com
Notes
Notes: svn path=/head/; revision=454658
Diffstat (limited to 'math/mprime')
-rw-r--r--math/mprime/Makefile66
-rw-r--r--math/mprime/Makefile.amd6417
-rw-r--r--math/mprime/Makefile.i38626
-rw-r--r--math/mprime/distinfo6
-rw-r--r--math/mprime/files/LICENSE202
-rw-r--r--math/mprime/files/pkg-message.in10
-rw-r--r--math/mprime/pkg-plist7
7 files changed, 291 insertions, 43 deletions
diff --git a/math/mprime/Makefile b/math/mprime/Makefile
index d51476d5ddcf..b7384a0f8701 100644
--- a/math/mprime/Makefile
+++ b/math/mprime/Makefile
@@ -1,31 +1,51 @@
-# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+# Created by: Rozhuk Ivan <rozhuk.im@gmail.com>
# $FreeBSD$
-PORTNAME= mprime
-PORTVERSION= 26.6
-CATEGORIES= math benchmarks net
-MASTER_SITES= http://www.mersenne.org/ftp_root/gimps/
-DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}-${OPSYS}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= mersenne.org distributed Great Internet Mersenne Prime Search
-
-LIB_DEPENDS= libcrypto.so.6:misc/compat9x
-
-ONLY_FOR_ARCHS= i386
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-
-SUB_FILES= pkg-message wrapper.sh
-
-OPTIONS_DEFINE= DOCS
+PORTNAME= mprime
+PORTVERSION= 28.10
+CATEGORIES= math benchmarks net
+MASTER_SITES= http://www.mersenne.org/ftp_root/gimps/ \
+ ftp://mersenne.org/gimps/
+DISTNAME= p95v${PORTVERSION:R}${PORTVERSION:E}.source
+
+MAINTAINER= rozhuk.im@gmail.com
+COMMENT= Great Internet Mersenne Prime Search
+
+LICENSE= EULA
+LICENSE_NAME= EULA
+LICENSE_FILE= ${FILESDIR}/LICENSE
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+
+ONLY_FOR_ARCHS= amd64 i386
+
+LIB_DEPENDS= libcurl.so:ftp/curl
+
+USES= zip
+USE_LDCONFIG= yes
+NO_WRKSUBDIR= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+ALL_TARGET= mprime
+
+SUB_FILES= wrapper.sh
+
+PLIST_FILES+=\
+ bin/mprime \
+ bin/mprime-real
+
+post-patch:
+ @${REINPLACE_CMD} -e 's| abs (| labs (|g ; \
+ s|(abs (|(labs (|g ; \
+ s| abs(| labs(|g ; \
+ s|(abs(|(labs(|g' \
+ ${WRKSRC}/../gwnum/gwnum.c \
+ ${WRKSRC}/../commonc.c \
+ ${WRKSRC}/../ecm.c \
+ ${WRKSRC}/../gwtest.c
+ @${REINPLACE_CMD} -e 's|__APPLE__|__FreeBSD__|g' \
+ ${WRKSRC}/../gwnum/gwutil.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mprime ${STAGEDIR}${PREFIX}/bin/mprime-real
${INSTALL_SCRIPT} ${WRKDIR}/wrapper.sh ${STAGEDIR}${PREFIX}/bin/mprime
-do-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.txt ${STAGEDIR}${DOCSDIR}
-
.include <bsd.port.mk>
diff --git a/math/mprime/Makefile.amd64 b/math/mprime/Makefile.amd64
new file mode 100644
index 000000000000..c83e409b98e9
--- /dev/null
+++ b/math/mprime/Makefile.amd64
@@ -0,0 +1,17 @@
+# Created by: Rozhuk Ivan <rozhuk.im@gmail.com>
+# $FreeBSD$
+
+WRKSRC_SUBDIR= linux64
+
+post-extract:
+ @${RM} ${WRKSRC}/makefile
+ @${MV} ${WRKSRC}/makebsd ${WRKSRC}/Makefile
+
+pre-build:
+ @${REINPLACE_CMD} -e 's|-ldl||g ; \
+ s|-lstdc++||g ; \
+ s|gcc|${CC}|g ; \
+ s|cc|${CC}| ; \
+ s|-malign-double||' \
+ ${WRKSRC}/Makefile
+ @(cd ${WRKSRC}/../gwnum/ && ${MAKE} -f makebsd64)
diff --git a/math/mprime/Makefile.i386 b/math/mprime/Makefile.i386
new file mode 100644
index 000000000000..17d9606a19f4
--- /dev/null
+++ b/math/mprime/Makefile.i386
@@ -0,0 +1,26 @@
+# Created by: Rozhuk Ivan <rozhuk.im@gmail.com>
+# $FreeBSD$
+
+WRKSRC_SUBDIR= linux
+
+post-extract:
+ @${RM} ${WRKSRC}/makefile
+ @${MV} ${WRKSRC}/makebsd ${WRKSRC}/Makefile
+
+pre-build:
+ @${REINPLACE_CMD} -e 's|-ldl||g ; \
+ s|-lstdc++||g ; \
+ s|gcc|${CC}|g ; \
+ s|cc|${CC}| ; \
+ s|-lz|| ; \
+ s|LFLAGS = -Wl,-M|LFLAGS = -L/usr/local/lib -Wl,-M| ; \
+ s|-Bstatic /usr/local/lib/libcurl.a|-lcurl| ; \
+ s|-Bdynamic -lssl|| ; \
+ s|-malign-double||' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|g ; \
+ s|g++|${CC}| ; \
+ s|cc|${CC}| ; \
+ s|-malign-double||' \
+ ${WRKSRC}/../gwnum/makemsys
+ @(cd ${WRKSRC}/../gwnum/ && ${MAKE} -f makemsys)
diff --git a/math/mprime/distinfo b/math/mprime/distinfo
index 07f683d4ece0..c981d456eeae 100644
--- a/math/mprime/distinfo
+++ b/math/mprime/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1302303090
-SHA256 (mprime266-FreeBSD.tar.gz) = d4c2c044cfa45311dd7f2c41574f59a0519c989fd6e0ca723505dea12b2ff1fd
-SIZE (mprime266-FreeBSD.tar.gz) = 4233056
+TIMESTAMP = 1495315765
+SHA256 (p95v2810.source.zip) = fdde4652ea12a66487245fbef7980237b2707c595f613cac013e97a489301060
+SIZE (p95v2810.source.zip) = 44979437
diff --git a/math/mprime/files/LICENSE b/math/mprime/files/LICENSE
new file mode 100644
index 000000000000..74b024d627e6
--- /dev/null
+++ b/math/mprime/files/LICENSE
@@ -0,0 +1,202 @@
+
+Terms and Conditions of Use ("TCU")
+
+ - GIMPS participation is free of charge and open to the public
+ internationally.
+ - Web Site. The GIMPS "Web Site" is understood to include all
+ Mersenne.org Internet web site domains, web content and services,
+ PrimeNet APIs, data, downloads, etc., regardless of means of access.
+ - Non-Participants. Viewing the Web Site does not necessarily make you
+ a Participant; non-Participants are not bound by this TCU.
+ - Participation Constitutes Agreement. "Participant" is understood to
+ be an individual person, or a single individual person designated as
+ the authorized representative of any group, team, organization or
+ legal entity, who personally, or whose computer(s), accesses and/or
+ communicates with the Web Site to perform, or cause to perform,
+ mathematical calculations that are, or typically, systematically
+ organized by GIMPS. This includes, but is not restricted to, use of
+ Prime95, MPrime, GLucas, or similar software, automatically over the
+ Internet or using the Web Site (manual testing forms, reports, APIs,
+ etc.), to get data or work assignments or to upload results or other
+ data. Participation constitutes agreement with the TCU by that
+ individual and any group, team, organization or legal entity the
+ Participant represents.
+ - Participant Identifiers. Participant's user ID, password and email
+ address are the primary unique identifiers used by GIMPS to
+ communicate and confirm Participant's identity. Secondary
+ identifiers may include unique computer identifiers known as a
+ "GUID". The "Anonymous" or "ANONYMOUS" user ID is owned by GIMPS,
+ but may be used by Participants who do not wish to be publically
+ identified.
+ - Award Rules. Participant agrees to the Research Discovery Award Rules.
+ - Award Refusal. Participant may at their option decline any award.
+ Research Discovery Award Rules apply even if an award is unclaimed
+ or optionally declined by the Participant.
+ - Data Ownership and Privacy. GIMPS owns all collected data, and may
+ publish or make available certain limited subset(s) of that data for
+ public reference, excluding personally identifiable data according
+ to the Privacy Policy. Examples of published data are stats,
+ standings, charts and other derived charts or tables.
+ - Disclaimer. GIMPS is not responsible for any losses due to Web Site
+ errors, electronic transmission errors, omissions or unauthorized
+ disclosures, failure of any software to correctly find and timely
+ report a new prime number, or any other research discovery, or for
+ someone "poaching" or "stealing" your assignment (performing work on
+ it without it being assigned to them by GIMPS) and subsequently
+ making a discovery.
+ - Terms and Conditions of Use Changes. GIMPS reserves the right to
+ change this TCU without notice. Last updated 15 October 2008.
+ - Jurisdiction. Jurisdiction of law shall be the State of California
+ and the United States of America. Participant agrees to settle all
+ disputes through a good faith effort directly with GIMPS officers
+ and directors, or as a last resort, by third-party binding
+ arbitration through a certified arbitrator of GIMPS' choosing.
+
+
+Research Discovery Award Rules ("Rules")
+1) General Award Rules
+
+ - Participants. "Participant" is understood as defined in the Terms
+ and Conditions of Use ("TCU").
+ - Award Eligibility. All GIMPS Participants are automatically eligible
+ for Research Discovery Awards. GIMPS-interested parties, including
+ its officers, directors, their immediate family members or
+ directly-contracted agents, are ineligible for any award.
+ - Awardees. "Awardee" is understood to be the Participant, or the
+ group, team, organization or legal entity the Participant represents,
+ and whose computer achieves a research discovery for which an award
+ exists and all Rules in effect at the time of the discovery comply.
+ - Award Payee. Awards are payable to a single Awardee, except if the
+ Awardee designates a single charity to receive all or part of the
+ award, for which GIMPS will make reasonable effort but does not
+ guarantee to accommodate. Awardee is responsible for all applicable
+ taxes and fees.
+ - Awardee Information. Certain information about the Awardee, and where
+ designated information about a selected charity, may be collected by
+ GIMPS where lawfully required.
+ - Discovery Evidence. As proof of discovery, Participant agrees to
+ email to GIMPS at woltman@alum.mit.edu and/or primenet@mersenne.org
+ certain data files generated by any software program used to make the
+ discovery, along with their name, post mailing address, phone number,
+ and GIMPS user ID if not anonymous. If proof is not satisfactory, it
+ will be treated as an unclaimed award.
+ - Discovery Non-Disclosure Period. Participants and Awardees agree to a
+ reasonable immediate period of non-disclosure communications silence,
+ not to exceed 90 days, about any discovery, alleged or verified,
+ until GIMPS announces the discovery to the academia and press.
+ Non-compliance may result in award disqualification.
+ - Evidence of Authority. A Participant who does not own a computer on
+ which a research discovery is found must produce written evidence
+ satisfactory to the GIMPS board of directors of their status as a
+ designated authorized representative with authority over that
+ computer and to bind the TCU, before they, or whom they represent,
+ can be considered an Awardee. If proof is not satisfactory, it will
+ be treated as an unclaimed prize.
+ - Award Notification. Participant is responsible for maintaining and
+ monitoring the email address registered in their GIMPS user ID
+ account. GIMPS is not responsible for ensuring email notification
+ delivery or receipt by Participants. Anonymous Participants will not
+ be notified. It is not necessary to receive an email notification
+ from GIMPS to qualify for a Research Discovery Award.
+ - Award Claims and Release Waivers. Participant and Awardee is/are
+ responsible for claiming any applicable Research Discovery Award, and
+ agree to execute a GIMPS award claim and release waiver and/or
+ release waiver, as appropriate, satisfactory to the GIMPS board of
+ directors.
+ - Unclaimed, Expired, Disqualified and Refused Awards. Unclaimed awards
+ expire one year from the date of the qualifying discovery. Expired,
+ refused or disqualified awards will be donated by GIMPS to a
+ 501(c)(3) charity or retained by GIMPS to fund awards or cover its
+ expenses.
+ - Other Disqualifications. GIMPS reserves the right to deny award
+ payment if the Awardee is determined by the GIMPS board of directors
+ to be personally, or affiliated with, or organized under, a charter
+ or entity, practicing or promoting interests counter to humanitarian
+ good or public benefit. GIMPS may require Awardee to execute an
+ affidavit of eligibility according to these Rules.
+ - Assignment of Specific Interest. Whereas GIMPS has undertaken an
+ organized and systematic attempt to earn the $150,000 (USD)
+ Electronic Frontier Foundation ("EFF") Cooperative Computing Award,
+ all Participants and Awardees agree to the Rules and release their
+ entire interest in the EFF award to GIMPS (see Research Discovery
+ Awards).
+ - Final Authority. Decisions of the GIMPS board of directors in
+ applying the TCU and Rules, and in granting awards, are final.
+ - Rule Changes. These Rules, as in effect at the date and time of a
+ discovery, shall apply. GIMPS reserves the right to change these
+ Rules without notice. Last updated 06 January 2010.
+
+2) Research Discovery Awards
+
+Mersenne Prime Award of USD $3,000.00
+Awarded to a GIMPS Participant for each new Mersenne prime discovered
+after August 23, 2008 and having fewer than 100,000,000 (decimal) digits.
+Rules in addition to the General Award Rules:
+
+ - The award is presently $3,000. A maximum of $5,000 USD and minimum
+ of $1,000 will be awarded, as determined by the GIMPS board of
+ directors from actual and forecast award funds availability.
+ GIMPS may, at its sole discretion and without notice, change the
+ award amount or retroactively increase certain previously-awarded
+ Research Discovery Awards up to the maximum amount.
+ - Verification may take several weeks. No money will be awarded until
+ the discovery is independently verified, and the award money is
+ available after GIMPS annual operating expenses.
+ - In the unlikely event that an identical qualifying prime is
+ discovered at about the same time by two or more Participants, then
+ the winner will be the first to either send their result to the
+ GIMPS PrimeNet server or to email their results to GIMPS.
+
+100 Million Digit Prime Award of USD $50,000.00
+Awarded to a GIMPS Participant for the first prime discovered having at
+least 100,000,000 (decimal) digits. Rules in addition to the General
+Award Rules:
+
+ - GIMPS has undertaken an organized and systematic attempt to earn the
+ $150,000 (USD) Electronic Frontier Foundation ("EFF") Cooperative
+ Computing Award such that each Participant assigns all interest in
+ this award entirely to GIMPS. Note that this Award may at current
+ participation rates require an estimated 12-15 years of calculations
+ before a qualifying discovery is made.
+ - No money will be awarded unless and until a GIMPS Participant's
+ computer discovers a 100,000,000 digit prime, it is independently
+ verified, EFF validates GIMPS' claim according to their rules, and
+ pays GIMPS the award.
+ - Verification may take several weeks and publication in a suitable
+ academic refereed journal as required by EFF rules will likely take
+ several more months.
+ - GIMPS will redistribute the EFF award money into thirds as follows:
+ -- $50,000 will be awarded to the discoverer Awardee of the
+ 100,000,000 digit prime.
+ -- $50,000 will be awarded to a 501(c)(3) mathematics-related charity
+ selected by GIMPS.
+ -- $50,000 will be retained by GIMPS to cover expenses and/or fund
+ future or past awards.
+ - In the unlikely event that more than one qualifying prime is
+ discovered at about the same time, then the winner will be the first
+ to either send their result to the GIMPS PrimeNet server or to email
+ their results to GIMPS.
+
+Privacy Policy
+
+Thank you for investing your trust. Since 1996, we never have and never
+will sell, distribute or release your email address or any other
+information you provide us for the administration and operation of this
+amazing public participation research project, except in the unlikely
+requirement to comply with law. Last updated 15 October 2008.
+Software End User License Agreement ("EULA")
+
+ - This EULA applies to all versions of GIMPS Prime95 and MPrime
+ software and source code ("Software").
+ - Software is free to download and use indefinitely on any computer(s)
+ you own or for which you have permission and authority to install and
+ run Software. Software is not export-restricted.
+ - To use the Software you agree to be bound by this EULA and the Terms
+ and Conditions of Use.
+ - GIMPS reserves the right to change this EULA without notice and with
+ reasonable retroactive effect. Last updated 15 October 2008.
+ - GIMPS not responsible for any damages or losses arising from use of
+ Software. SOFTWARE AND INFORMATION IS PROVIDED "AS IS" WITHOUT
+ WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT
+ LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS
+ FOR A PARTICULAR PURPOSE.
diff --git a/math/mprime/files/pkg-message.in b/math/mprime/files/pkg-message.in
deleted file mode 100644
index 46a39c0949cd..000000000000
--- a/math/mprime/files/pkg-message.in
+++ /dev/null
@@ -1,10 +0,0 @@
- ATTENTIONATTENTION:
-
-Please, make sure that you read
-%%DOCSDIR%%/license.txt
-and agree to the licensing terms before running this application.
-
-Furthermore, read
-%%DOCSDIR%%/readme.txt
-It contains important information about both configuring and running
-mprime. You will have problems running it if you do not read it.
diff --git a/math/mprime/pkg-plist b/math/mprime/pkg-plist
deleted file mode 100644
index dc8c8dae1333..000000000000
--- a/math/mprime/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-bin/mprime
-bin/mprime-real
-%%PORTDOCS%%%%DOCSDIR%%/license.txt
-%%PORTDOCS%%%%DOCSDIR%%/readme.txt
-%%PORTDOCS%%%%DOCSDIR%%/stress.txt
-%%PORTDOCS%%%%DOCSDIR%%/undoc.txt
-%%PORTDOCS%%%%DOCSDIR%%/whatsnew.txt