aboutsummaryrefslogtreecommitdiff
path: root/math/mumps4
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2020-11-17 22:15:22 +0000
committerMark Linimon <linimon@FreeBSD.org>2020-11-17 22:15:22 +0000
commit9657fec72cb89da33430eb1afd6e9de308de9de0 (patch)
treeae31f1fa2ac0d9a433806270d9fb00e42ea4c77f /math/mumps4
parent346de0e3983422367494f79a6fb1f054b75697ab (diff)
downloadports-9657fec72cb89da33430eb1afd6e9de308de9de0.tar.gz
ports-9657fec72cb89da33430eb1afd6e9de308de9de0.zip
Add workaround for Fortran frontend in GCC 10.
PR: 246700
Notes
Notes: svn path=/head/; revision=555593
Diffstat (limited to 'math/mumps4')
-rw-r--r--math/mumps4/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/math/mumps4/Makefile b/math/mumps4/Makefile
index 06f515678e6b..2d47b6ad3435 100644
--- a/math/mumps4/Makefile
+++ b/math/mumps4/Makefile
@@ -61,6 +61,11 @@ BLASLIB= -lblas
#LAPACKLIB= -llapack
.endif
+.if ${GCC_DEFAULT} >= 10
+# workaround for Type mismatch in argument 's' at (1); passed INTEGER(4) to LOGICAL(4)
+FCFLAGS+= -fallow-argument-mismatch
+.endif
+
pre-configure:
${INSTALL_DATA} ${WRKSRC}/Make.inc/Makefile.inc.generic.SEQ \
${WRKSRC}/Makefile.inc