aboutsummaryrefslogtreecommitdiff
path: root/math/mumps
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2020-12-09 11:07:41 +0000
committerThierry Thomas <thierry@FreeBSD.org>2020-12-09 11:07:41 +0000
commit376636fda5a230de7d7dcd1ccccc128cd51a8474 (patch)
treed8079db1fc2d5809bb5fd0812fe55b80fde9d98b /math/mumps
parent932a4703bcabb15576d4d5e9ef6f814de22a4153 (diff)
downloadports-376636fda5a230de7d7dcd1ccccc128cd51a8474.tar.gz
ports-376636fda5a230de7d7dcd1ccccc128cd51a8474.zip
Modify cad/scotch to install shared libraries.
Chase these libraries to the consumers ports.
Notes
Notes: svn path=/head/; revision=557366
Diffstat (limited to 'math/mumps')
-rw-r--r--math/mumps/Makefile11
-rw-r--r--math/mumps/files/patch-Make.inc_Makefile.FREEBSD10.PAR4
-rw-r--r--math/mumps/files/patch-Make.inc_Makefile.FREEBSD10.SEQ14
3 files changed, 23 insertions, 6 deletions
diff --git a/math/mumps/Makefile b/math/mumps/Makefile
index 974288f7c12e..8e9834ffe902 100644
--- a/math/mumps/Makefile
+++ b/math/mumps/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mumps
DISTVERSION= 5.1.2-aster7
+PORTREVISION= 1
CATEGORIES= math
PKGNAMESUFFIX= -edf
@@ -29,10 +30,10 @@ PLIST_SUB= VE=${VEM} MUMPSVERSION=${MUMPSVERSION}
OPTIONS_DEFINE= DOCS EXAMPLES MPI
-MPI_BUILD_DEPENDS_OFF= ${LOCALBASE}/lib/libscotch.a:cad/scotch
-MPI_BUILD_DEPENDS= ${LOCALBASE}/lib/libptscotch.a:cad/scotch
+MPI_LIB_DEPENDS_OFF= libscotch.so:cad/scotch
MPI_LIB_DEPENDS= libmpi.so:net/mpich \
libparmetis.so:math/parmetis \
+ libptscotch.so:cad/scotch \
libscalapack.so:math/scalapack
MPI_PLIST_SUB= WITH_LIBSEQ="@comment "
MPI_PLIST_SUB_OFF= WITH_LIBSEQ=""
@@ -74,6 +75,12 @@ pre-configure:
s+@LOCALBASE@+${LOCALBASE}+g;' \
${WRKSRC}/${MF}
.endfor
+.ifdef WITH_MPI
+ ${REINPLACE_CMD} -e '/lptscotch/s|#LSCOTCH|LSCOTCH|' \
+ -e 's|^LMETIS|##LMETIS|;s|^#LMETIS|LMETIS|' ${WRKSRC}/Makefile.inc
+.else
+ ${REINPLACE_CMD} -e '/lscotch/s|#LSCOTCH|LSCOTCH|' ${WRKSRC}/Makefile.inc
+.endif
do-install:
${INSTALL_DATA} ${WRKSRC}/include/*.h ${STAGEDIR}${PREFIX}/include
diff --git a/math/mumps/files/patch-Make.inc_Makefile.FREEBSD10.PAR b/math/mumps/files/patch-Make.inc_Makefile.FREEBSD10.PAR
index d846883600fc..af58b3336740 100644
--- a/math/mumps/files/patch-Make.inc_Makefile.FREEBSD10.PAR
+++ b/math/mumps/files/patch-Make.inc_Makefile.FREEBSD10.PAR
@@ -15,8 +15,8 @@
-#LSCOTCH = -L$(SCOTCHDIR)/lib -lesmumps -lscotch -lscotcherr
-#LSCOTCH = -L$(SCOTCHDIR)/lib -lptesmumps -lptscotch -lptscotcherr
-+#LSCOTCH = -L@LOCALBASE@/lib -lesmumps -lscotch -lscotcherr
-+LSCOTCH = -L@LOCALBASE@/lib -lptesmumps -lptscotch -lptscotcherr
++#LSCOTCH = -L@LOCALBASE@/lib -lesmumps -lscotch -lscotcherr -lz
++LSCOTCH = -L@LOCALBASE@/lib -lptesmumps -lscotch -lptscotch -lptscotcherr -lz
LPORDDIR = $(topdir)/PORD/lib/
diff --git a/math/mumps/files/patch-Make.inc_Makefile.FREEBSD10.SEQ b/math/mumps/files/patch-Make.inc_Makefile.FREEBSD10.SEQ
index 64027c40df1c..7d5c59f56b6e 100644
--- a/math/mumps/files/patch-Make.inc_Makefile.FREEBSD10.SEQ
+++ b/math/mumps/files/patch-Make.inc_Makefile.FREEBSD10.SEQ
@@ -1,4 +1,4 @@
---- Make.inc/Makefile.FREEBSD10.SEQ.orig 2019-04-03 14:40:12 UTC
+--- Make.inc/Makefile.FREEBSD10.SEQ.orig 2020-10-23 09:16:48 UTC
+++ Make.inc/Makefile.FREEBSD10.SEQ
@@ -20,7 +20,7 @@
#
@@ -9,7 +9,17 @@
#
# You have to choose one among the following two lines depending on
# the type of analysis you want to perform. If you want to perform only
-@@ -36,8 +36,8 @@ LPORDDIR = $(topdir)/PORD/lib/
+@@ -28,16 +28,16 @@
+ # variable below); for both parallel and sequential analysis choose the second
+ # line (remember to add -Dptscotch in the ORDERINGSF variable below)
+
+-#LSCOTCH = -L$(SCOTCHDIR)/lib -lesmumps -lscotch -lscotcherr
+-#LSCOTCH = -L$(SCOTCHDIR)/lib -lptesmumps -lptscotch -lptscotcherr
++#LSCOTCH = -L$(SCOTCHDIR)/lib -lesmumps -lscotch -lscotcherr -lz
++#LSCOTCH = -L$(SCOTCHDIR)/lib -lptesmumps -lptscotch -lptscotcherr -lz
+
+
+ LPORDDIR = $(topdir)/PORD/lib/
IPORD = -I$(topdir)/PORD/include/
LPORD = -L$(LPORDDIR) -lpord