aboutsummaryrefslogtreecommitdiff
path: root/math/nauty
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-05-17 09:51:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-05-17 09:51:11 +0000
commit5b3bbd5ad061851aa13dceb19794da6f46eca0bb (patch)
tree383d455f200006ab384867cc5b05ca68ab1555c2 /math/nauty
parent842ee794b6914a6b451677cf67c15348aa89aade (diff)
downloadports-5b3bbd5ad061851aa13dceb19794da6f46eca0bb.tar.gz
ports-5b3bbd5ad061851aa13dceb19794da6f46eca0bb.zip
- Fix build
- Support PLIST_FILES PR: 187746 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=354303
Diffstat (limited to 'math/nauty')
-rw-r--r--math/nauty/Makefile37
-rw-r--r--math/nauty/pkg-plist24
2 files changed, 20 insertions, 41 deletions
diff --git a/math/nauty/Makefile b/math/nauty/Makefile
index d6ba51bd51c9..3d24ab8c4ccb 100644
--- a/math/nauty/Makefile
+++ b/math/nauty/Makefile
@@ -5,34 +5,37 @@ PORTNAME= nauty
PORTVERSION= 2.4r2
CATEGORIES= math
MASTER_SITES= http://cs.anu.edu.au/~bdm/nauty/
-DISTNAME= ${PORTNAME}24r2
+DISTNAME= ${PORTNAME}${PORTVERSION:S!.!!}
MAINTAINER= ports@FreeBSD.org
COMMENT= Brendan McKay's graph isomorphism tester
-WRKSRC= ${WRKDIR}/${PORTNAME}24r2
+USES= gmake
+GNU_CONFIGURE= yes
MAKEFILE= makefile
-USE_CSTD= gnu89
-GNU_CONFIGURE= YES
+
PORTDOCS= nug.pdf
+PLIST_FILES= ${PROGRAMS:S!^!bin/!}
+
+OPTIONS_DEFINE= DOCS
+
+PROGRAMS= NRswitchg addedgeg amtog biplabg catg complg copyg \
+ countg deledgeg directg dreadnaut dretog genbg geng \
+ genrang gentourng labelg listg multig newedgeg pickg \
+ planarg shortg showg
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|gcc|${CC}|; s|-O4 -march=i686|${CFLAGS}|' \
- ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -e \
+ 's|gcc|$${CC}| ; \
+ s|-O4 -march=i686|$${CFLAGS}|' ${WRKSRC}/${MAKEFILE}
do-install:
- cd ${WRKSRC}; ${INSTALL_PROGRAM} dreadnaut copyg listg labelg dretog \
- amtog geng complg shortg showg NRswitchg biplabg addedgeg \
- deledgeg countg pickg genrang newedgeg catg genbg directg \
- multig planarg gentourng ${PREFIX}/bin
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+.for i in ${PROGRAMS}
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${i} ${STAGEDIR}${PREFIX}/bin)
+.endfor
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${STAGEDIR}${DOCSDIR})
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/math/nauty/pkg-plist b/math/nauty/pkg-plist
deleted file mode 100644
index e902ae269074..000000000000
--- a/math/nauty/pkg-plist
+++ /dev/null
@@ -1,24 +0,0 @@
-bin/NRswitchg
-bin/addedgeg
-bin/amtog
-bin/biplabg
-bin/catg
-bin/complg
-bin/copyg
-bin/countg
-bin/deledgeg
-bin/directg
-bin/dreadnaut
-bin/dretog
-bin/genbg
-bin/geng
-bin/genrang
-bin/gentourng
-bin/labelg
-bin/listg
-bin/multig
-bin/newedgeg
-bin/pickg
-bin/planarg
-bin/shortg
-bin/showg