aboutsummaryrefslogtreecommitdiff
path: root/math/ndiff
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2004-06-02 17:18:39 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2004-06-02 17:18:39 +0000
commiteb050698650cd1c5fc82b78ea5edfd581127e819 (patch)
treeb582210cb09ead60e0ca55760fb1a0186c951d9c /math/ndiff
parent188ecf39c3ef56b0f0bb9e32fed9451b9427d855 (diff)
downloadports-eb050698650cd1c5fc82b78ea5edfd581127e819.tar.gz
ports-eb050698650cd1c5fc82b78ea5edfd581127e819.zip
Notes
Diffstat (limited to 'math/ndiff')
-rw-r--r--math/ndiff/Makefile19
-rw-r--r--math/ndiff/files/patch-Makefile.in12
2 files changed, 29 insertions, 2 deletions
diff --git a/math/ndiff/Makefile b/math/ndiff/Makefile
index e32da3cb94aa..5801a223f881 100644
--- a/math/ndiff/Makefile
+++ b/math/ndiff/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ndiff
PORTVERSION= 2.00
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ftp://ftp.math.utah.edu/pub/misc/
PKGNAMEPREFIX=
@@ -14,8 +15,22 @@ PKGNAMEPREFIX=
MAINTAINER= ports@FreeBSD.org
COMMENT= Compare putatively similar files, ignoring small numeric differences
+.include <bsd.port.pre.mk>
+
.if !defined(WITHOUT_GMP)
-LIB_DEPENDS= gmp:${PORTSDIR}/math/libgmp-freebsd
+.if ${OSVERSION} > 500023
+LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+.endif
+CONFIGURE_ARGS= --with-gmp
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+.else
+.if ${ARCH} == sparc64
+CONFIGURE_ARGS= --with-long-double
+.else
+CONFIGURE_ARGS= --with-double
+.endif
.endif
GNU_CONFIGURE= yes
@@ -41,4 +56,4 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.html ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/ndiff/files/patch-Makefile.in b/math/ndiff/files/patch-Makefile.in
index a9e603a03884..6d2926c662df 100644
--- a/math/ndiff/files/patch-Makefile.in
+++ b/math/ndiff/files/patch-Makefile.in
@@ -1,5 +1,17 @@
--- Makefile.in.orig Wed Feb 18 14:17:22 2004
+++ Makefile.in Wed Feb 18 14:19:31 2004
+@@ -191,9 +191,9 @@
+
+ DEFINES = -DVERSION='"@VERSION@"' -DDATE='"@DATE@"' $(XDEFINES)
+
+-INCLUDES = -I. -I$(prefix)/include $(XINCLUDES)
++INCLUDES = -I. $(XINCLUDES)
+
+-LDFLAGS = @LDFLAGS@ -L$(prefix)/lib $(XLDFLAGS)
++LDFLAGS = @LDFLAGS@ $(XLDFLAGS)
+
+ LIBS = @LIBS@ $(XLIBS)
+
@@ -602,14 +602,12 @@
if test -f $(PROGNAME) ; \
then \