aboutsummaryrefslogtreecommitdiff
path: root/math/ocaml-zarith
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-10-16 09:03:43 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-10-16 09:03:43 +0000
commiteeb39316e3b4129fe7a989e98c51111809fd2c59 (patch)
tree7be92479b3c6092cbb400a31a50bbe91ebaa90e1 /math/ocaml-zarith
parenta8e577f421e033afe0f8b00fb470ac9f029fc7c8 (diff)
downloadports-eeb39316e3b4129fe7a989e98c51111809fd2c59.tar.gz
ports-eeb39316e3b4129fe7a989e98c51111809fd2c59.zip
- Fix license
- Add LICENSE_FILE - Fix build on arm
Notes
Notes: svn path=/head/; revision=424051
Diffstat (limited to 'math/ocaml-zarith')
-rw-r--r--math/ocaml-zarith/Makefile8
-rw-r--r--math/ocaml-zarith/files/patch-configure17
2 files changed, 18 insertions, 7 deletions
diff --git a/math/ocaml-zarith/Makefile b/math/ocaml-zarith/Makefile
index 289db7a91832..bb9bc52dc219 100644
--- a/math/ocaml-zarith/Makefile
+++ b/math/ocaml-zarith/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= ocaml-
MAINTAINER= ports@FreeBSD.org
COMMENT= OCaml arithmetic library for arbitrary precision integers
-LICENSE= GPLv2
+LICENSE= LGPL20
+LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libgmp.so:math/gmp
@@ -22,13 +23,12 @@ OCAMLFIND_LDCONF= /dev/null
HAS_CONFIGURE= yes
ALL_TARGET= all
SHEBANG_FILES= z_pp.pl
-CONFIGURE_ENV+= DESTDIR=${STAGEDIR}
+CONFIGURE_ENV= DESTDIR=${STAGEDIR}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
-BROKEN_armv6= binary /nxb-bin/usr/bin/cc: not found
PORTDOCS= html
DOCSDIR= ${OCAML_DOCSDIR}/${PORTNAME}
@@ -37,7 +37,7 @@ OPTIONS_DEFINE= DOCS
DOCS_ALL_TARGET=doc
post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${MV} ${WRKSRC}/html ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/math/ocaml-zarith/files/patch-configure b/math/ocaml-zarith/files/patch-configure
index d8022f7de1b1..6a42bd3e0d82 100644
--- a/math/ocaml-zarith/files/patch-configure
+++ b/math/ocaml-zarith/files/patch-configure
@@ -1,6 +1,17 @@
---- configure.orig 2013-06-12 07:13:59.000000000 +0000
+--- configure.orig 2013-06-12 07:13:59 UTC
+++ configure
-@@ -304,6 +304,14 @@ case $host in
+@@ -127,6 +127,10 @@ searchbin()
+ {
+ if test "x$1" = "x"; then return 0; fi
+ echo_n "binary $1: "
++ if test -x "$1"; then
++ echo "found"
++ return 1
++ fi
+ IFS=':'
+ for i in $PATH
+ do
+@@ -304,6 +308,14 @@ case $host in
arch='i686'
fi
;;
@@ -15,7 +26,7 @@
i386-*darwin* | x86_64-*darwin*)
ccdef="-DZ_UNDERSCORE_PREFIX -DZ_MACOS $ccdef"
if test "x$wordsize" = "x64"; then
-@@ -401,7 +409,7 @@ CFLAGS=$ccinc $ccdef $ccopt
+@@ -401,7 +413,7 @@ CFLAGS=$ccinc $ccdef $ccopt
ASFLAGS=$ccdef $asopt
LIBS=$cclib
ARCH=$arch