aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-doctest/Makefile
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2015-07-08 23:37:47 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2015-07-08 23:37:47 +0000
commit93367a6c049c32d25f3791810eebd0f5475d9346 (patch)
treeb980d6f2f57c3f046af644726b2333dd30180159 /math/octave-forge-doctest/Makefile
parent2c177dde87b50ca496b607e9895c1dfe8a9d1f01 (diff)
downloadports-93367a6c049c32d25f3791810eebd0f5475d9346.tar.gz
ports-93367a6c049c32d25f3791810eebd0f5475d9346.zip
Notes
Diffstat (limited to 'math/octave-forge-doctest/Makefile')
-rw-r--r--math/octave-forge-doctest/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/math/octave-forge-doctest/Makefile b/math/octave-forge-doctest/Makefile
new file mode 100644
index 000000000000..ce920d30f7bb
--- /dev/null
+++ b/math/octave-forge-doctest/Makefile
@@ -0,0 +1,26 @@
+# Created by: Stephen Montgomery-Smith <stephen@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= octave-forge-doctest
+PORTVERSION= 0.4.0
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>