aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-image
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2011-11-21 01:17:40 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2011-11-21 01:17:40 +0000
commitdf56e1f431553fe11f5a8e45d94d71e5bc584ad4 (patch)
treea49ff5cb6b00ab4e248704a358294b0151f9ee4f /math/octave-forge-image
parentd9b2767be3eb8223e3bebb0529ddd1d8771bba4a (diff)
downloadports-df56e1f431553fe11f5a8e45d94d71e5bc584ad4.tar.gz
ports-df56e1f431553fe11f5a8e45d94d71e5bc584ad4.zip
- Cosmetic change to Makefile. Use the variable OCTSRC to describe where the
contents of the package are stored. This should make it easier if other people take over maintainership of the octave-forge-* ports. Feature safe: yes
Notes
Notes: svn path=/head/; revision=286140
Diffstat (limited to 'math/octave-forge-image')
-rw-r--r--math/octave-forge-image/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/math/octave-forge-image/Makefile b/math/octave-forge-image/Makefile
index 83007638f1ff..c07cfc4b257c 100644
--- a/math/octave-forge-image/Makefile
+++ b/math/octave-forge-image/Makefile
@@ -12,7 +12,11 @@ CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/Mk/bsd.octave.mk"
@@ -21,6 +25,6 @@ post-patch:
post-build:
${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${DISTNAME}
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
.include <bsd.port.post.mk>