aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-mechanics
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2020-01-06 01:39:20 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2020-01-06 01:39:20 +0000
commit535a489b18eabb004678e993986b7b7e8adebf27 (patch)
tree879d95a02fe000f139b5c6c522b733c15c75e8e3 /math/octave-forge-mechanics
parenta02b63905571da8b35f4ad878819877f727e6b82 (diff)
downloadports-535a489b18eabb004678e993986b7b7e8adebf27.tar.gz
ports-535a489b18eabb004678e993986b7b7e8adebf27.zip
- Resurrect port math/octave-forge-mechanics.
- Bump portrevision.
Notes
Notes: svn path=/head/; revision=522181
Diffstat (limited to 'math/octave-forge-mechanics')
-rw-r--r--math/octave-forge-mechanics/Makefile31
-rw-r--r--math/octave-forge-mechanics/distinfo2
-rw-r--r--math/octave-forge-mechanics/pkg-descr10
3 files changed, 43 insertions, 0 deletions
diff --git a/math/octave-forge-mechanics/Makefile b/math/octave-forge-mechanics/Makefile
new file mode 100644
index 000000000000..d4fcfdb8e7c0
--- /dev/null
+++ b/math/octave-forge-mechanics/Makefile
@@ -0,0 +1,31 @@
+# Created by: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+# $FreeBSD$
+
+PORTNAME= octave-forge-mechanics
+PORTVERSION= 1.3.1
+PORTREVISION= 17
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+
+RUN_DEPENDS+= ${TARBALLS_DIR}/general.tar.gz:math/octave-forge-general
+RUN_DEPENDS+= ${TARBALLS_DIR}/geometry.tar.gz:math/octave-forge-geometry
+RUN_DEPENDS+= ${TARBALLS_DIR}/linear-algebra.tar.gz:math/octave-forge-linear-algebra
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${OCTAVE_PKGNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/inst/molecularDynamics/src
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+post-build:
+ ${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>
diff --git a/math/octave-forge-mechanics/distinfo b/math/octave-forge-mechanics/distinfo
new file mode 100644
index 000000000000..769f8ced0b5e
--- /dev/null
+++ b/math/octave-forge-mechanics/distinfo
@@ -0,0 +1,2 @@
+SHA256 (octave-forge/mechanics-1.3.1.tar.gz) = 06291ede6589761cec329d213a81bce7c68a26ef8adf9ff5c9d66ffbf021bf6c
+SIZE (octave-forge/mechanics-1.3.1.tar.gz) = 67844
diff --git a/math/octave-forge-mechanics/pkg-descr b/math/octave-forge-mechanics/pkg-descr
new file mode 100644
index 000000000000..cd13e5b94a58
--- /dev/null
+++ b/math/octave-forge-mechanics/pkg-descr
@@ -0,0 +1,10 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is mechanics.
+
+ Library with functions useful for numerical computation in classical mechanics.
+
+WWW: http://octave.sourceforge.net/