aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-miscellaneous
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2014-05-17 19:57:55 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2014-05-17 19:57:55 +0000
commit9e6c3ab7fdad9f91c29e1714bb5d999af74176a6 (patch)
tree59de5efc927e5babf2b06c1eba4e495c5367a6d2 /math/octave-forge-miscellaneous
parent179a54755e90f586b4d28bfb22ec7ffd4b9d8323 (diff)
Notes
Diffstat (limited to 'math/octave-forge-miscellaneous')
-rw-r--r--math/octave-forge-miscellaneous/Makefile2
-rw-r--r--math/octave-forge-miscellaneous/files/patch-partarray.cc12
2 files changed, 7 insertions, 7 deletions
diff --git a/math/octave-forge-miscellaneous/Makefile b/math/octave-forge-miscellaneous/Makefile
index 9504541bc57b..f816f59c5291 100644
--- a/math/octave-forge-miscellaneous/Makefile
+++ b/math/octave-forge-miscellaneous/Makefile
@@ -3,7 +3,7 @@
PORTNAME= octave-forge-miscellaneous
PORTVERSION= 1.2.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
diff --git a/math/octave-forge-miscellaneous/files/patch-partarray.cc b/math/octave-forge-miscellaneous/files/patch-partarray.cc
index 417863ab1447..177a69305df6 100644
--- a/math/octave-forge-miscellaneous/files/patch-partarray.cc
+++ b/math/octave-forge-miscellaneous/files/patch-partarray.cc
@@ -18,8 +18,8 @@
{
error ("%s: argument %i: wrong dimensions",
fname.c_str (), i + 2);
-+ delete(bidc);
-+ delete(eidc);
++ delete[](bidc);
++ delete[](eidc);
return Cell ();
}
cnidx =
@@ -29,8 +29,8 @@
}
- if (error_state)
+ if (error_state) {
-+ delete(bidc);
-+ delete(eidc);
++ delete[](bidc);
++ delete[](eidc);
return Cell ();
+ }
@@ -40,8 +40,8 @@
}
}
-+ delete(bidc);
-+ delete(eidc);
++ delete[](bidc);
++ delete[](eidc);
return retval;
}