aboutsummaryrefslogtreecommitdiff
path: root/math/octave/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-05-09 12:00:55 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-05-09 12:00:55 +0000
commitc2b5d3fb67e9333db428f69529deecd2415f96e1 (patch)
tree6ba583dee2ebfb23c603cfc8048187970e47a7f9 /math/octave/Makefile
parentf64b966d40273675da41c7f6834bf7977d703dfe (diff)
downloadports-c2b5d3fb67e9333db428f69529deecd2415f96e1.tar.gz
ports-c2b5d3fb67e9333db428f69529deecd2415f96e1.zip
Notes
Diffstat (limited to 'math/octave/Makefile')
-rw-r--r--math/octave/Makefile102
1 files changed, 42 insertions, 60 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 510b10d38e6d..f30678eee9ba 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -3,7 +3,7 @@
PORTNAME= octave
PORTVERSION= 3.8.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= octave
@@ -13,42 +13,55 @@ COMMENT= High-level interactive language for numerical computations
LICENSE= GPLv3
-BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot \
+BUILD_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf \
gsed:${PORTSDIR}/textproc/gsed \
${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
gsed:${PORTSDIR}/textproc/gsed \
${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo
-LIB_DEPENDS= GraphicsMagick.14:${PORTSDIR}/graphics/GraphicsMagick13 \
- arpack:${PORTSDIR}/math/arpack \
- curl:${PORTSDIR}/ftp/curl \
- fftw3:${PORTSDIR}/math/fftw3 \
- fftw3f:${PORTSDIR}/math/fftw3-float \
- fltk.1:${PORTSDIR}/x11-toolkits/fltk \
- ftgl:${PORTSDIR}/graphics/ftgl \
+LIB_DEPENDS= libGraphicsMagick.so.14:${PORTSDIR}/graphics/GraphicsMagick13 \
+ libarpack.so:${PORTSDIR}/math/arpack \
+ libcurl.so:${PORTSDIR}/ftp/curl \
+ libfftw3.so:${PORTSDIR}/math/fftw3 \
+ libfftw3f.so:${PORTSDIR}/math/fftw3-float \
+ libfltk.so:${PORTSDIR}/x11-toolkits/fltk \
+ libftgl.so:${PORTSDIR}/graphics/ftgl \
libhdf5.so:${PORTSDIR}/science/hdf5 \
- pcre.3:${PORTSDIR}/devel/pcre \
- qhull.5:${PORTSDIR}/math/qhull5 \
- qrupdate:${PORTSDIR}/math/qrupdate \
- umfpack.1:${PORTSDIR}/math/suitesparse \
- glpk:${PORTSDIR}/math/glpk \
- gl2ps:${PORTSDIR}/print/gl2ps
-
-USES= charsetfix fortran gmake perl5 pkgconfig
-USE_BZIP2= yes
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libqhull.so.5:${PORTSDIR}/math/qhull5 \
+ libqrupdate.so:${PORTSDIR}/math/qrupdate \
+ libumfpack.so:${PORTSDIR}/math/suitesparse \
+ libglpk.so:${PORTSDIR}/math/glpk \
+ libgl2ps.so:${PORTSDIR}/print/gl2ps
+
+USES= charsetfix fortran gmake libtool perl5 pkgconfig tar:bzip2
USE_PERL5= build
USE_TEX= dvipsk:build
GNU_CONFIGURE= yes
-#USE_AUTOTOOLS= autoconf
USE_JAVA= yes
JAVA_VERSION= 1.7+
-CONFIGURE_ENV+= JAVA_HOME=${JAVA_HOME}
USE_QT4= gui network
+OCTAVE_VERSION= ${PORTVERSION}
+GNU_HOST= ${ARCH}-portbld-freebsd${OSREL}
+PLIST_SUB= OCTAVE_VERSION=${OCTAVE_VERSION} GNU_HOST=${GNU_HOST}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= GPERF="${LOCALBASE}/bin/gperf" \
+ JAVA_HOME=${JAVA_HOME} \
+ MAKEINFO=${LOCALBASE}/bin/makeinfo
+CONFIGURE_ARGS= --host=${GNU_HOST} \
+ --with-blas="-L${LOCALBASE}/lib ${BLAS}" \
+ --with-lapack="${LAPACK}" \
+ --enable-shared \
+ --disable-jit
+
+OPTIONS_DEFINE= DOCS
+
INFO= octave liboctave
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if exists(${LOCALBASE}/lib/libopenblas.so)
WITH_BLAS?= openblas
@@ -61,69 +74,38 @@ WITH_BLAS?= reference
.endif
. if ${WITH_BLAS} == reference
-LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so.2:${PORTSDIR}/math/blas \
+ liblapack.so.4:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.elif ${WITH_BLAS} == openblas
-LIB_DEPENDS+= openblas:${PORTSDIR}/math/openblas
+LIB_DEPENDS+= libopenblas.so:${PORTSDIR}/math/openblas
BLAS= -lopenblasp
LAPACK= -lopenblasp
.elif ${WITH_BLAS} == gotoblas
-LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
+LIB_DEPENDS+= libgoto2.so:${PORTSDIR}/math/gotoblas
BLAS= -lgoto2p
LAPACK= -lgoto2p
.elif ${WITH_BLAS} == atlas
-LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
BLAS= -lptf77blas
LAPACK= -lalapack -lptcblas
.endif
-OCTAVE_VERSION= ${PORTVERSION}
-GNU_HOST= ${ARCH}-portbld-freebsd${OSREL}
-PLIST_SUB= OCTAVE_VERSION=${OCTAVE_VERSION} GNU_HOST=${GNU_HOST}
-INCLUDES= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-CFLAGS+= ${INCLUDES}
-CXXFLAGS+= ${INCLUDES}
-CPPFLAGS+= ${INCLUDES}
-CONFIGURE_ENV+= GPERF="${LOCALBASE}/bin/gperf" \
- CC="${CC}" \
- CXX="${CXX}" \
- MAKEINFO=${PREFIX}/bin/makeinfo
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-CONFIGURE_ARGS= --host=${GNU_HOST} \
- --with-blas="-L${LOCALBASE}/lib ${BLAS}" \
- --with-lapack="${LAPACK}" \
- --enable-shared \
- --disable-jit
-
-.if (${OSVERSION} <= 700000)
-WITH_PTMALLOC=yes
-.endif
-
-.if defined(WITH_PTMALLOC)
-LIB_DEPENDS+= ptmalloc:${PORTSDIR}/devel/ptmalloc
-CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -lptmalloc"
-.endif
-
post-patch:
- ${REINPLACE_CMD} 's+"makeinfo"+"${PREFIX}/bin/makeinfo"+' ${WRKSRC}/libinterp/corefcn/help.cc
+ ${REINPLACE_CMD} 's+"makeinfo"+"${LOCALBASE}/bin/makeinfo"+' ${WRKSRC}/libinterp/corefcn/help.cc
${REINPLACE_CMD} 's+-lumfpack+-lumfpack -lsuitesparseconfig -lamd -lcholmod -lcolamd ${LAPACK}+' ${WRKSRC}/configure
${REINPLACE_CMD} 's+-lcholmod+-lumfpack -lsuitesparseconfig -lamd -lcholmod -lcolamd ${LAPACK}+' ${WRKSRC}/configure
post-install:
- ${MKDIR} ${STAGEDIR}${DESKTOPDIR}
${INSTALL_DATA} ${WRKSRC}/doc/icons/octave.desktop \
- ${STAGEDIR}${DESKTOPDIR}/www.octave.org-octave.desktop
-.if !defined(NOPORTDOCS)
+ ${STAGEDIR}${DESKTOPDIR}/www.octave.org-octave.desktop
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in liboctave/liboctave.ps \
refcard/refcard-a4.ps refcard/refcard-legal.ps \
refcard/refcard-letter.ps interpreter/octave.ps
${INSTALL_DATA} ${WRKSRC}/doc/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
${RM} -f ${WRKDIR}/PLIST
.for d in ${PREFIX}/include/octave-${OCTAVE_VERSION} ${PREFIX}/share/octave/${OCTAVE_VERSION} ${PREFIX}/share/octave/site ${PREFIX}/lib/octave/${OCTAVE_VERSION} ${PREFIX}/libexec/octave/${OCTAVE_VERSION}
@${FIND} -s ${STAGEDIR}$d -not -type d | \
@@ -148,4 +130,4 @@ post-install:
check regression-test: build
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} check)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>