aboutsummaryrefslogtreecommitdiff
path: root/math/octave/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-11-12 20:11:15 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-11-12 20:11:15 +0000
commitfaad978beffdab9b45854b8438b0b324e6c6ae81 (patch)
tree0fcccb9a24694698a1fa3d575a9b5e70155807b7 /math/octave/Makefile
parentee9b96077b1f24736618eb1b3b71833bf8b36f69 (diff)
downloadports-faad978beffdab9b45854b8438b0b324e6c6ae81.tar.gz
ports-faad978beffdab9b45854b8438b0b324e6c6ae81.zip
Notes
Diffstat (limited to 'math/octave/Makefile')
-rw-r--r--math/octave/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index fe0d93d1734b..2828452fba51 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -112,20 +112,14 @@ post-install:
@${FIND} -s ${STAGEDIR}$d -not -type d -not -name '*.la' | \
${SED} -e 's#^${STAGEDIR}${PREFIX}/##' >> ${WRKDIR}/PLIST
@${FIND} -s ${STAGEDIR}$d -type d -empty | \
- ${SED} -e 's,^${STAGEDIR}${PREFIX}/,@exec ${MKDIR} %D/,' \
- -e 's,$$, 2>/dev/null || true,' >> ${WRKDIR}/PLIST
- @${FIND} -s ${STAGEDIR}$d -type d -depth | \
- ${SED} -e 's,^${STAGEDIR}${PREFIX}/,@dirrm ,' >> ${WRKDIR}/PLIST
+ ${SED} -e 's,^${STAGEDIR}${PREFIX}/,@dir ,' \
+ >> ${WRKDIR}/PLIST
.endfor
.for d in ${PREFIX}/libexec/octave/api-v49+ ${PREFIX}/libexec/octave/site ${PREFIX}/lib/octave/site
@${FIND} -s ${STAGEDIR}$d -type d -empty | \
- ${SED} -e 's,^${STAGEDIR}${PREFIX}/,@exec ${MKDIR} %D/,' \
- -e 's,$$, 2>/dev/null || true,' >> ${WRKDIR}/PLIST
- @${FIND} -s ${STAGEDIR}$d -type d -depth | \
- ${SED} -e 's,^${STAGEDIR}${PREFIX}/,@dirrm ,' >> ${WRKDIR}/PLIST
+ ${SED} -e 's,^${STAGEDIR}${PREFIX}/,@dir ,' \
+ >> ${WRKDIR}/PLIST
.endfor
- ${ECHO_CMD} @dirrm libexec/octave >> ${WRKDIR}/PLIST
- ${ECHO_CMD} @dirrm share/octave >> ${WRKDIR}/PLIST
cd ${WRKDIR} ; ${SED} -i.bak -e "/PLIST/ r PLIST" ${TMPPLIST}
check regression-test: build