aboutsummaryrefslogtreecommitdiff
path: root/math/octave
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /math/octave
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'math/octave')
-rw-r--r--math/octave/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index edf3ea81c6f3..f059036cf760 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -40,7 +40,7 @@ LIB_DEPENDS= libGraphicsMagick.so:graphics/GraphicsMagick \
libOSMesa.so:graphics/libosmesa \
libsundials_arkode.so:math/sundials
-USES= charsetfix fortran gmake libtool perl5 pkgconfig readline \
+USES= charsetfix fortran gmake libtool perl5 pkgconfig qt:5 readline \
tar:xz compiler:c++14-lang
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}/${PORTVERSION}
USE_PERL5= build
@@ -48,7 +48,7 @@ USE_TEX= dvipsk:build formats:build
GNU_CONFIGURE= yes
USE_JAVA= yes
JAVA_VERSION= 1.7+
-USE_QT5= core gui help network opengl \
+USE_QT= core gui help network opengl \
qmake_build buildtools_build linguist_build
USE_XORG= x11 xext xfixes xft
USE_GL= gl glu