aboutsummaryrefslogtreecommitdiff
path: root/math/ogdf
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-09-06 07:31:12 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-09-06 07:31:12 +0000
commit3764d29dad49077a47477258d5200a92976bd877 (patch)
treee388d3e1efc2e03d5931c06a9ad0954633342fe2 /math/ogdf
parent7577b4b8e2c5d47b50204d03f8eebef7f5b112ca (diff)
downloadports-3764d29dad49077a47477258d5200a92976bd877.tar.gz
ports-3764d29dad49077a47477258d5200a92976bd877.zip
- New port: math/ogdf
OGDF (Open Graph Drawing Framework) is a self-contained C++ class library for the automatic layout of diagrams. OGDF offers sophisticated algorithms and data structures to use within your own applications or scientific projects. The library provides: * A wide range of graph drawing algorithms that allow to reuse and replace particular algorithm phases by using a dedicated module mechanism. * Sophisticated data structures that are commonly used in graph drawing, equipped with rich public interfaces. * Self-contained code that does not require any additional libraries (except for some optional branch-and-cut algorithms). WWW: http://www.ogdf.net
Notes
Notes: svn path=/head/; revision=326473
Diffstat (limited to 'math/ogdf')
-rw-r--r--math/ogdf/Makefile61
-rw-r--r--math/ogdf/distinfo2
-rw-r--r--math/ogdf/files/patch-makeMakefile.config59
-rw-r--r--math/ogdf/files/patch-ogdf-basic_System.h20
-rw-r--r--math/ogdf/files/patch-ogdf-basic_basic.h12
-rw-r--r--math/ogdf/files/patch-src-basic_System.cpp77
-rw-r--r--math/ogdf/pkg-descr13
-rw-r--r--math/ogdf/pkg-plist390
8 files changed, 634 insertions, 0 deletions
diff --git a/math/ogdf/Makefile b/math/ogdf/Makefile
new file mode 100644
index 000000000000..738da6c387c7
--- /dev/null
+++ b/math/ogdf/Makefile
@@ -0,0 +1,61 @@
+# Created by: gahr
+# $FreeBSD$
+
+PORTNAME= ogdf
+PORTVERSION= 2012.07
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://people.freebsd.org/~gahr/distfiles/
+MASTER_SITE_SUBDIR= gahr
+DISTNAME= ogdf.v2012.07
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= C++ class library for the automatic layout of diagrams
+
+OPTIONS_DEFINE= COIN ABACUS
+COIN_DESC= Use the Coin Open Solver Interface (Osi)
+ABACUS_DESC= Use the ABACUS branch-and-cut library
+
+LICENSE= GPLv2
+
+USE_ZIP= yes
+USE_LDCONFIG= yes
+USE_PYTHON= build
+
+WRKSRC= ${WRKDIR}/${PORTNAME:U}
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MCOIN}
+LIB_DEPENDS+= Clp:${PORTSDIR}/math/coinmp
+USE_COIN= true
+.else
+USE_COIN= false
+.endif
+
+.if ${PORT_OPTIONS:MABACUS}
+USE_GCC= 4.4+
+LIB_DEPENDS+= abacus-osi:${PORTSDIR}/math/abacus
+USE_ABACUS= true
+USE_COIN= true
+.else
+USE_ABACUS= false
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e '\
+ s|%%CXX%%|${CXX}|g; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g; \
+ s|%%USE_COIN%%|${USE_COIN}|g; \
+ s|%%USE_ABACUS%%|${USE_ABACUS}|g' \
+ ${WRKSRC}/makeMakefile.config
+
+do-configure:
+ cd ${WRKSRC} && ${PYTHON_CMD} makeMakefile.py
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/_release/libOGDF.so ${PREFIX}/lib/libOGDF.so.1
+ ${LN} -sf libOGDF.so.1 ${PREFIX}/lib/libOGDF.so
+ cd ${WRKSRC} && ${COPYTREE_SHARE} ogdf ${PREFIX}/include
+
+.include <bsd.port.mk>
diff --git a/math/ogdf/distinfo b/math/ogdf/distinfo
new file mode 100644
index 000000000000..633433fbc01b
--- /dev/null
+++ b/math/ogdf/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ogdf.v2012.07.zip) = 818029b36e04f8f726606784f95c839b34d3372de0a60c8fbeb0b6e842b4fe01
+SIZE (ogdf.v2012.07.zip) = 2159592
diff --git a/math/ogdf/files/patch-makeMakefile.config b/math/ogdf/files/patch-makeMakefile.config
new file mode 100644
index 000000000000..cae78f1725a1
--- /dev/null
+++ b/math/ogdf/files/patch-makeMakefile.config
@@ -0,0 +1,59 @@
+--- makeMakefile.config.orig 2012-07-18 09:17:42.000000000 +0200
++++ makeMakefile.config 2013-06-18 12:18:55.000000000 +0200
+@@ -1,20 +1,20 @@
+ [GENERAL]
+ #**********************************************************
+ #* build OGDF as a static library (false) or shared library (true)
+-sharedLib = false
++sharedLib = true
+
+ #* name of the static (import) library
+ libName = libOGDF.a
+ #* name of the shared library (.dll for Windows, .so for Linux)
+ sharedlibName = libOGDF.so
+
+-compilerCommand = g++
++compilerCommand = %%CXX%%
+ compilerParams = -I.
+
+ #* command used to create a static library
+ libCommand = ar
+ #* command used to create a shared library
+-sharedlibCommand = g++
++sharedlibCommand = %%CXX%%
+
+ #* blank means don't call ranlib
+ ranlibCommand = ranlib
+@@ -43,16 +43,16 @@
+ [COIN]
+ #**********************************************************
+ #* set to "true" to use COIN
+-useCoin = false
+-coinIncl = /somewhere/COIN/include
++useCoin = %%USE_COIN%%
++coinIncl = %%LOCALBASE%%/include
+
+ #* Select your solver for COIN
+ #* CPLEX:
+ # solver_name = COIN_OSI_CPX
+ # solver_incl = /somewhere/ILOG/cplex90/include/ilcplex
+ #* Coin's CLP:
+-# solver_name = COIN_OSI_CLP
+-# solver_incl =
++solver_name = COIN_OSI_CLP
++solver_incl = %%LOCALBASE%%/include
+ #* Coin's Symphony
+ # solver_name = COIN_OSI_SYM
+ # solver_incl = /home/plug/COIN/SYMPHONY/include
+@@ -70,7 +70,7 @@
+
+ [ABACUS]
+ #**********************************************************
+-useAbacus = false
+-# abacusDef = -DABACUS_COMPILER_GCC
+-# abacusIncl = /somewhere/abacus/include
+-# abacusLib = -L/somewhere/abacus/lib/linux-gcc33 -labacus-cplex80
++useAbacus = %%USE_ABACUS%%
++abacusDef = -DABACUS_COMPILER_GCC
++abacusIncl = %%LOCALBASE%%/inclue/abacus
++abacusLib = -L%%LOCALBASE%%/lib -labacus-osi
diff --git a/math/ogdf/files/patch-ogdf-basic_System.h b/math/ogdf/files/patch-ogdf-basic_System.h
new file mode 100644
index 000000000000..47f94c5156f9
--- /dev/null
+++ b/math/ogdf/files/patch-ogdf-basic_System.h
@@ -0,0 +1,20 @@
+--- ogdf/basic/System.h.orig 2012-07-18 09:17:51.000000000 +0200
++++ ogdf/basic/System.h 2013-06-18 10:23:07.000000000 +0200
+@@ -51,7 +51,7 @@
+
+
+ #include <ogdf/basic/basic.h>
+-#if defined(OGDF_SYSTEM_OSX)
++#if defined(OGDF_SYSTEM_OSX) || defined(OGDF_SYSTEM_FREEBSD)
+ #include <stdlib.h>
+ #elif defined(OGDF_SYSTEM_UNIX) || defined(__MINGW32__)
+ #include <malloc.h>
+@@ -178,7 +178,7 @@
+ size_t alignment = 16;
+ #ifdef OGDF_SYSTEM_WINDOWS
+ return _aligned_malloc(size,alignment);
+-#elif defined(OGDF_SYSTEM_OSX)
++#elif defined(OGDF_SYSTEM_OSX) || defined(OGDF_SYSTEM_FREEBSD)
+ // malloc returns 16 byte aligned memory on OS X.
+ return malloc(size);
+ #else
diff --git a/math/ogdf/files/patch-ogdf-basic_basic.h b/math/ogdf/files/patch-ogdf-basic_basic.h
new file mode 100644
index 000000000000..aad386782a9e
--- /dev/null
+++ b/math/ogdf/files/patch-ogdf-basic_basic.h
@@ -0,0 +1,12 @@
+--- ogdf/basic/basic.h.orig 2013-06-18 10:18:02.000000000 +0200
++++ ogdf/basic/basic.h 2013-06-18 10:19:00.000000000 +0200
+@@ -88,6 +88,9 @@
+ #define OGDF_SYSTEM_OSX
+ #endif
+
++#if defined(__FreeBSD__)
++#define OGDF_SYSTEM_FREEBSD
++#endif
+
+ #if defined(USE_COIN) || defined(OGDF_OWN_LPSOLVER)
+ #define OGDF_LP_SOLVER
diff --git a/math/ogdf/files/patch-src-basic_System.cpp b/math/ogdf/files/patch-src-basic_System.cpp
new file mode 100644
index 000000000000..330ba8306cfe
--- /dev/null
+++ b/math/ogdf/files/patch-src-basic_System.cpp
@@ -0,0 +1,77 @@
+--- src/basic/System.cpp.orig 2013-06-10 17:33:24.000000000 +0200
++++ src/basic/System.cpp 2013-06-10 17:47:24.000000000 +0200
+@@ -51,6 +51,13 @@
+ #include <mach/vm_statistics.h>
+ #include <mach/mach.h>
+ #include <mach/machine.h>
++#elif defined(OGDF_SYSTEM_FREEBSD)
++#include <stdlib.h>
++#include <unistd.h>
++#include <sys/types.h>
++#include <sys/sysctl.h>
++#include <sys/time.h>
++#include <sys/resource.h>
+ #elif defined(OGDF_SYSTEM_UNIX)
+ #include <malloc.h>
+ #endif
+@@ -310,6 +317,40 @@
+ return 0;
+ }
+
++#elif defined(OGDF_SYSTEM_FREEBSD)
++
++long long System::physicalMemory()
++{
++ unsigned long value;
++ size_t size = sizeof( value );
++ if (sysctlbyname("hw.physmem", (void *)&value, &size, NULL, 0) != -1)
++ return value;
++ else
++ return 0;
++}
++
++long long System::availablePhysicalMemory()
++{
++ int pageSize = getpagesize ();
++ unsigned long result;
++ size_t size = sizeof (result);
++
++ if (sysctlbyname("vm.stats.vm.v_free_count", (void *)&result, &size, NULL, 0) != -1)
++ return result * pageSize;
++ else
++ return 0;
++}
++
++
++size_t System::memoryUsedByProcess()
++{
++ struct rusage r;
++ if (getrusage(RUSAGE_SELF, &r) != -1)
++ return r.ru_maxrss;
++ else
++ return 0;
++}
++
+ #else
+ // LINUX, NOT MAC OS
+ long long System::physicalMemory()
+@@ -396,6 +437,19 @@
+ {
+ return mstats().chunks_free;
+ }
++
++#elif defined(OGDF_SYSTEM_FREEBSD)
++
++size_t System::memoryAllocatedByMalloc()
++{
++ return 0;
++}
++
++size_t System::memoryInFreelistOfMalloc()
++{
++ return 0;
++}
++
+ #else
+
+ size_t System::memoryAllocatedByMalloc()
diff --git a/math/ogdf/pkg-descr b/math/ogdf/pkg-descr
new file mode 100644
index 000000000000..2c7419f518f4
--- /dev/null
+++ b/math/ogdf/pkg-descr
@@ -0,0 +1,13 @@
+OGDF (Open Graph Drawing Framework) is a self-contained C++ class library for
+the automatic layout of diagrams. OGDF offers sophisticated algorithms and data
+structures to use within your own applications or scientific projects.
+The library provides:
+
+* A wide range of graph drawing algorithms that allow to reuse and replace
+ particular algorithm phases by using a dedicated module mechanism.
+* Sophisticated data structures that are commonly used in graph drawing,
+ equipped with rich public interfaces.
+* Self-contained code that does not require any additional libraries
+ (except for some optional branch-and-cut algorithms).
+
+WWW: http://www.ogdf.net
diff --git a/math/ogdf/pkg-plist b/math/ogdf/pkg-plist
new file mode 100644
index 000000000000..a22833ab3f24
--- /dev/null
+++ b/math/ogdf/pkg-plist
@@ -0,0 +1,390 @@
+lib/libOGDF.so.1
+lib/libOGDF.so
+include/ogdf/augmentation/DfsMakeBiconnected.h
+include/ogdf/augmentation/PlanarAugmentation.h
+include/ogdf/augmentation/PlanarAugmentationFix.h
+include/ogdf/basic/AdjEntryArray.h
+include/ogdf/basic/Array.h
+include/ogdf/basic/Array2D.h
+include/ogdf/basic/ArrayBuffer.h
+include/ogdf/basic/Barrier.h
+include/ogdf/basic/BinaryHeap.h
+include/ogdf/basic/BinaryHeap2.h
+include/ogdf/basic/BoundedQueue.h
+include/ogdf/basic/BoundedStack.h
+include/ogdf/basic/CombinatorialEmbedding.h
+include/ogdf/basic/Constraints.h
+include/ogdf/basic/CriticalSection.h
+include/ogdf/basic/DisjointSets.h
+include/ogdf/basic/DualGraph.h
+include/ogdf/basic/EFreeList.h
+include/ogdf/basic/EList.h
+include/ogdf/basic/EdgeArray.h
+include/ogdf/basic/EdgeComparer.h
+include/ogdf/basic/EdgeComparerSimple.h
+include/ogdf/basic/FaceArray.h
+include/ogdf/basic/FaceSet.h
+include/ogdf/basic/Graph.h
+include/ogdf/basic/GraphAttributes.h
+include/ogdf/basic/GraphCopy.h
+include/ogdf/basic/GraphCopyAttributes.h
+include/ogdf/basic/GraphObserver.h
+include/ogdf/basic/Graph_d.h
+include/ogdf/basic/GridLayout.h
+include/ogdf/basic/GridLayoutMapped.h
+include/ogdf/basic/HashArray.h
+include/ogdf/basic/HashArray2D.h
+include/ogdf/basic/HashIterator2D.h
+include/ogdf/basic/Hashing.h
+include/ogdf/basic/HeapBase.h
+include/ogdf/basic/HyperGraph.h
+include/ogdf/basic/IncNodeInserter.h
+include/ogdf/basic/Layout.h
+include/ogdf/basic/List.h
+include/ogdf/basic/Logger.h
+include/ogdf/basic/Math.h
+include/ogdf/basic/MinHeap.h
+include/ogdf/basic/MinPriorityQueue.h
+include/ogdf/basic/Module.h
+include/ogdf/basic/ModuleOption.h
+include/ogdf/basic/NearestRectangleFinder.h
+include/ogdf/basic/NodeArray.h
+include/ogdf/basic/NodeComparer.h
+include/ogdf/basic/NodeSet.h
+include/ogdf/basic/PreprocessorLayout.h
+include/ogdf/basic/Queue.h
+include/ogdf/basic/SList.h
+include/ogdf/basic/Skiplist.h
+include/ogdf/basic/Stack.h
+include/ogdf/basic/String.h
+include/ogdf/basic/System.h
+include/ogdf/basic/System.h.orig
+include/ogdf/basic/Thread.h
+include/ogdf/basic/Timeouter.h
+include/ogdf/basic/TopologyModule.h
+include/ogdf/basic/UMLGraph.h
+include/ogdf/basic/basic.h
+include/ogdf/basic/basic.h.orig
+include/ogdf/basic/comparer.h
+include/ogdf/basic/exceptions.h
+include/ogdf/basic/extended_graph_alg.h
+include/ogdf/basic/geometry.h
+include/ogdf/basic/graph_generators.h
+include/ogdf/basic/memory.h
+include/ogdf/basic/precondition.h
+include/ogdf/basic/simple_graph_alg.h
+include/ogdf/basic/tuples.h
+include/ogdf/cluster/CPlanarEdgeInserter.h
+include/ogdf/cluster/CPlanarSubClusteredGraph.h
+include/ogdf/cluster/CconnectClusterPlanar.h
+include/ogdf/cluster/CconnectClusterPlanarEmbed.h
+include/ogdf/cluster/ClusterArray.h
+include/ogdf/cluster/ClusterGraph.h
+include/ogdf/cluster/ClusterGraphAttributes.h
+include/ogdf/cluster/ClusterGraphCopyAttributes.h
+include/ogdf/cluster/ClusterGraphObserver.h
+include/ogdf/cluster/ClusterOrthoLayout.h
+include/ogdf/cluster/ClusterOrthoShaper.h
+include/ogdf/cluster/ClusterPlanRep.h
+include/ogdf/cluster/ClusterPlanarizationLayout.h
+include/ogdf/cluster/ClusterSet.h
+include/ogdf/cluster/MaximumCPlanarSubgraph.h
+include/ogdf/decomposition/BCTree.h
+include/ogdf/decomposition/DynamicBCTree.h
+include/ogdf/decomposition/DynamicPlanarSPQRTree.h
+include/ogdf/decomposition/DynamicSPQRForest.h
+include/ogdf/decomposition/DynamicSPQRTree.h
+include/ogdf/decomposition/DynamicSkeleton.h
+include/ogdf/decomposition/PertinentGraph.h
+include/ogdf/decomposition/PlanarSPQRTree.h
+include/ogdf/decomposition/SPQRTree.h
+include/ogdf/decomposition/Skeleton.h
+include/ogdf/decomposition/StaticPlanarSPQRTree.h
+include/ogdf/decomposition/StaticSPQRTree.h
+include/ogdf/decomposition/StaticSkeleton.h
+include/ogdf/energybased/CoinTutteLayout.h
+include/ogdf/energybased/DavidsonHarel.h
+include/ogdf/energybased/DavidsonHarelLayout.h
+include/ogdf/energybased/FMMMLayout.h
+include/ogdf/energybased/FastMultipoleEmbedder.h
+include/ogdf/energybased/GEMLayout.h
+include/ogdf/energybased/MultilevelLayout.h
+include/ogdf/energybased/SpringEmbedderFR.h
+include/ogdf/energybased/SpringEmbedderFRExact.h
+include/ogdf/energybased/SpringEmbedderKK.h
+include/ogdf/energybased/StressMajorizationSimple.h
+include/ogdf/energybased/multilevelmixer/BarycenterPlacer.h
+include/ogdf/energybased/multilevelmixer/CirclePlacer.h
+include/ogdf/energybased/multilevelmixer/EdgeCoverMerger.h
+include/ogdf/energybased/multilevelmixer/IndependentSetMerger.h
+include/ogdf/energybased/multilevelmixer/InitialPlacer.h
+include/ogdf/energybased/multilevelmixer/LocalBiconnectedMerger.h
+include/ogdf/energybased/multilevelmixer/MMMExampleFastLayout.h
+include/ogdf/energybased/multilevelmixer/MMMExampleNiceLayout.h
+include/ogdf/energybased/multilevelmixer/MMMExampleNoTwistLayout.h
+include/ogdf/energybased/multilevelmixer/MatchingMerger.h
+include/ogdf/energybased/multilevelmixer/MedianPlacer.h
+include/ogdf/energybased/multilevelmixer/MixedForceLayout.h
+include/ogdf/energybased/multilevelmixer/ModularMultilevelMixer.h
+include/ogdf/energybased/multilevelmixer/MultilevelBuilder.h
+include/ogdf/energybased/multilevelmixer/RandomMerger.h
+include/ogdf/energybased/multilevelmixer/RandomPlacer.h
+include/ogdf/energybased/multilevelmixer/ScalingLayout.h
+include/ogdf/energybased/multilevelmixer/SolarMerger.h
+include/ogdf/energybased/multilevelmixer/SolarPlacer.h
+include/ogdf/energybased/multilevelmixer/ZeroPlacer.h
+include/ogdf/external/abacus.h
+include/ogdf/external/coin.h
+include/ogdf/fileformats/DinoLineBuffer.h
+include/ogdf/fileformats/DinoTools.h
+include/ogdf/fileformats/DinoUmlDiagramGraph.h
+include/ogdf/fileformats/DinoUmlModelGraph.h
+include/ogdf/fileformats/DinoUmlToGraphConverter.h
+include/ogdf/fileformats/DinoXmlParser.h
+include/ogdf/fileformats/DinoXmlScanner.h
+include/ogdf/fileformats/GmlParser.h
+include/ogdf/fileformats/Ogml.h
+include/ogdf/fileformats/OgmlParser.h
+include/ogdf/fileformats/SteinLibParser.h
+include/ogdf/fileformats/XmlObject.h
+include/ogdf/fileformats/XmlParser.h
+include/ogdf/fileformats/simple_graph_load.h
+include/ogdf/graphalg/CliqueFinder.h
+include/ogdf/graphalg/Clusterer.h
+include/ogdf/graphalg/ConvexHull.h
+include/ogdf/graphalg/Dijkstra.h
+include/ogdf/graphalg/GraphReduction.h
+include/ogdf/graphalg/MinCostFlowReinelt.h
+include/ogdf/graphalg/MinimumCut.h
+include/ogdf/graphalg/PageRank.h
+include/ogdf/graphalg/ShortestPathWithBFM.h
+include/ogdf/internal/augmentation/PALabel.h
+include/ogdf/internal/basic/MallocMemoryAllocator.h
+include/ogdf/internal/basic/PoolMemoryAllocator.h
+include/ogdf/internal/basic/intrinsics.h
+include/ogdf/internal/basic/list_templates.h
+include/ogdf/internal/cluster/CPlanarSubClusteredST.h
+include/ogdf/internal/cluster/ClusterPQContainer.h
+include/ogdf/internal/cluster/Cluster_ChunkConnection.h
+include/ogdf/internal/cluster/Cluster_CutConstraint.h
+include/ogdf/internal/cluster/Cluster_EdgeVar.h
+include/ogdf/internal/cluster/Cluster_MaxPlanarEdges.h
+include/ogdf/internal/cluster/KuratowskiConstraint.h
+include/ogdf/internal/cluster/MaxCPlanar_Master.h
+include/ogdf/internal/cluster/MaxCPlanar_MinimalClusterConnection.h
+include/ogdf/internal/cluster/MaxCPlanar_Sub.h
+include/ogdf/internal/cluster/basics.h
+include/ogdf/internal/energybased/AdjacencyOracle.h
+include/ogdf/internal/energybased/Attraction.h
+include/ogdf/internal/energybased/EdgeAttributes.h
+include/ogdf/internal/energybased/EnergyFunction.h
+include/ogdf/internal/energybased/FruchtermanReingold.h
+include/ogdf/internal/energybased/IntersectionRectangle.h
+include/ogdf/internal/energybased/MultilevelGraph.h
+include/ogdf/internal/energybased/NMM.h
+include/ogdf/internal/energybased/NodeAttributes.h
+include/ogdf/internal/energybased/NodePairEnergy.h
+include/ogdf/internal/energybased/Overlap.h
+include/ogdf/internal/energybased/ParticleInfo.h
+include/ogdf/internal/energybased/Planarity.h
+include/ogdf/internal/energybased/PlanarityGrid.h
+include/ogdf/internal/energybased/QuadTreeNM.h
+include/ogdf/internal/energybased/QuadTreeNodeNM.h
+include/ogdf/internal/energybased/Repulsion.h
+include/ogdf/internal/energybased/UniformGrid.h
+include/ogdf/internal/lpsolver/LPSolver_coin.h
+include/ogdf/internal/orthogonal/NodeInfo.h
+include/ogdf/internal/orthogonal/RoutingChannel.h
+include/ogdf/internal/planarity/BoyerMyrvoldInit.h
+include/ogdf/internal/planarity/BoyerMyrvoldPlanar.h
+include/ogdf/internal/planarity/ConnectedSubgraph.h
+include/ogdf/internal/planarity/EmbedIndicator.h
+include/ogdf/internal/planarity/EmbedPQTree.h
+include/ogdf/internal/planarity/EmbedderMaxFaceBiconnectedGraphs.h
+include/ogdf/internal/planarity/EmbedderMaxFaceBiconnectedGraphsLayers.h
+include/ogdf/internal/planarity/FindKuratowskis.h
+include/ogdf/internal/planarity/IndInfo.h
+include/ogdf/internal/planarity/MDMFLengthAttribute.h
+include/ogdf/internal/planarity/MaxSequencePQTree.h
+include/ogdf/internal/planarity/PQBasicKey.h
+include/ogdf/internal/planarity/PQBasicKeyRoot.h
+include/ogdf/internal/planarity/PQInternalKey.h
+include/ogdf/internal/planarity/PQInternalNode.h
+include/ogdf/internal/planarity/PQLeaf.h
+include/ogdf/internal/planarity/PQLeafKey.h
+include/ogdf/internal/planarity/PQNode.h
+include/ogdf/internal/planarity/PQNodeKey.h
+include/ogdf/internal/planarity/PQNodeRoot.h
+include/ogdf/internal/planarity/PQTree.h
+include/ogdf/internal/planarity/PlanarLeafKey.h
+include/ogdf/internal/planarity/PlanarPQTree.h
+include/ogdf/internal/planarity/PlanarSubgraphPQTree.h
+include/ogdf/internal/planarity/whaInfo.h
+include/ogdf/internal/steinertree/EdgeWeightedGraph.h
+include/ogdf/internal/steinertree/EdgeWeightedGraphCopy.h
+include/ogdf/labeling/ELabelInterface.h
+include/ogdf/labeling/ELabelPosSimple.h
+include/ogdf/labeling/EdgeLabel.h
+include/ogdf/layered/BarycenterHeuristic.h
+include/ogdf/layered/CoffmanGrahamRanking.h
+include/ogdf/layered/CrossingsMatrix.h
+include/ogdf/layered/DfsAcyclicSubgraph.h
+include/ogdf/layered/ExtendedNestingGraph.h
+include/ogdf/layered/FastHierarchyLayout.h
+include/ogdf/layered/FastSimpleHierarchyLayout.h
+include/ogdf/layered/GreedyCycleRemoval.h
+include/ogdf/layered/GreedyInsertHeuristic.h
+include/ogdf/layered/GreedySwitchHeuristic.h
+include/ogdf/layered/Hierarchy.h
+include/ogdf/layered/Level.h
+include/ogdf/layered/LongestPathRanking.h
+include/ogdf/layered/MedianHeuristic.h
+include/ogdf/layered/OptimalHierarchyClusterLayout.h
+include/ogdf/layered/OptimalHierarchyLayout.h
+include/ogdf/layered/OptimalRanking.h
+include/ogdf/layered/SiftingHeuristic.h
+include/ogdf/layered/SplitHeuristic.h
+include/ogdf/layered/SugiyamaLayout.h
+include/ogdf/lpsolver/LPSolver.h
+include/ogdf/misclayout/BalloonLayout.h
+include/ogdf/misclayout/CircularLayout.h
+include/ogdf/misclayout/ProcrustesSubLayout.h
+include/ogdf/module/AcyclicSubgraphModule.h
+include/ogdf/module/AugmentationModule.h
+include/ogdf/module/CCLayoutPackModule.h
+include/ogdf/module/CPlanarSubgraphModule.h
+include/ogdf/module/ClustererModule.h
+include/ogdf/module/CrossingMinimizationModule.h
+include/ogdf/module/EdgeInsertionModule.h
+include/ogdf/module/EmbedderModule.h
+include/ogdf/module/FUPSModule.h
+include/ogdf/module/ForceLayoutModule.h
+include/ogdf/module/GridLayoutModule.h
+include/ogdf/module/HierarchyClusterLayoutModule.h
+include/ogdf/module/HierarchyLayoutModule.h
+include/ogdf/module/LayoutClusterPlanRepModule.h
+include/ogdf/module/LayoutModule.h
+include/ogdf/module/LayoutPlanRepModule.h
+include/ogdf/module/MMCrossingMinimizationModule.h
+include/ogdf/module/MMEdgeInsertionModule.h
+include/ogdf/module/MinCostFlowModule.h
+include/ogdf/module/MixedModelCrossingsBeautifierModule.h
+include/ogdf/module/MultilevelLayoutModule.h
+include/ogdf/module/PlanarSubgraphModule.h
+include/ogdf/module/PlanarityModule.h
+include/ogdf/module/RankingModule.h
+include/ogdf/module/ShellingOrderModule.h
+include/ogdf/module/ShortestPathModule.h
+include/ogdf/module/TwoLayerCrossMin.h
+include/ogdf/module/UMLLayoutModule.h
+include/ogdf/module/UPRLayoutModule.h
+include/ogdf/module/UpwardEdgeInserterModule.h
+include/ogdf/module/UpwardPlanarSubgraphModule.h
+include/ogdf/module/UpwardPlanarizerModule.h
+include/ogdf/orthogonal/CompactionConstraintGraph.h
+include/ogdf/orthogonal/EdgeRouter.h
+include/ogdf/orthogonal/FlowCompaction.h
+include/ogdf/orthogonal/LongestPathCompaction.h
+include/ogdf/orthogonal/MinimumEdgeDistances.h
+include/ogdf/orthogonal/OrthoLayout.h
+include/ogdf/orthogonal/OrthoRep.h
+include/ogdf/orthogonal/OrthoShaper.h
+include/ogdf/packing/ComponentSplitterLayout.h
+include/ogdf/packing/TileToRowsCCPacker.h
+include/ogdf/planarity/BoothLueker.h
+include/ogdf/planarity/BoyerMyrvold.h
+include/ogdf/planarity/EdgeTypePatterns.h
+include/ogdf/planarity/EmbedderMaxFace.h
+include/ogdf/planarity/EmbedderMaxFaceLayers.h
+include/ogdf/planarity/EmbedderMinDepth.h
+include/ogdf/planarity/EmbedderMinDepthMaxFace.h
+include/ogdf/planarity/EmbedderMinDepthMaxFaceLayers.h
+include/ogdf/planarity/EmbedderMinDepthPiTa.h
+include/ogdf/planarity/ExtractKuratowskis.h
+include/ogdf/planarity/FastPlanarSubgraph.h
+include/ogdf/planarity/FixedEmbeddingInserter.h
+include/ogdf/planarity/KuratowskiSubdivision.h
+include/ogdf/planarity/MMFixedEmbeddingInserter.h
+include/ogdf/planarity/MMSubgraphPlanarizer.h
+include/ogdf/planarity/MMVariableEmbeddingInserter.h
+include/ogdf/planarity/MaximalPlanarSubgraphSimple.h
+include/ogdf/planarity/MaximumPlanarSubgraph.h
+include/ogdf/planarity/MultiEdgeApproxInserter.h
+include/ogdf/planarity/NodeTypePatterns.h
+include/ogdf/planarity/NonPlanarCore.h
+include/ogdf/planarity/PlanRep.h
+include/ogdf/planarity/PlanRepExpansion.h
+include/ogdf/planarity/PlanRepInc.h
+include/ogdf/planarity/PlanRepUML.h
+include/ogdf/planarity/PlanarizationGridLayout.h
+include/ogdf/planarity/PlanarizationLayout.h
+include/ogdf/planarity/SimpleEmbedder.h
+include/ogdf/planarity/SimpleIncNodeInserter.h
+include/ogdf/planarity/SubgraphPlanarizer.h
+include/ogdf/planarity/VariableEmbeddingInserter.h
+include/ogdf/planarity/VariableEmbeddingInserter2.h
+include/ogdf/planarlayout/BiconnectedShellingOrder.h
+include/ogdf/planarlayout/FPPLayout.h
+include/ogdf/planarlayout/MMCBBase.h
+include/ogdf/planarlayout/MMCBDoubleGrid.h
+include/ogdf/planarlayout/MMCBLocalStretch.h
+include/ogdf/planarlayout/MixedModelLayout.h
+include/ogdf/planarlayout/PlanarDrawLayout.h
+include/ogdf/planarlayout/PlanarStraightLayout.h
+include/ogdf/planarlayout/SchnyderLayout.h
+include/ogdf/planarlayout/ShellingOrder.h
+include/ogdf/planarlayout/TriconnectedShellingOrder.h
+include/ogdf/simultaneous/SimDraw.h
+include/ogdf/simultaneous/SimDrawCaller.h
+include/ogdf/simultaneous/SimDrawColorizer.h
+include/ogdf/simultaneous/SimDrawCreator.h
+include/ogdf/simultaneous/SimDrawCreatorSimple.h
+include/ogdf/simultaneous/SimDrawManipulatorModule.h
+include/ogdf/simultaneous/TwoLayerCrossMinSimDraw.h
+include/ogdf/tree/RadialTreeLayout.h
+include/ogdf/tree/TreeLayout.h
+include/ogdf/upward/DominanceLayout.h
+include/ogdf/upward/ExpansionGraph.h
+include/ogdf/upward/FUPSSimple.h
+include/ogdf/upward/FaceSinkGraph.h
+include/ogdf/upward/FeasibleUpwardPlanarSubgraph.h
+include/ogdf/upward/FixedEmbeddingUpwardEdgeInserter.h
+include/ogdf/upward/FixedUpwardEmbeddingInserter.h
+include/ogdf/upward/LayerBasedUPRLayout.h
+include/ogdf/upward/SubgraphUpwardPlanarizer.h
+include/ogdf/upward/UpwardPlanRep.h
+include/ogdf/upward/UpwardPlanarModule.h
+include/ogdf/upward/UpwardPlanarSubgraphSimple.h
+include/ogdf/upward/UpwardPlanarizationLayout.h
+include/ogdf/upward/VisibilityLayout.h
+@dirrm include/ogdf/upward
+@dirrm include/ogdf/tree
+@dirrm include/ogdf/simultaneous
+@dirrm include/ogdf/planarlayout
+@dirrm include/ogdf/planarity
+@dirrm include/ogdf/packing
+@dirrm include/ogdf/orthogonal
+@dirrm include/ogdf/module
+@dirrm include/ogdf/misclayout
+@dirrm include/ogdf/lpsolver
+@dirrm include/ogdf/layered
+@dirrm include/ogdf/labeling
+@dirrm include/ogdf/internal/steinertree
+@dirrm include/ogdf/internal/planarity
+@dirrm include/ogdf/internal/orthogonal
+@dirrm include/ogdf/internal/lpsolver
+@dirrm include/ogdf/internal/energybased
+@dirrm include/ogdf/internal/cluster
+@dirrm include/ogdf/internal/basic
+@dirrm include/ogdf/internal/augmentation
+@dirrm include/ogdf/internal
+@dirrm include/ogdf/graphalg
+@dirrm include/ogdf/fileformats
+@dirrm include/ogdf/external
+@dirrm include/ogdf/energybased/multilevelmixer
+@dirrm include/ogdf/energybased
+@dirrm include/ogdf/decomposition
+@dirrm include/ogdf/cluster
+@dirrm include/ogdf/basic
+@dirrm include/ogdf/augmentation
+@dirrm include/ogdf