aboutsummaryrefslogtreecommitdiff
path: root/math/ogdf
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-10-01 08:16:14 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-10-01 08:16:14 +0000
commit6a0181bd5ee716981005d2906738015dde719562 (patch)
tree77d2d355cb007dd95a99de77d9616dcbae77d154 /math/ogdf
parent94067d550b9f559007761e90296f8fa9ea9c4075 (diff)
downloadports-6a0181bd5ee716981005d2906738015dde719562.tar.gz
ports-6a0181bd5ee716981005d2906738015dde719562.zip
- Fix with Coin and Abacus
- Modernize framework (USE_PYTHON, @dirrm)
Notes
Notes: svn path=/head/; revision=369699
Diffstat (limited to 'math/ogdf')
-rw-r--r--math/ogdf/Makefile3
-rw-r--r--math/ogdf/files/patch-makeMakefile.config5
-rw-r--r--math/ogdf/files/patch-makeMakefile.py34
-rw-r--r--math/ogdf/files/patch-ogdf-internal-cluster_basics.h10
-rw-r--r--math/ogdf/pkg-plist31
5 files changed, 48 insertions, 35 deletions
diff --git a/math/ogdf/Makefile b/math/ogdf/Makefile
index 22106221abd4..f4433a2eef40 100644
--- a/math/ogdf/Makefile
+++ b/math/ogdf/Makefile
@@ -13,9 +13,8 @@ COMMENT= C++ class library for the automatic layout of diagrams
LICENSE= GPLv2
-USES= zip
+USES= zip python:build
USE_LDCONFIG= yes
-USE_PYTHON_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME:tu}
diff --git a/math/ogdf/files/patch-makeMakefile.config b/math/ogdf/files/patch-makeMakefile.config
index cae78f1725a1..e2ab70464631 100644
--- a/math/ogdf/files/patch-makeMakefile.config
+++ b/math/ogdf/files/patch-makeMakefile.config
@@ -24,7 +24,7 @@
#* blank means don't call ranlib
ranlibCommand = ranlib
-@@ -43,16 +43,16 @@
+@@ -43,16 +43,17 @@
[COIN]
#**********************************************************
#* set to "true" to use COIN
@@ -42,6 +42,7 @@
-# solver_incl =
+solver_name = COIN_OSI_CLP
+solver_incl = %%LOCALBASE%%/include
++solver_lib = %%LOCALBASE%%/lib/libClp.so
#* Coin's Symphony
# solver_name = COIN_OSI_SYM
# solver_incl = /home/plug/COIN/SYMPHONY/include
@@ -56,4 +57,4 @@
+useAbacus = %%USE_ABACUS%%
+abacusDef = -DABACUS_COMPILER_GCC
+abacusIncl = %%LOCALBASE%%/inclue/abacus
-+abacusLib = -L%%LOCALBASE%%/lib -labacus-osi
++abacusLib = %%LOCALBASE%%/lib/libabacus-osi.so
diff --git a/math/ogdf/files/patch-makeMakefile.py b/math/ogdf/files/patch-makeMakefile.py
new file mode 100644
index 000000000000..eed4b7e2f9e5
--- /dev/null
+++ b/math/ogdf/files/patch-makeMakefile.py
@@ -0,0 +1,34 @@
+--- makeMakefile.py.orig 2012-07-18 09:17:42.000000000 +0200
++++ makeMakefile.py 2014-02-07 17:28:44.000000000 +0100
+@@ -82,7 +82,7 @@
+ libs = ''
+
+ if sharedLib:
+- compiler = ' '.join( [compiler, '-DOGDF_DLL -DOGDF_INSTALL' ] )
++ compiler = ' '.join( [compiler, '-DOGDF_INSTALL' ] )
+ if sys.platform == 'win32' or sys.platform == 'cygwin':
+ libs = ' '.join( [libs, '-lpsapi'] )
+ else:
+@@ -97,17 +97,20 @@
+ # coinLib = loadConfig('COIN', 'coinLib')
+ solver_name = loadConfig('COIN', 'solver_name')
+ solver_incl = loadConfig('COIN', 'solver_incl')
+- # solver_lib = loadConfig('COIN', 'solver_lib')
++ solver_lib = loadConfig('COIN', 'solver_lib')
+ si2 = ' '
+ if solver_incl.strip() != '':
+ si2 = '-I'+solver_incl
++ if solver_lib.strip() != '':
++ libs = ' '.join( [libs, solver_lib] )
+ compiler = ' '.join( [ compiler, '-I'+coinIncl, si2, '-D'+solver_name, '-DUSE_COIN', ' ' ] )
+
+ useAbacus = loadConfig('ABACUS', 'useAbacus').startswith('t')
+ if useAbacus:
+ abacusDef = loadConfig('ABACUS', 'abacusDef')
+ abacusIncl = loadConfig('ABACUS', 'abacusIncl')
+- # abacusLib = loadConfig('ABACUS', 'abacusLib')
++ abacusLib = loadConfig('ABACUS', 'abacusLib')
++ libs = ' '.join( [libs, abacusLib] )
+ compiler = ' '.join( [ compiler, abacusDef, '-I'+abacusIncl, '-DUSE_ABACUS', ' ' ] )
+
+ versions = []
diff --git a/math/ogdf/files/patch-ogdf-internal-cluster_basics.h b/math/ogdf/files/patch-ogdf-internal-cluster_basics.h
new file mode 100644
index 000000000000..71ccfe15010b
--- /dev/null
+++ b/math/ogdf/files/patch-ogdf-internal-cluster_basics.h
@@ -0,0 +1,10 @@
+--- ogdf/internal/cluster/basics.h.orig 2014-10-01 10:12:06.000000000 +0200
++++ ogdf/internal/cluster/basics.h 2014-10-01 10:12:37.000000000 +0200
+@@ -47,6 +47,7 @@
+ #define OGDF_CPLANAR_BASICS_H
+
+ #include <abacus/master.h>
++#include <abacus/constraint.h>
+ #include <ogdf/basic/Graph_d.h>
+ #include <ogdf/cluster/ClusterGraph.h>
+ #include <ogdf/cluster/ClusterGraphAttributes.h>
diff --git a/math/ogdf/pkg-plist b/math/ogdf/pkg-plist
index a22833ab3f24..6375871dbb0b 100644
--- a/math/ogdf/pkg-plist
+++ b/math/ogdf/pkg-plist
@@ -357,34 +357,3 @@ include/ogdf/upward/UpwardPlanarModule.h
include/ogdf/upward/UpwardPlanarSubgraphSimple.h
include/ogdf/upward/UpwardPlanarizationLayout.h
include/ogdf/upward/VisibilityLayout.h
-@dirrm include/ogdf/upward
-@dirrm include/ogdf/tree
-@dirrm include/ogdf/simultaneous
-@dirrm include/ogdf/planarlayout
-@dirrm include/ogdf/planarity
-@dirrm include/ogdf/packing
-@dirrm include/ogdf/orthogonal
-@dirrm include/ogdf/module
-@dirrm include/ogdf/misclayout
-@dirrm include/ogdf/lpsolver
-@dirrm include/ogdf/layered
-@dirrm include/ogdf/labeling
-@dirrm include/ogdf/internal/steinertree
-@dirrm include/ogdf/internal/planarity
-@dirrm include/ogdf/internal/orthogonal
-@dirrm include/ogdf/internal/lpsolver
-@dirrm include/ogdf/internal/energybased
-@dirrm include/ogdf/internal/cluster
-@dirrm include/ogdf/internal/basic
-@dirrm include/ogdf/internal/augmentation
-@dirrm include/ogdf/internal
-@dirrm include/ogdf/graphalg
-@dirrm include/ogdf/fileformats
-@dirrm include/ogdf/external
-@dirrm include/ogdf/energybased/multilevelmixer
-@dirrm include/ogdf/energybased
-@dirrm include/ogdf/decomposition
-@dirrm include/ogdf/cluster
-@dirrm include/ogdf/basic
-@dirrm include/ogdf/augmentation
-@dirrm include/ogdf